We have moved at community.getvera.com

Author Topic: Vera Plus (working beautifully, then chose fw update - now just power light)  (Read 17288 times)

Offline Grwebster

  • Sr. Member
  • ****
  • Posts: 388
  • Karma: +7/-4
This is one continuous issue that Vera absolutely needs to fix.  My unit bricked again on an update.   This is a major issue with their platform.  I am a computer geek, and even I hate the thought of having to connect my laptop and ssh?ing in to fix it.  Typical users would be lost.  It?s not great that upgrades often result in a bricked device, but it is made worse by the painful recovery method.

Sent from my iPad using Tapatalk

Offline fyford

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +0/-1
Right so I got a call from a chap called 'Angel' from support, (phoning from Columbia). I turned out that the latest update is a tad larger than previous ones and it maxed out my spare space on the VeraPlus. (This has a total of 8MB for all apps and the firmware).

Angel cleared my cache which was tricky as he had to do this from SSH before the whole system started up properly, as it would stall and run out of space once properly up and running. So yes this took a few restarts from scratch and then a race against time once we could get into SSH to clear off what we could. ALTUI took up the most space and I was told to not use that.. He explained that Vera is working on some new firmware which would give some more space in the plugin directory.

Once we got some space we rolled back to a previous backup ( I did not know they keep backups of our configs on their server) and he created a scene that runs daily with LUUP below to clear cache:

 {    os.execute("rm /etc/cmh/ergy_cache*")     }

I'm now back up and running the latest firmware, I lost connections to various hardware with 'Can't Detect Device' errors. I have removed one of these (fibraro 3 in 1 sensor), unpaired, reset and re-paired it, but I still get the error.

As a last note, I migrated from an Edge to a Plus, doing that caused the Edge's SSH password to migrate over as well!

Hope this helps someone out there.

Offline Tillsy

  • Full Member
  • ***
  • Posts: 208
  • Karma: +13/-5
Vera is far more fundamentally flawed than that.  This latest firmware is just the tip of the iceberg.

I only bought my Vera in February.  The firmware at the time bricked it straight out of the box.  Brand new Vera.  Brand new customer.  Bricked.  Immediately.  Lots of us.  And, well known issue... it had been going on for a while, and they later issued a firmware update that specifically addressed this.  So well done having a product out on the market that did this.

Then, over a period of a few months, it slowly screwed itself on its own.  I have not installed this new firmware, I'm not that stupid after what I had already been through straight out of the box.  It simply killed itself.  Turned out system exhaustion.  No "larger firmware", it is already a crippled enough device to do that on its own.

Like you, once we got the thing going they restored me from a backup at their end.  Except they stuffed up doing the encryption keys, so like you Fibaro devices all failed because they all do "secure" inclusions.  I worked that out, they failed to realise this... for multiple fix attempts, each time making things worse and worse, until eventually acknowledging they did it wrong and offered to fix properly.  But never have, they changed their mind and just want to keep kicking the thing.

And now my Vera, all on its own only a few weeks later instead of months, has gone offline again.

This product is deeply, deeply, deeply flawed - and they've known this for at minimum the whole five months since I bought my "already known to brick itself straight out of the box" product back in February.

Yes, they are starting to acknowledge that selling specifications from 1999 in the year 2018 is not cutting the mustard, but right now like in February they are continuing to let more and more and more customers install a firmware that makes this worse and worse and worse.  Also as I said I, like many others, haven't even installed this firmware yet given a bit of time the same system exhaustion still happens.

Yeah sure we can blame plugins galore.  Except I don't run anything big like AltUI, in fact I only have a single plugin - DelayLight... plus a heap of devices.  That's it.  Can't ask for a cleaner or simpler setup.

Look at the threads all over this forum with people going down left, right, and centre... some over time because it'll just crap out anyway, or happening immediately because of the new firmware.  In the very least withdraw that darned firmware for heavens sake...

I am very saddened that, right before things turned to crap (as in the death spiral began, there were always multiple issues with Vera), I bought a second one for my holiday (vacation) home.  Though ironically I just grabbed a Vera Edge for that as there isn't much there, and so far (TOUCH WOOD, OMG don't curse that one now) I haven't had a single glitch with that baby... so the Plus definitely has added payload (probably from all the extra stuff that doesn't even work anyway like Bluetooth, Zigbee, etc)...

Offline Grwebster

  • Sr. Member
  • ****
  • Posts: 388
  • Karma: +7/-4
Any tips or tricks I can try?  I had boxed away my vera plus for quite some time (kids were just messing with doors and windows that I had monitoring on). I pulled it out to get back into it.  I plugged it back in everything lit up and I wad able to access it via vera mobile.  I could see everything was there just as I had left it.  My cameras were online and everything was happy.  I noticed it was requesting a fw update via my desktop browser. I told it to upgrade.  It gave me the this could take 15 minutes.  Well I let it sit for 30-40 minutes and it never came back online.  I have power cycled it but nothing.  I sent an email to support but hoping there is something I can do to resolve the issue myself.  Any help is much appreciated.
You have to reboot and get it into ssh mode, then send it a few commands to get it cleared up.  The you?ll have to restore assuming you have a back-up.  Let me know if you don?t get any instructions and I will,find and paste them here.

Sent from my iPad using Tapatalk

Offline pwelten

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Please DO paste them here ASAP.