Author Topic: VeraLite can't upgrade, can't reset  (Read 499 times)

Offline Dolphran

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +1/-0
VeraLite can't upgrade, can't reset
« on: December 21, 2017, 09:06:04 am »
My VeraLite has had all of it's devices and plugins removed. (I moved over to a VeraPlus). I wanted to try the latest upgrade on the VeraLite before trying it on my working VeraPlus. The VeraLite says it can't upgrade because: Available Space:  6728 KB
Required Space:  7560 KB. There is nothing installed on this VeraLite! All devices and plug-ins have been removed! So I decided to just hard reset the VeraLite to get rid of whatever phantoms are using all the memory space. No Luck! The reset button does nothing - I tried all the variations I could find in threads (double click, 6-click, click and hold, double click and hold), and none had any affect. So I SSH into the box and run all. It reboots the device, but nothing is reset. Same memory as before. Found a thread on editing that script. I did that, ran it, and still no effect. Sometimes I really, really hate MCV.

Offline Dolphran

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +1/-0
Re: VeraLite can't upgrade, can't reset
« Reply #1 on: December 21, 2017, 09:54:19 am »
FWIW, here's the mem usage report on the VeraLite:
root@MiOS_xxxxxxxx:~# cat /proc/meminfo
MemTotal:          62480 kB
MemFree:           25500 kB
Buffers:             188 kB
Cached:            18828 kB
SwapCached:            0 kB
Active:            13648 kB
Inactive:          11844 kB
Active(anon):       6988 kB
Inactive(anon):       68 kB
Active(file):       6660 kB
Inactive(file):    11776 kB
Unevictable:           0 kB
Mlocked:               0 kB
SwapTotal:             0 kB
SwapFree:              0 kB
Dirty:                 0 kB
Writeback:             0 kB
AnonPages:          6488 kB
Mapped:             6052 kB
Shmem:               580 kB
Slab:               7120 kB
SReclaimable:       1560 kB
SUnreclaim:         5560 kB
KernelStack:         568 kB
PageTables:          448 kB
NFS_Unstable:          0 kB
Bounce:                0 kB
WritebackTmp:          0 kB
CommitLimit:       31240 kB
Committed_AS:      55196 kB
VmallocTotal:    1048372 kB
VmallocUsed:         880 kB
VmallocChunk:    1022032 kB

Offline Don Phillips

  • Hero Member
  • *****
  • Posts: 1463
  • Karma: +41/-36
Re: VeraLite can't upgrade, can't reset
« Reply #2 on: December 21, 2017, 07:36:00 pm »
Try to reset it to factory defaults, that is what I have to do with my 3:
Vera 3, 1.7.1040, CT101, Everspring Motion, GE/Jasco Switch/Dimmer, Leviton outlet, AeonLabs sensor, NuTone garage door, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual/Multi Switch, LB60Z-1 bulb, Hue, Alexa, Zooz 4-1

Offline RichardTSchaefer

  • Community Beta
  • Master Member
  • ******
  • Posts: 10091
  • Karma: +764/-143
Re: VeraLite can't upgrade, can't reset
« Reply #3 on: December 21, 2017, 07:46:00 pm »
You are looking at run-time memory ... it's running out of memory used as disk space (kind of like a thumb drive ... but internal)

I think the size of the UI7 image had become two big to user their default install.

The default install requires 2 copies of everything ... the Old Version and the New Version, then they copy the new Version files to the old Version.
The Customer Support team can do a manual upgrade that does not require moving the whole new version over first ... but it's a more manual process. Pretty much UI7 has outgrown the capabilities of the Vera Lite.

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1132
  • Karma: +103/-11
Re: VeraLite can't upgrade, can't reset
« Reply #4 on: December 22, 2017, 12:13:30 pm »
Customer Care team can help as well. See my signature for details.
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ ▾ ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7