Author Topic: "Unset" a variable / re-enable automatic updating ?  (Read 294 times)

Offline rge

  • Full Member
  • ***
  • Posts: 104
  • Karma: +10/-1
"Unset" a variable / re-enable automatic updating ?
« on: December 28, 2017, 06:09:38 am »
I stupidly manually set the battery level on a device (from the Variables screen), and now it doesn't update automatically...

Is there any way to fix this without reinstalling the device completely?

I tried looking through user_data.json to find some sort of flag indicating "don't automatically update" but that variable doesn't look any different to other battery variables that work fine :-(

Thanks for any help.

Offline akbooer

  • Master Member
  • *******
  • Posts: 6123
  • Karma: +274/-69
  • "Less is more"
Re: "Unset" a variable / re-enable automatic updating ?
« Reply #1 on: December 28, 2017, 07:44:32 am »
This would be surprising (as with so many other things in Vera.) Indeed, there is no such flag in device variables.  It does rather depend on the characteristics of the particular device.  I have one temperature sensor which only reports battery levels in 10% increments, so hasn't updated for over a year!

You might try simply replacing the battery, and hope that this will force an update.
3x Vera Lite-UI5/Edge-UI7, 25x Fibaro, 23x TKB, 9x MiniMote, 2x NorthQ Power, 2x Netatmo, 1x Foscam FI9831P, 9x Philips Hue,
Razberry, MySensors Arduino, HomeWave, AltUI, AltHue, DataYours, Grafana, openLuup, ZWay, ZeroBrane Studio.

Offline rge

  • Full Member
  • ***
  • Posts: 104
  • Karma: +10/-1
Re: "Unset" a variable / re-enable automatic updating ?
« Reply #2 on: December 28, 2017, 07:51:56 am »
I've replaced the battery, it doesn't make any difference.

Strangely, the time reported in the corresponding battery update field always matches the time of the JSON file, it's like something in LUUP is constantly updating it.