Author Topic: Alexa wont discover devices  (Read 238 times)

Offline pbrisebois

  • Jr. Member
  • **
  • Posts: 70
  • Karma: +0/-0
Alexa wont discover devices
« on: December 28, 2017, 06:10:44 pm »
Hi Everyone,

I am currently trying to get my new Echo Plus (Canadian Version) to run my Vera lights and scenes. What I am using is a Windows PC, running HA-Bridge 5.1.0, I also updated to the newest version of Java and the inbound firewall is configured to allow Java through. I also created a batch file with the following line: java -jar -Dserver.port=8080 ha-bridge.jar.

When I start the batch file, then open Google Chrome, I type in my windows pc IP address (192.168.2.159:8080) and HA Bridge starts fine. I am also able to go into the Bridge Control tab and configure my vera. When I save (or Bridge Reinitialize) I do get the Vera Devices and Vera Scenes at the top. As well, I am able to pick one of my lights (in Vera Devices), build item and the light now shows in the Bridge Devices tab. I am also able to test by turning the light on and off.....works great up to this point. However, when I ask Alexa to discover devices (or try manually via the web browser or my android app), Alexa does not find the device?

I did try other ports that were not used (I tried 8081 and 8085), I also tried an older version HA Bridge jar file (3.5.1)........and still nothing seems to work. I also checked if uPnP was enabled on my router, it is enabled.

Is there something that I am missing here or doing wrong?
« Last Edit: January 15, 2018, 09:35:29 am by Sorin M. »

Offline Dingin

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Alexa wont discover devices
« Reply #1 on: January 12, 2018, 08:27:24 pm »
Logout of the vera controller on the webpage, then log in again and before you go to your controller check the right top on the page there is a menu, and in there it says manage Alexa,  there you give it permission to access devices.
hope it helps

Offline hellovn

  • Full Member
  • ***
  • Posts: 233
  • Karma: +19/-46
Re: Alexa wont discover devices
« Reply #2 on: January 14, 2018, 08:36:30 am »
You seem to have done everything correctly. If your Alexa & habridge are on the same network, they should see each other.

Offline iflatow

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Alexa wont discover devices
« Reply #3 on: January 15, 2018, 09:47:17 am »
My Echo Dot as working successfully for months with Vera, discovering devices and responding to commands to turn them off and on.

Now it has stopped responding. As I've added new devices to Vera, Alexa does not find them. Nor does it find new scenes.  And if fact, it still "remembers" old scenes that I have deleted and which it adds back.

How do I restore to "normal" operation?

Offline thief

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Alexa wont discover devices
« Reply #4 on: January 16, 2018, 04:43:32 am »
Put this here as a reminder..


Offline iflatow

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Alexa wont discover devices
« Reply #5 on: January 16, 2018, 02:29:13 pm »
Thief,
Thanks for that photo of the opening screen.  I had no idea it was even there!  It helped....

Offline thief

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Alexa wont discover devices
« Reply #6 on: January 16, 2018, 03:53:46 pm »
You are so welcome :)