Author Topic: Configuring Google Calendar  (Read 609 times)

Offline paros

  • Full Member
  • ***
  • Posts: 205
  • Karma: +6/-1
Configuring Google Calendar
« on: January 02, 2018, 02:20:29 pm »
Need help to setup the calendar.
I have followed the manual and finished the "Setting up a Google V3 API Service Account" (service account created).
The user rights for the new user is set in the online google calendar.
I have installed the app and am trying to configure the calendar.
I am using the standard name of the json file and have uploaded it to Vera.
I paste the ID: <iframe src="https://calendar.google.com/calendar/embed?src=changed%40gmail.com&ctz=Europe%2FStockholm" style="border: 0" width="800" height="600" frameborder="0" scrolling="no"></iframe>
Then Press "Set"

First it say: see attached file.
Later it say "** ** No more events today"

However, I have several meetings in the calendar for the current day?!
« Last Edit: January 02, 2018, 02:38:24 pm by paros »

Offline paros

  • Full Member
  • ***
  • Posts: 205
  • Karma: +6/-1
Re: Configuring Google Calendar
« Reply #1 on: January 02, 2018, 02:44:51 pm »
Need help to setup the calendar.
I have followed the manual and finished the "Setting up a Google V3 API Service Account" (service account created).
The user rights for the new user is set in the online google calendar.
I have installed the app and am trying to configure the calendar.
I am using the standard name of the json file and have uploaded it to Vera.
I paste the ID: <iframe src="https://calendar.google.com/calendar/embed?src=changed%40gmail.com&ctz=Europe%2FStockholm" style="border: 0" width="800" height="600" frameborder="0" scrolling="no"></iframe>
Then Press "Set"

First it say: see attached file.
Later it say "** ** No more events today"

However, I have several meetings in the calendar for the current day?!

Tried with the testfiles from "Documentation" and getting error: see attached file 2

Offline pls90

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +2/-0
Re: Configuring Google Calendar
« Reply #2 on: January 02, 2018, 09:23:39 pm »
I am also having troubles setting this up on openluup.
For me it is working with the test credentials, but not with my own.
After a while I realized that the client_mail I added under "share with specific people" in the calendar settings just disappears.
When arming the device I always get "Http error code: 403" which hints that there are permission issues.
How do I make the client_mail "stick" under my calendar settings?
« Last Edit: January 02, 2018, 09:25:28 pm by pls90 »

Offline paros

  • Full Member
  • ***
  • Posts: 205
  • Karma: +6/-1
Re: Configuring Google Calendar
« Reply #3 on: January 03, 2018, 02:48:13 am »
I am also having troubles setting this up on openluup.
For me it is working with the test credentials, but not with my own.
After a while I realized that the client_mail I added under "share with specific people" in the calendar settings just disappears.
When arming the device I always get "Http error code: 403" which hints that there are permission issues.
How do I make the client_mail "stick" under my calendar settings?

I understand what you mean.
Change back to "Classic mode"- here you only have "Share with specific people" - here the shared address is still saved.
In the "new" UI there is both "Access permissions" and "Share with specific people" - here the shared address is disappearing?


However, the calendar is empty for me?!
I created a new device from AltUI and it showing the same..

Offline paros

  • Full Member
  • ***
  • Posts: 205
  • Karma: +6/-1
Re: Configuring Google Calendar
« Reply #4 on: January 03, 2018, 03:00:50 am »
I tried again with the test file provided in the documentation and now I getting this error.
The file (GCal3Test.json) is already uploaded and I can see it under luup files.
« Last Edit: January 03, 2018, 03:02:53 am by paros »

Offline pls90

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +2/-0
Re: Configuring Google Calendar
« Reply #5 on: January 03, 2018, 06:49:06 am »
Thank you for pointing out the different settings pages for new/old calendar layout.
Switching back to old design actually brought up the client_email address I had entered which was not showing in new design (still some kind of bug in new design?).
Regarding my error message (Http error code: 403) it didn't make any difference though.
What looks fishy is the fact that I have set gc_debug to 3 but the log file (31-GCal3.log) has 0 bytes.
Is anyone running the plugin on openLuup successfully and willing to share their permissions that are set for the GCal files / directories? Thank you.
« Last Edit: January 03, 2018, 06:53:45 am by pls90 »

Offline jswim788

  • Hero Member
  • *****
  • Posts: 787
  • Karma: +57/-2
Re: Configuring Google Calendar
« Reply #6 on: January 03, 2018, 12:35:06 pm »
I run it successfully on openLuup.  GCal3 directory has:

Code: [Select]
GCal3:
total 12
-rw-r--r-- 1 openluup openluup  487 Jan  3 09:01 11GCalVariables
-rw-r--r-- 1 openluup openluup 1704 Dec 31 09:34 GCal3.pem
-rw-r--r-- 1 openluup openluup 2314 Nov  5  2016 GCal3.json

GCal3 under /etc/cmh-ludl:
Code: [Select]
drwxr-xr-x 2 openluup openluup  4096 Dec 31 09:34 GCal3What's in your openLuup log when you restart openLuup?

Offline pls90

  • Sr. Member
  • ****
  • Posts: 308
  • Karma: +2/-0
Re: Configuring Google Calendar
« Reply #7 on: January 03, 2018, 04:21:56 pm »
@jswim788, great, thank you! I did fumble with permissions a bit and got it working.
Alas, I quite don't know which one it was that made the difference in the end.
Now I will have do a bit of reading how to put this to use  :)

Offline kalavo

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Configuring Google Calendar
« Reply #8 on: May 06, 2018, 09:59:04 pm »
Ran in to the same issue and even more frustrated that there wasn't an answer in this thread!

So for those of you who can't figure out why you're getting Error 403 after following the instructions...

Visit https://console.developers.google.com/apis/ and add the Google Calendar API to your project!

Online Stuart

  • Moderator
  • Hero Member
  • *****
  • Posts: 681
  • Karma: +69/-2
Re: Configuring Google Calendar
« Reply #9 on: May 16, 2018, 11:18:02 am »
Ran in to the same issue and even more frustrated that there wasn't an answer in this thread!

So for those of you who can't figure out why you're getting Error 403 after following the instructions...

Visit https://console.developers.google.com/apis/ and add the Google Calendar API to your project!

Along the way -(likely when google changed the UI last) -- the service account instructions omitted the need to enable the Google Calendar API.
I have added it back in (as the first step).  Thanks for pointing it out.