Author Topic: iPhone Credentials not being saved (Resolved)  (Read 472 times)

Offline jimmyhtz

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +2/-2
iPhone Credentials not being saved (Resolved)
« on: January 09, 2018, 07:42:40 pm »
I have been working on this for weeks now trying to figure it out before asking for help.

All started when wife changed password for her iCloud.
I entered in the new password and it finds her devices.  I move the one I wanted tracked.  (there is no save button that I can see)
When I back out of the settings and hit 'Save Changes' (also doesn't work when I don't hit save changes.
It says:
No Devices for this account, check network/credentials 2018-01-09 16:25 / 120 s 0.01 Mm @ 0.00 Mm/h on 2017-12-27 16:18 v2.41
When I go back into the Credentials, It has saved the iCloud Email, but not the password, and the Devices are not shown.

I have:
Downloaded and installed your beta update
Cleared browser info and cookies.
Used a different Browser.   (I normally use Chrome and I tried with Explorer which I never use)
Created a new Device and tried with that (I cannot enter in my credentials or my wife's)
Reentering my credentials on my device creates the same issue
Made a backup, reset the entire Vera Plus from scratch and then only installed iPhone Locater)
Didn't work so I restored my system.
Contacted Vera and they said my Vera Plus was working normally.

Once in a while, I get this (see attached)

I am completely stuck until I get this resolved since my entire home network works on this working.

I thank you in advance

« Last Edit: January 10, 2018, 05:36:03 pm by jimmyhtz »

Offline amg0

  • Moderator
  • Master Member
  • *****
  • Posts: 3087
  • Karma: +206/-8
Re: iPhone Credentials not being saved
« Reply #1 on: January 10, 2018, 01:43:23 am »
I have been working on this for weeks now trying to figure it out before asking for help.

All started when wife changed password for her iCloud.
I entered in the new password and it finds her devices.  I move the one I wanted tracked.  (there is no save button that I can see)
When I back out of the settings and hit 'Save Changes' (also doesn't work when I don't hit save changes.
It says:
No Devices for this account, check network/credentials 2018-01-09 16:25 / 120 s 0.01 Mm @ 0.00 Mm/h on 2017-12-27 16:18 v2.41
When I go back into the Credentials, It has saved the iCloud Email, but not the password, and the Devices are not shown.

I have:
Downloaded and installed your beta update
Cleared browser info and cookies.
Used a different Browser.   (I normally use Chrome and I tried with Explorer which I never use)
Created a new Device and tried with that (I cannot enter in my credentials or my wife's)
Reentering my credentials on my device creates the same issue
Made a backup, reset the entire Vera Plus from scratch and then only installed iPhone Locater)
Didn't work so I restored my system.
Contacted Vera and they said my Vera Plus was working normally.

Once in a while, I get this (see attached)

I am completely stuck until I get this resolved since my entire home network works on this working.

I thank you in advance

please confirm all versions numbers:
- Vera
- UI
- IPhoneLocator


then enable debug mode on IPhoneLocator and do a luup reload
after the reload , go to IPhoneLocator settings and try again entering the user name / pwd and refresh the list of devices
once that is all done,  go capture the log file on /var/log/cmh and send it to me by private mail. I will send you a email address by PM

Offline jimmyhtz

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +2/-2
Re: iPhone Credentials not being saved
« Reply #2 on: January 10, 2018, 04:48:24 pm »
Thank you for responding

Vera Plus
Application Version: 1.7.3453
UI7
v2.41

I just received an email from Vera Support.
I will see if this fixes my issue first before sending you the logs.

"Johnny replied:
Hello Jim,

This is happening wehn the unit does not have enough free space into the /overly partition to run the Vera?s engine. In order to make some free space on the unit, please try to create a scene that will delete the ergy cache file of the plug-in.

To do this, go to Scenes > Add scene > Schedule > Weekly > select the hour and the day when you want to trigger the scene in order to delete the cache file from the unit > Validate > Next Step > Next Step > in the 3rd Step, click on ?No Luup Code defined? and put the luup code below, then click on ?Save lua? > Give a name for the scene and then click on Finish

os.execute(?rm -rf /overlay/etc/cmh/ergy_cache_paired_devices.conf?)

If you still are experiencing the same matter, please enable tech support on the unit and pass me here the remote access code so I can take a look to see what is going on.
(E.g. xxxxxxxx-xxxxxx (ssh: SSH_22=xxxxx TS_SRV=us-ts xx))

Thank you!

Regards,

Johnny ▾Customer Care Engineer

Vera Control, Ltd. ▾ Smarter Home Control"

Offline jimmyhtz

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +2/-2
Re: iPhone Credentials not being saved (Resolved)
« Reply #3 on: January 10, 2018, 05:43:18 pm »
OK.... I called Vera Tech Support actually got someone on the first ring.

There is something really effed up with the new Firmware update.  I wasn't able to get the Luup code they sent me (above) working until I rebooted the Vera Plus.

We downgraded the Firmware to 1.7.3232

Also, I was backing up and restoring my Vera Plus so much that I failed to notice that I had iPhone Locator 2.41 instead of 2.43.  I fixed that.

The iPhone Devices still didn't work so I deleted the devices and created new ones. 
(My next step if that didn't work was to delete the App and reinstall it.  But that was unnecessary)
And now I am back in business.

I asked for help here one day too early after pulling my hair out for nearly two weeks.
I hope someone else who has the same issues as me can apply same fix I did here.
Jim

Offline KhMerA

  • Sr. Newbie
  • *
  • Posts: 31
  • Karma: +0/-0
Re: iPhone Credentials not being saved (Resolved)
« Reply #4 on: January 19, 2018, 03:45:48 pm »
OK.... I called Vera Tech Support actually got someone on the first ring.

There is something really effed up with the new Firmware update.  I wasn't able to get the Luup code they sent me (above) working until I rebooted the Vera Plus.

We downgraded the Firmware to 1.7.3232

Also, I was backing up and restoring my Vera Plus so much that I failed to notice that I had iPhone Locator 2.41 instead of 2.43.  I fixed that.

The iPhone Devices still didn't work so I deleted the devices and created new ones. 
(My next step if that didn't work was to delete the App and reinstall it.  But that was unnecessary)
And now I am back in business.

I asked for help here one day too early after pulling my hair out for nearly two weeks.
I hope someone else who has the same issues as me can apply same fix I did here.
Jim

Jim, I got the same problem, cannot save after entering iCloud credential. I will try your method later when I get home . By the way, is there any reason for you to downgraded the Firmware to 1.7.3232?


Offline amg0

  • Moderator
  • Master Member
  • *****
  • Posts: 3087
  • Karma: +206/-8
Re: iPhone Credentials not being saved (Resolved)
« Reply #5 on: January 19, 2018, 06:48:34 pm »
OK.... I called Vera Tech Support actually got someone on the first ring.

There is something really effed up with the new Firmware update.  I wasn't able to get the Luup code they sent me (above) working until I rebooted the Vera Plus.

We downgraded the Firmware to 1.7.3232

Also, I was backing up and restoring my Vera Plus so much that I failed to notice that I had iPhone Locator 2.41 instead of 2.43.  I fixed that.

The iPhone Devices still didn't work so I deleted the devices and created new ones. 
(My next step if that didn't work was to delete the App and reinstall it.  But that was unnecessary)
And now I am back in business.

I asked for help here one day too early after pulling my hair out for nearly two weeks.
I hope someone else who has the same issues as me can apply same fix I did here.
Jim

Jim, I got the same problem, cannot save after entering iCloud credential. I will try your method later when I get home . By the way, is there any reason for you to downgraded the Firmware to 1.7.3232?

I fixed a problem and put a beta version 2.44 on https://github.com/amg0/IPhoneLocator
you can try it and let me know. I will publish it to mios app store afterward

Offline jimmyhtz

  • Jr. Member
  • **
  • Posts: 75
  • Karma: +2/-2
Re: iPhone Credentials not being saved (Resolved)
« Reply #6 on: January 19, 2018, 07:41:19 pm »
OK.... I called Vera Tech Support actually got someone on the first ring.

There is something really effed up with the new Firmware update.  I wasn't able to get the Luup code they sent me (above) working until I rebooted the Vera Plus.

We downgraded the Firmware to 1.7.3232

Also, I was backing up and restoring my Vera Plus so much that I failed to notice that I had iPhone Locator 2.41 instead of 2.43.  I fixed that.

The iPhone Devices still didn't work so I deleted the devices and created new ones. 
(My next step if that didn't work was to delete the App and reinstall it.  But that was unnecessary)
And now I am back in business.

I asked for help here one day too early after pulling my hair out for nearly two weeks.
I hope someone else who has the same issues as me can apply same fix I did here.
Jim

Jim, I got the same problem, cannot save after entering iCloud credential. I will try your method later when I get home . By the way, is there any reason for you to downgraded the Firmware to 1.7.3232?

I fixed a problem and put a beta version 2.44 on https://github.com/amg0/IPhoneLocator
you can try it and let me know. I will publish it to mios app store afterward

I am not sure if I am doing this right.

I saw the two files you just added, but when I clicked on the files expecting a download, I only saw the code.
I didn't see a download button.  Is there one?

I downloaded both files into text files of the same name and then removed the .txt extention, then uploaded, but I received an error.

Offline Jakadia

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
Re: iPhone Credentials not being saved (Resolved)
« Reply #7 on: January 23, 2018, 01:21:52 pm »
OK.... I called Vera Tech Support actually got someone on the first ring.

There is something really effed up with the new Firmware update.  I wasn't able to get the Luup code they sent me (above) working until I rebooted the Vera Plus.

We downgraded the Firmware to 1.7.3232

Also, I was backing up and restoring my Vera Plus so much that I failed to notice that I had iPhone Locator 2.41 instead of 2.43.  I fixed that.

The iPhone Devices still didn't work so I deleted the devices and created new ones. 
(My next step if that didn't work was to delete the App and reinstall it.  But that was unnecessary)
And now I am back in business.

I asked for help here one day too early after pulling my hair out for nearly two weeks.
I hope someone else who has the same issues as me can apply same fix I did here.
Jim

Jim, I got the same problem, cannot save after entering iCloud credential. I will try your method later when I get home . By the way, is there any reason for you to downgraded the Firmware to 1.7.3232?

I fixed a problem and put a beta version 2.44 on https://github.com/amg0/IPhoneLocator
you can try it and let me know. I will publish it to mios app store afterward

I also downloaded these files, uploaded them to overwrite the existing ones in my Luup files list, and forced my Luup to restart.  I am still not getting the save button - am I doing something wrong?