We have moved at community.getvera.com

Author Topic: 2 Vera Plus controllers bricked after initial setup and firmware upgrade.. help  (Read 3712 times)

Offline tomaszm1976

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0

I bought Vera Plus with firmware Version 1.7.1786. during initial setup, after adding to account it started Firmware upgrade. nothing happened.
the unit is not not responding with only Power LED on. ocassionally Wi-Fi would come on for few seods and then the unit appears to be rebooting back to only Power LED.

i have returned it to Amazon as "dead on arrival"

Then i ordered another Vera Pus device next day... followed same steps... again bricked after firmware update.

resetting does not help. pressing reset 3 or 6 times or 30s press makes no difference.

is there any way to re-flash firmware from USB?

i really want to use it... bought lots of kit and without controller it is useless...


Offline Zmedic

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Exactly what happened to me today

is there a solution?

Offline MtView

  • Sr. Newbie
  • *
  • Posts: 46
  • Karma: +1/-1
Call customer care. They can fix it. See my previous post on this topic.

Offline Tillsy

  • Full Member
  • ***
  • Posts: 208
  • Karma: +13/-5
Last week was my first experience unboxing a Vera (Plus) and I was horrified, no appalled, at going through exactly the same thing.

I'm a programmer at heart for over 35 years, and an IT Manager of 15 years, so I have a fair idea what I am doing.

I had to almost beat the bejesus out of the thing to get it going again, after which it once again wanted to do the firmware update.  Yep, back to the same disaster.

And again after that too.

Eventually it worked the fourth time from memory - albeit the next surprise was learning quirks like the pairing/unpairing not being reliable and having to do it multiple times, variables not always sticking (or, as it seems, they do but the UI doesn't realise it for ages and gives you wrong info), etc.

Not a good start.

Then, two days later, it tells me it has another firmware update.  You guessed it - never starts up again.  However, after power cycling the bloody thing it did seem to continue the update and completed.

I chose Vera over the Home Centre 2 because a few people said the HC2 can be unreliable... so far I'm in a lot of regret over that, who the heck ships a product that fails straight out the box.

That said, I am open to the fact that a few posts here suggest the past month worth of firmware updates have been very flakey... but to not realise you're unleashing that hell upon brand new customers is unforgivable, talk about serious quality control :(

Am hoping that's the end of my troubles... albeit I'm having significant problems with the Z-UNO which Vera doesn't recognise, installs as generic devices, and an issue is occurring that the vendor claims is Vera's fault... so my confidence is taking another hit.  :(

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1134
  • Karma: +103/-11
Hey there Tillsy,

The last thing we want to see are unhappy experiences, especially for first-time users. If this didn't discourage you already I highly suggest asking for a hand when in need. Our Customer Care will always be there for you. We really want to turn this around into a better experience.
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7

Offline jeubanks

  • Beta Testers
  • Full Member
  • *****
  • Posts: 225
  • Karma: +11/-4
Hi Sorin,

Sorry but so far customer care has not been very helpful.  For very basic things sorta helpful.  The people on this forum and yourself have been more helpful actually.

1.  GE Fan Control switch shows as a "dimmer".  Nope can't be fixed, maybe in the next update
2.  Philips Hue lights are showing at Generic Z devices, not light icons.  Nope, maybe fixed in the next release
3.  Apps in the store are broken (probably UI7 problem).  Sorry not our problem those are community developed
4.  Critical integrations that EVERYONE else has, nope sorry those plugins are community driven (IE Lutron Caseta).  No support there.
5.  Advanced rules, nope go write Lua code or use community plugins

So I'm having a hard time in fully understanding what I purchased.  If everything is "community" supported, and community developed and community driven, then why am I not just using Home Assistant.  The cost of a Raspberry Pi 3 and a good USB Z-wave stick would provide more features, same local processing, better rules and the same community driven support, and would work with everything I have and things I don't have and things get fixed a lot faster.

So again, what did I pay for?  I'm trying to migrate away from SmartThings to get local processing and an "upgrade" in a system.  It is very sad when I go to what was a big player in the HA field and find out they are no longer that big of a player.  Sure you have good z-wave device support, but really so does everyone.  The zigbee support is lacking, the Geofencing is pathetic, no Life360 support is just stupid and every question ends in the answer of "Contact Support" and Support replies "Maybe in the next release".

Offline atokle

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
I got the same after last FW upgrade.

Have had so much trouble with the Vera Plus. Had it bricked before and used days googling to get it unlocked.

Switches not handled correct, Relays not handled correct. Garage door opener not handled correct.

I can't understand why Vera don't try to fix the basics first. I bought this to have something that works out of the box, but instead ended up with something giving me more work and frustration than if I just used Raspberry and open source.

Offline jeubanks

  • Beta Testers
  • Full Member
  • *****
  • Posts: 225
  • Karma: +11/-4
Well, I have learned the hard way that internet is required for things to work correctly with Vera.

1. NTP - known issue that vera uses internet for ntp lookups.  Not that big of a deal, but the setup information for local ntp is really old.
2. Plugins - any plugins that require internet (Philips Hue, Harmony, etc) will HOSE your system and prevent Luup from doing a proper restart.  On the next restart cycle everything HANGS. 

Now I'm having to try and get my systems (two) all worked out as the bridging isn't working.  Not like it worked correctly before my internet problems.

Long story short my internet problems have resulted in a change of my internal LAN IP's and has wreaked HAVOC on Vera.  Everything else came up fine with new DHCP settings.