Author Topic: Connecting SES 302 sensor to VeraPlus and also to an external NTC sensor  (Read 187 times)

Offline hab

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Hello everyone,

I am a novice in Z-Wave systems, and I am doing some tests in order to connect different sensors.

I have a VeraPlus controller with the latest firmware version 1.7.3532.

I recently bought a SES 302 Temperature Sensor, with the idea of connecting on to it an external NTC sensor I have already connected to my Water Heater. The idea is to be able to see the water heater's temperature from my phone and decide to switch the water heater on or not. I have already connected a Z-Wave switch on the heater, so I can control it already.

So, first of all, I am trying to connect the SES302 to the the VeraEdge, without connecting the NTC sensor. Just to see if I can read the standard temperature of the room from the device. In order to do that, I chose to Add Device and then chose generic ZWave device, since I did not find it in the list. I press the small button in the SES302, and after a little while the device gets connected and appears in my devices list.

The problem now, is that I do not see any temperature displayed. I see only one Sensor, I see the battery indicator, but I do not see any readings next to the ?C sign (I am using Celsius). I have tried moving the device just next to the VeraPlus, I have tried pressing the button on the SES302 to send the temperature, but nothing changes... What am I doing wrong? Should I enable something in the options?

I am looking in the manual on the SES302, but I cannot find a lot of information...

I have tried un-pairing and pairing the device again a couple of time, but with no success. I also tried to connect an NTC sensor, but again no temperature was displayed....

Offline hab

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Connecting SES 302 sensor to VeraPlus and also to an external NTC sensor
« Reply #1 on: February 06, 2018, 12:32:00 pm »
Hello,

I have solved this issue and I posting my feedback on this, in case someone has the same issue. I also have a question in the end.

For some reason, when I added the device in Vera, the controller recognized the device but in the wrong category. It was in category 4, but it had to be in category 17. So, inside the Advanced settings, and the Params tab, I changed the catefory_num field to 17. As soon as I did this, the temperature immediately appeared and started working just fine.

So, my next task was to connect the NTC sensor I already had, to position 3 and 5 on the SES 302. Since this was not the official accessory of Secure (SES 001) I was not sure if it was going to work. Fortunately after playing around with the polarity, the temperature appeared in the second temperature device as well! So, it seems that the SES302 works with standard NTC sensors just fine, you only have to find the correct polarity by trial and error.

However, I had another issue. I figured out after a while that the temperature of the external sensor only refreshed when I pressed the button on the SES302 device. It did not refreshed automatically. After a lot of searching around, I saw that the Variables WakeUpInterval and PollSettings where missing. So, I pressed the "New service" tab in the Advanced option, and added these two variables, with the desired seconds as values, and this did the trick. The temperature of the external sensor started refreshing!

My only concern now, is the battery level, which I am not sure if it is refreshing or not. I have this concern, because when I initially added the device, the battery indicator did not appear, and it only appeared when I pressed the button on the SES302 device. So, I have the feeling that this is not refreshing as well, but I do not know how to test if it is refreshing or not. The only way I can think of, is to wait and see after some days. Is there any way to see in a log or something similar? Is there any setting that actually refreshes the battery indicator that might be missing as well?