We have moved at community.getvera.com

Author Topic: Vera (Luup) Control of Denon A/V receiver over serial/ethernet  (Read 189842 times)

Offline a-lurker

  • Hero Member
  • *****
  • Posts: 872
  • Karma: +66/-8
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #615 on: January 05, 2016, 06:00:25 pm »
@zoot1612  re: connection drop outs and having to resort to these sort of solutions:

http://forum.micasaverde.com/index.php/topic,25066.msg175975.html#msg175975

I had similar connections problems with a Yamaha AVR. The original plugin used a socket connection, which just stopped working every now and then. Came to the conclusion it was a Vera problem but I can't be definite about that. Regardless I wrote a plugin that uses HTTP for control and now have no problems:

http://forum.micasaverde.com/index.php/topic,23079.msg156151.html#msg156151

I see that the more recent Denon's also allow HTTP control. eg

http://forum.micasaverde.com/index.php/topic,24464.msg177810.html#msg177810

According to this person, you can send the socket connection commands via HTTP:

https://translate.google.com.au/translate?hl=en&sl=de&u=http://blue-pc.net/2013/12/28/denon-av-reciever-ueber-http-steuern/&prev=search

Like so:

Code: [Select]
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?SITV
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?SIGAME
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?MVUP
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?MVDOWN
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?SITV
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?SIGAME
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?SIIRADIO
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?SIFAVORITES
http://<AV IP-Adresse>/goform/formiPhoneAppDirect.xml?ZMFAVORITE1

It should be possible to an "UseHTTPFlag" in the plugin, that when set, issues the commands via HTTP rather than through the socket?

Offline DeltaNu1142

  • Hero Member
  • *****
  • Posts: 1153
  • Karma: +40/-67
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #616 on: February 25, 2016, 10:24:28 am »
I'm using this plugin with a Marantz SR6009, and it works fine for the main zone; any ideas on how to enable zone 2? I've seen some talk of it on here, but nothing related to a Marantz.
Vera 3 @ UI5 | HomeWave | PLEG

Offline Dansker

  • Full Member
  • ***
  • Posts: 108
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #617 on: February 29, 2016, 05:57:42 am »
Been working with Android app AnyMote Smart Remote to control six AVR-x2100W's in a large residence (using zone 2 from all receivers eliminated expensive multi channel amp for the house zones).

Going the http route seems to work reliably. Smart Remote presently includes remotes for both protocols over Wi-Fi.

To bad Denon don't get it, and fix it.

Offline Aura

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-1
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #618 on: March 18, 2016, 01:13:15 pm »
It's possible that I've missed this somewhere in the thread, so apologies if this is redundant -

Is it possible to connect Denon via Wifi? In my apartment configuration, the Denon is far from my ethernet hub.

I'd love to control the Denon via Zwave, but not if it means running 100' cable across the living room!

Offline PabloNZ

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #619 on: May 01, 2016, 11:20:13 pm »
It's possible that I've missed this somewhere in the thread, so apologies if this is redundant -

Is it possible to connect Denon via Wifi? In my apartment configuration, the Denon is far from my ethernet hub.

I'd love to control the Denon via Zwave, but not if it means running 100' cable across the living room!
Depends on your AVR. My X3200W does have wifi, but not all do.

Offline tomgru

  • Hero Member
  • *****
  • Posts: 1403
  • Karma: +18/-6
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #620 on: May 03, 2016, 03:47:08 pm »
Any noticeable changes to this plugin recently? I'm starting to frequent reboots and the logs are pointing in this direction.  See here for discussion.
http://forum.micasaverde.com/index.php/topic,37341.0/topicseen.html

Offline DeltaNu1142

  • Hero Member
  • *****
  • Posts: 1153
  • Karma: +40/-67
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #621 on: May 03, 2016, 03:53:06 pm »
I recently uninstalled mine. I can ping the AVR, but I kept getting a Lua startup error connecting to it via Vera plugin.
Vera 3 @ UI5 | HomeWave | PLEG

Offline tomgru

  • Hero Member
  • *****
  • Posts: 1403
  • Karma: +18/-6
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #622 on: May 03, 2016, 04:01:07 pm »
I recently uninstalled mine. I can ping the AVR, but I kept getting a Lua startup error connecting to it via Vera plugin.

i went to uninstall... and it removed on instance/device, but not the other.  The original was installed manually - maybe that's the problem.

to uninstall that version, would i just go in and delete those files that i uploaded?

Offline zoot1612

  • Moderator
  • Hero Member
  • *****
  • Posts: 603
  • Karma: +21/-2
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #623 on: May 03, 2016, 10:53:17 pm »
@tomgru
Just delete the parent device, the files will not be deleted from /etc/cmh-ludl but that should not affect day to day operations. You can login with ssh and delete manually if you want them gone completely.

In respect to http://forum.micasaverde.com/index.php/topic,37341.0/topicseen.html I don't believe it is this plugin that is causing issues. But if removing the plugin helps then let me know.

Offline zoot1612

  • Moderator
  • Hero Member
  • *****
  • Posts: 603
  • Karma: +21/-2
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #624 on: May 03, 2016, 10:55:43 pm »
@DeltaNu1142

I recently uninstalled mine. I can ping the AVR, but I kept getting a Lua startup error connecting to it via Vera plugin.

The AVR only handles one Telnet session at a time. If you have another device connected then you would get that message.

Offline DeltaNu1142

  • Hero Member
  • *****
  • Posts: 1153
  • Karma: +40/-67
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #625 on: May 04, 2016, 01:21:48 pm »
@DeltaNu1142
I recently uninstalled mine. I can ping the AVR, but I kept getting a Lua startup error connecting to it via Vera plugin.
The AVR only handles one Telnet session at a time. If you have another device connected then you would get that message.
Interesting... well, my AVR is a Marantz, but I don't expect that to make a difference. I really don't know what other devices could be connected to it. I attempted to use the Marantz iPhone app and couldn't connect to it either. I can see through the AVR UI that it's got an active Internet connection... but I wonder what could be connected to it? The plugin worked for about a week and then stopped working.
Vera 3 @ UI5 | HomeWave | PLEG

Offline tomgru

  • Hero Member
  • *****
  • Posts: 1403
  • Karma: +18/-6
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #626 on: May 06, 2016, 11:22:04 am »
@tomgru
Just delete the parent device, the files will not be deleted from /etc/cmh-ludl but that should not affect day to day operations. You can login with ssh and delete manually if you want them gone completely.

In respect to http://forum.micasaverde.com/index.php/topic,37341.0/topicseen.html I don't believe it is this plugin that is causing issues. But if removing the plugin helps then let me know.

Hi Zoot... thanks.

I did remove, and you'll be happy to know that the problem didn't go away.  :-)

That said... one weird thing... I removed the files (at least all that I knew of) and in the logs I still saw some calls looking for the receive.  Honestly, I've done so many things since then, I wasn't smart enough to write down the actual call - but do you have any idea what that might be?

That part aside... if you happened to see in the other thread... I actually restored to a good known version of Vera... reset via a vera firmware upgrade... and things seem to be mostly back to normal.

However... even now I see some pretty big spikes, and a LOT of activity regarding the plugin.  Attached is just a snippet of what I saw today... any idea if it should be this busy?

Offline tomgru

  • Hero Member
  • *****
  • Posts: 1403
  • Karma: +18/-6
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #627 on: May 08, 2016, 03:04:44 pm »
As an example... after removing devices and uninstalling app, I still see this:

luup_log:201: AVRReceiverPlugin::Connection currently OK

Offline zoot1612

  • Moderator
  • Hero Member
  • *****
  • Posts: 603
  • Karma: +21/-2
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #628 on: May 08, 2016, 06:49:14 pm »
That said... one weird thing... I removed the files (at least all that I knew of) and in the logs I still saw some calls looking for the receive.  Honestly, I've done so many things since then, I wasn't smart enough to write down the actual call - but do you have any idea what that might be?

Looks like plugin is still loaded, have you deleted the device and restarted the box? Not sure what has happened looks like the plugin has not been removed totally, you may have to look around the forum for an answer.

However... even now I see some pretty big spikes, and a LOT of activity regarding the plugin.  Attached is just a snippet of what I saw today... any idea if it should be this busy?

The plugin only reacts when receiving input from AVR the reason you are seeing a lot of activity is that I think I left the plugin debugging on by default. Just set it to zero in the parameters and output should decrease.

Offline Fred S

  • Sr. Newbie
  • *
  • Posts: 48
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #629 on: May 20, 2016, 10:30:04 pm »
Guys whenever I reboot my Vera Plus, I get an error message stating AVR Receiver : Communications error. The Denon receiver is off when this happens. The only way around this is to turn on my Denon receiver and reload the Zwave Engine. Is there any way to fix this?