We have moved at community.getvera.com

Author Topic: Vera (Luup) Control of Denon A/V receiver over serial/ethernet  (Read 190090 times)

Offline ChrisGrund

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #630 on: June 03, 2016, 10:15:04 am »
Looking for a little help in Creating the other zones:

I have successfully installed the Denon app and it did create the "Main" Zone which appears to work (I have not tested everything but did change the source and a few other things.

My problem is with the creation of the 2nd and 3rd zones.  I have a AVR-X6200WUSA as listed in the Model Number Line and I did change the Impl file to I_DenonReceiver1_UI7.xml from the I_DenonReceiver1.xml it was originally created with (Since I am running UI7).

I have tried adding the following lines in the L_DenonReceiver1.LUA one at a time, each time changing the SETUP to a 0 afterwards and restarting LUUP with no zones being created.

Inside Local MODEL
Firstly adding ['AVR-X6200WUSA'] = {zones = "2,3"},
Next  adding ['6200'] = {zones = "2,3"},
Next  adding ['1'] = {zones = "2,3"},

Finally I just added a line after this selection logic immediately before: local avr_rec_dev = nil
local zones = "2,3"

I will admit, I am not familiar with LUA/LUUP programming and have been getting by using the PLEG stuff for my more advanced scenes so it is probably something simple.

Thanks in advance for your help.


UPDATE:
    After messing with this a good bit and not sure exactly what I did, but it is working (At least the zones are created).  I am not at home so I cannot verify they are functioning properly till tonight, but I am assuming they are working and will only post back if they are not.  The last file I uploaded had both "1" and "6200" in the table. Hope this helps someone else.

« Last Edit: June 07, 2016, 12:26:01 pm by ChrisGrund »

Offline zoot1612

  • Moderator
  • Hero Member
  • *****
  • Posts: 603
  • Karma: +21/-2
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #631 on: June 07, 2016, 10:00:54 pm »
@ChrisGrund

Adding ['6200'] = {zones = "2,3"} would work.

You need to reset the config after changing the file otherwise the plugin will not go through the configuration again.

Under the "Advanced" tab set the "Setup" to "0" then restart the luup engine. This will rewrite the json and xml device files.

This is documented here: -
http://code.mios.com/trac/mios_denon-receiver-control/wiki

Hopefully this works for you as I am not really supporting this plugin anymore.


Offline tomgru

  • Hero Member
  • *****
  • Posts: 1403
  • Karma: +18/-6
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #632 on: June 09, 2016, 09:59:33 am »

Hopefully this works for you as I am not really supporting this plugin anymore.

Zoot.... you going somewhere?

Offline zoot1612

  • Moderator
  • Hero Member
  • *****
  • Posts: 603
  • Karma: +21/-2
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #633 on: June 12, 2016, 06:51:42 pm »
@tomgru
No still hanging around, just don't have the time I once did.

Thanks

Offline mikoz

  • Full Member
  • ***
  • Posts: 126
  • Karma: +1/-6
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #634 on: June 14, 2016, 10:07:31 pm »
I had to uninstall this and give up. The denon is simply unreliable when you have more than one client connecting to it, as described in other posts.  Once the receiver (well, preamp is my case) is under control of the plugin, every communication to it became unreliable   I have a denon iPhone app for allowing control of the preamp and 99% of the attempts to use it caused errors when the plugin was running, it was flawless without it.   I guess there's no hope of denon fixing that. 


Offline Maskfaen

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #635 on: October 20, 2016, 03:04:06 pm »
I got this plugin working awsome! But then I suddenly got "AVR-X1200WEUR_main[56] : Startup Lua Failed".

Any idea?

Offline dcaler

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #636 on: November 17, 2016, 04:32:49 pm »
Fred S.
Anything on this "AVR Receiver : Communications error"?  Working through the same issue.

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1985
  • Karma: +61/-193
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #637 on: December 16, 2016, 01:30:11 am »
I'm also getting... Denon Receiver (AVR) via RS232/Ethernet[541] : Startup Lua Failed

Anyone know how to fix?

Offline ALcALoIDe

  • Jr. Member
  • **
  • Posts: 69
  • Karma: +1/-1
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #638 on: January 09, 2017, 09:45:56 am »
Wow, just saw this thread now. I own a 4806ci, which I love too, and bought the global cache with serial port and one with IR port. I haven't started "playing" yet, but would love to enjoy your journey. Subscribing to this thread now.
Vera Plus UI7 and lots of zwave devices

Offline dcaler

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #639 on: January 09, 2017, 05:13:29 pm »
not know anything about this stuff, especially close to the code, I change the "PollFreq" in, Device/Advanced/Variables from 5m to 24h.
I think this might have helped in that the controller is not frequently checking for the Denon receiver.  For now, this appears to eb a good band-aid for me

Offline zoot1612

  • Moderator
  • Hero Member
  • *****
  • Posts: 603
  • Karma: +21/-2
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #640 on: January 09, 2017, 06:39:50 pm »
@Aaron
Try latest alpha version here https://github.com/zoot1612/plugin-denon and let me know how it goes.





Offline ronluna

  • Jr. Member
  • **
  • Posts: 96
  • Karma: +1/-3
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #641 on: March 18, 2017, 10:22:10 am »
I'm using a Marantz SR6010 and the plugin is throwing the following error while the engine is starting/reloading.
Could this error be due to the fact that this receiver model is not defined in MODEL array inside the L_DenonReceiver1.lua ?

Code: [Select]
2017-03-18 10:17:07.701   openLuup.context_switch::  ERROR: [string "[55] I_DenonReceiver1.xml"]:391: attempt to concatenate local 'msgZone' (a boolean value)stack traceback:
./openLuup/scheduler.lua:128: in function <./openLuup/scheduler.lua:125>
(tail call): ?
./openLuup/scheduler.lua:238: in function 'dispatch'
./openLuup/scheduler.lua:705: in function 'task_callbacks'
./openLuup/scheduler.lua:1084: in function 'start'
openLuup/init.lua:322: in main chunk
[C]: ?

Offline coyote

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #642 on: March 18, 2017, 11:45:52 am »
Hi, new member here. I'm stumbling through discovery of various http commands (which are preferable because they don't monopolize the network connection).

The following commands get various statuses:
http://192.168.xxx.xxx/goform/formMainZone_MainZoneXmlStatus.xml

http://192.168.xxx.xxx/goform/formNetAudio_StatusXml.xml?ZoneName=MAIN+ZONE

And there are other commands too. What I'm looking for is a status command that will tell me the status of the audio signal coming from the CBL/SAT input. I can't find one. The data has to be in there somewhere, because it is what shows onscreen in the 'SIGNAL' field when you press the 'INFO' button on the remote. Anyone have any ideas??

Offline dcaler

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #643 on: March 18, 2017, 07:59:18 pm »
I have ongoing supervision problems, although fully functional when controlling.  I would like to turn off supervision altogether.  Anyone know how to do this?

Offline mikoz

  • Full Member
  • ***
  • Posts: 126
  • Karma: +1/-6
Re: Vera (Luup) Control of Denon A/V receiver over serial/ethernet
« Reply #644 on: June 23, 2017, 03:22:28 am »
I downloaded the alpha version and it fixed a lot of problems.  I could finally setup the zones and the communication to the AVP-A1HDCI is much better (*).   Previously, I could never get the zones to be created, even if I manually edited the Lua file. 

For those trying it, you configure the zones as "2,3" (for example), not "1,2,3" in vera itself now, not via the Lua file.    You do this in the settings page after you initially setup the device.   


(*) I also changed the networking settings in the Denon itself, I previously had DHCP setup and the router had a fixed IP reserved for its MAC, but I changed this such I used static settings in both the router and the Denon.  so far, this is also helping stability.