Author Topic: What happened - 'Can't detect device'  (Read 536 times)

Offline awoodlandcritter

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
What happened - 'Can't detect device'
« on: February 21, 2018, 02:43:55 pm »
After a year and a half my Schlage BE469 door lock has started to report 'can not detect device`  after 5 tries.  What is strange is that after an over night back up or reload it will accept the command once, then go off line and 'device not detected will occur.   I have the latest firmware for my vera lite and new batteries.  The locks are next to two powered switches and was working for 18 months with no issue.  I even added a repeated with no effect. Note i have another BE469 leading into the room and it has no problems...

A call to tech support was fruitless with them listening to everything  i said i tried, then having me repeat it - i.e check the batteries,  try reloading from backup - with no effect.  Then came the dreaded  'please' exclude and include the device request.....after this  the lock would function...but as soon as an overnight vera backup...it went back to working only on the first command then going back to 'can not detect device'....  I am not saying the back ups is  at fault, but it is the only thing changing in the system from day to day.   
 
Any thoughts on this from the forum  would be appreciated.....

Offline Chaypee

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: What happened - 'Can't detect device'
« Reply #1 on: March 03, 2018, 09:50:28 am »
Happened to me/ Turned out that it was listening to a nearby Z-Wave GE light switch that had some sort of relay problem. Once rthat was eplaced everything continues to be normal. 

In most "Can't Detect Device" situations turning off the electric circuit (on light switches pulling out small slide out disconnect makes that easy,)else you need to throw the breaker. off/on.

No need to remove, reset or unpair.  The detection and relay function was restored.

Offline sgm

  • Sr. Newbie
  • *
  • Posts: 22
  • Karma: +1/-1
Re: What happened - 'Can't detect device'
« Reply #2 on: March 08, 2018, 06:28:26 pm »
Quote
In most "Can't Detect Device" situations turning off the electric circuit.....

Duh......now why didn't I think of that!  Worked like a charm.

I've been deleting/adding devices which is time consuming and problematical.  Your solution has worked.  Maybe it won't work in all cases, but even if just some, it's a big time saver.

THANKS for the tip.

Offline rafale77

  • Hero Member
  • *****
  • Posts: 1403
  • Karma: +71/-24
Re: What happened - 'Can't detect device'
« Reply #3 on: March 10, 2018, 12:34:31 pm »
Yep, not always the Vera's fault. Easier to try to go reboot the device than to restart the whole pairing process on the vera to see if fixes it.
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!