Author Topic: Fibaro Double Switch (FGS-223) Lag  (Read 3442 times)

Offline Klathmon

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Fibaro Double Switch (FGS-223) Lag
« Reply #45 on: June 12, 2018, 10:05:41 am »
There's gotta be a way to force this controller to treat it as a non-secure device.

Could we modify backups and then restore them? Possibly change some of the xml or json files to trick the controller into thinking it doesn't support secure?

I see from this (http://wiki.micasaverde.com/index.php/ZWave_Debugging) old URL that there used to be a zwave_products_sys.xml which could tell the vera to us specific settings based on the manufacturer ID and product ID.

That file is no longer on my VERA, but maybe it will still honor it if I add it? And if we can get it to use that file, then we can modify the zwave classes to maybe enforce a non-secure inclusion?

« Last Edit: June 12, 2018, 10:34:30 am by Klathmon »

Offline fooey

  • Newbie
  • *
  • Posts: 14
  • Karma: +1/-0
Re: Fibaro Double Switch (FGS-223) Lag
« Reply #46 on: June 13, 2018, 02:05:58 am »
Vera are aware of this and are working on it but there are no timelines yet.

I hope it?s fixed properly soon, or at least have a workaround until so as I have 19 of these devices!

Offline cw-kid

  • Hero Member
  • *****
  • Posts: 1450
  • Karma: +11/-2
Re: Fibaro Double Switch (FGS-223) Lag
« Reply #47 on: June 14, 2018, 07:24:50 am »
You can add me to list as well as having problems, I recently bought my first Fibaro Double Switch relay module and it seems very slow responding to On / Off commands.

In the log I see:

Code: [Select]
ZWaveNode::HandlePollUpdate node 66 device 278 got a secure command for unsecure command class 0x32 command 0x2 m_iFrameID 5951/38258960 data 0x1 0x44 0x0 0x0 0x0 0x26 (#D###&) <0x769d4520>
In the UI7 web GUI if I manually turn Off / On the Fibaro relay module it says "Sending the Z-Wave command after 0 retries..." underneath and seems very slow at reacting to the button presses.

Likewise when using LUA code to turn Off / On the relay module it doesn't react fast enough.

I have this relay connected to some outdoor PIR security lights and wanted to be able to send a series of commands for the manual override on the PIR security lights to keep them ON when I wish. The override power routine is OFF/ON/OFF/ON within two seconds.

I have the Fibaro relay connected to an outdoor light switch and using the switch I can get the override to work.

However when trying to do it in software its way too slow and doesn't work.

I just commented about this on another thread here

Vera support said to me recently:

"The delays you encountered for the Fibaro FGS-223 switch when the scenes are running were reported to our development team and they are working on a fix patch, but for the moment I dont have an ETA for when the fix would be released."

I don't seem to have any issues with my Fibaro Dimmer 2's apart from since the last Firmware update it started displaying the red banner "Can't detect device" again.

So how do you tell if a device was included in secure or un-secure mode ?

Offline therealdb

  • Jr. Member
  • **
  • Posts: 94
  • Karma: +0/-0
  • Automate all the things!
Re: Fibaro Double Switch (FGS-223) Lag
« Reply #48 on: Today at 03:23:36 am »
new beta announced, still no joy for us :(
Vera Edge, Fibaro FGRM 222 (12), Fibaro FGS 223 (20), Fibaro FGS 222 (5), Fibaro Universal Binary Sensor (2), Fibaro Plug (3), NeoCoolCam Door Sensor (3), NeoCoolCam PIR (1), Nest (3), Raspberry PI running my own integrations, Harmony Hub, OpenSprinkler, Personal Weather Station

Offline fooey

  • Newbie
  • *
  • Posts: 14
  • Karma: +1/-0
Re: Fibaro Double Switch (FGS-223) Lag
« Reply #49 on: Today at 05:44:17 am »
That is really disappointing  :( even more so that it?s not even acknowledged as a known issue with this device (outside of this forum post)

It would be handy to know rough timelines - one month / six months ??

Offline cw-kid

  • Hero Member
  • *****
  • Posts: 1450
  • Karma: +11/-2
Re: Fibaro Double Switch (FGS-223) Lag
« Reply #50 on: Today at 06:00:14 am »
That is really disappointing  :( even more so that it?s not even acknowledged as a known issue with this device (outside of this forum post)

It would be handy to know rough timelines - one month / six months ??

Vera support said to me recently:

"The delays you encountered for the Fibaro FGS-223 switch when the scenes are running were reported to our development team and they are working on a fix patch, but for the moment I dont have an ETA for when the fix would be released."

How long though? Your guess is as good as mine.

Offline therealdb

  • Jr. Member
  • **
  • Posts: 94
  • Karma: +0/-0
  • Automate all the things!
Re: Fibaro Double Switch (FGS-223) Lag
« Reply #51 on: Today at 06:50:18 am »
that's the standard response since we first reported it, about 12 months ago, just after they integrated the devices and claimed it was fully supported...
Vera Edge, Fibaro FGRM 222 (12), Fibaro FGS 223 (20), Fibaro FGS 222 (5), Fibaro Universal Binary Sensor (2), Fibaro Plug (3), NeoCoolCam Door Sensor (3), NeoCoolCam PIR (1), Nest (3), Raspberry PI running my own integrations, Harmony Hub, OpenSprinkler, Personal Weather Station