We have moved at community.getvera.com

Author Topic: 1.0.6 update  (Read 7057 times)

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
1.0.6 update
« on: April 29, 2011, 07:32:11 pm »
Hello,

   As some of you have seen, 1.0.6 was approved by Apple this week. Apparently some users have been experiencing issues connecting remotely for some reasons, unfortunately I cannot reproduce this issue on my systems nor can you contact people who put reviews on the AppStore (thank you Apple).

If you are experiencing issues connecting remotely with 1.0.6, could you email iVera@thinkiwi.com so we can investigate and provide a fix as soon as possible. Thanks in advance.
iVera ... control your house!
www.thinkiwi.com

Offline JOD

  • Hero Member
  • *****
  • Posts: 1973
  • Karma: +4/-0
Re: 1.0.6 update
« Reply #1 on: April 30, 2011, 01:21:07 pm »
Vera #1. Total of 3 devices. No issues loading.
Vera #2. Total of 13 devices. No issues loading.
Vera #3. Total of 145 devices. downloading data => downloading status and then returns a blank screen

JOD.
I'm sorry, my responses are limited. You must ask the right questions.

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: 1.0.6 update
« Reply #2 on: April 30, 2011, 03:12:03 pm »
JOD can you email me at ivera-bug@thinkiwi.com, thanks.
iVera ... control your house!
www.thinkiwi.com

Offline JOD

  • Hero Member
  • *****
  • Posts: 1973
  • Karma: +4/-0
Re: 1.0.6 update
« Reply #3 on: May 02, 2011, 11:45:40 am »
I've noticed my Vera has locked up a few times and it does this when trying to access it via iVera.

Would you shoot me an email when you are in my system or try to connect with iVera? That way I know to reboot.

Thx.
JOD.
I'm sorry, my responses are limited. You must ask the right questions.

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: 1.0.6 update
« Reply #4 on: May 02, 2011, 08:48:55 pm »
JOD,

     I looked at your problem and found that the request made to MCV's remote server to get all the information about your Vera doesn't return any data. Even when using a browser with the same URL, it didn't work.
Those are APIs defined by MCV to communicate with a Vera gateway. If those don't behave as expected, then remote access controller applications will not work.
iVera ... control your house!
www.thinkiwi.com

Offline JOD

  • Hero Member
  • *****
  • Posts: 1973
  • Karma: +4/-0
Re: 1.0.6 update
« Reply #5 on: May 03, 2011, 12:10:35 pm »
Try a remote connect using MCV's smartphone app. It does return data both locally and remotely and works fine.

This is not a remote issue.
iVera returns a blank screen (no data) both locally and remotely AND will cause my Vera to lock up, requiring a reboot.


JOD.

I'm sorry, my responses are limited. You must ask the right questions.

Offline Ap15e

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1998
  • Karma: +12/-0
Re: 1.0.6 update
« Reply #6 on: May 03, 2011, 01:27:46 pm »
AFAIK, the MiOS SmartPhone plugin uses the Luup Lua Extensions to enumerate scenes and devices and luup.register_handler to add itself to your local Vera. That might be quite different from what iVera is doing ...

Offline JOD

  • Hero Member
  • *****
  • Posts: 1973
  • Karma: +4/-0
Re: 1.0.6 update
« Reply #7 on: May 03, 2011, 04:58:36 pm »
I agree, and ...
was trying to make a point that data was being returned by MCV's server.
Quote
the request made to MCV's remote server to get all the information about your Vera doesn't return any data. Even when using a browser with the same URL, it didn't work.
Since (iVera) is added as a user to my system he could prove to himself that my system is online and functional.
But this is not limited to being a remote issue, iVera does not work locally either.
It appears the way in which the data is being requested is too aggressive (for lack of a better term)

JOD.
I'm sorry, my responses are limited. You must ask the right questions.

Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: 1.0.6 update
« Reply #8 on: May 04, 2011, 08:46:59 am »
@iVera,

I'd have to agree with @JOD that something is going on with larger networks. I don't know what the magic threshold number is (if there is one), but it definitely works better with a smaller number of nodes.

Typically, when I start iVera I get the 'Vera server is busy' count, a connection error etc. Subsequently things may appear to load fine, but then after swiping down the list of lights for example, it goes 'busy' again, at least once.

Local and remote. No difference with 1.0.6. I have had 2 Vera hang-ups so far; they definitely appear related to Vera-iVera interaction.

Haven't been able to pin it down more; sometimes it just works fine.

What is 100% reproducible:
Start iVera without a LAN connection -> 'Vera server is busy' 1 2 3 4 5 -> 'Connection error' -> do something else (e.g. click Lights) -> crash
Dezwaved at the moment...

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: 1.0.6 update
« Reply #9 on: May 04, 2011, 09:42:10 am »
JOD, I wasn't aware the mios smartphone plugin was using luup lua extensions to gather its data but so far, each time I've tried connecting to your system via cp.mios.com, direct URL or other remote access points (haven't tried mios smartphone) ... I get a "loading data in progress" message from UI4 and it never loads for me, the other never get the URL request back and end up timing out.

oTi@, can you email me at iVera-bug@thinkiwi.com so I can check your server as well. With 1.0.6, when Vera sends a new user_dataversion timestamp, iVera will reload the whole setup in the foreground whereas with 1.2.0, the entire update has been moved in the background so you shouldn't get the 'server busy'. However, if the problem comes from the fact that http requests to Vera or MCV's remote servers are not being answered as expected when networks are too large, then this won't solve the issue and needs to be talked to MCV about to understand why Vera is not returning the expected data.
iVera ... control your house!
www.thinkiwi.com

Offline JOD

  • Hero Member
  • *****
  • Posts: 1973
  • Karma: +4/-0
Re: 1.0.6 update
« Reply #10 on: May 04, 2011, 12:10:18 pm »
@iVera,
Currently I'm not able to connect through cp.mios.com either...hmmm the Smartphone app is still able to connect though.
Remember we had a similar issue back with rev.1.0.2 (Sept 2010) that's when you increased the time out period I believe...
JOD.
I'm sorry, my responses are limited. You must ask the right questions.

Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: 1.0.6 update
« Reply #11 on: May 04, 2011, 01:52:57 pm »
@JOD,
I don't know if iVera is pulling the config as XML, but FF complains about the XML returned for the weather plugin.

Would you mind deleting the weather device and see if it improves anything?
Dezwaved at the moment...

Offline JOD

  • Hero Member
  • *****
  • Posts: 1973
  • Karma: +4/-0
Re: 1.0.6 update
« Reply #12 on: May 04, 2011, 02:06:24 pm »
Would you mind deleting the weather device and see if it improves anything?
Those are fighting words.
Yes I mind. Aint no way I'm deleting any device!!  ;D

Could we accomplish the same thing by changing the XML the Weather device uses? Or deleting the XML?
Either way, I cant do anything until later, later this evening.

JOD.
I'm sorry, my responses are limited. You must ask the right questions.

Offline MNB

  • Hero Member
  • *****
  • Posts: 689
  • Karma: +4/-9
Re: 1.0.6 update
« Reply #13 on: May 04, 2011, 03:44:32 pm »
I too after updating to the 1.06 seem to have hit and miss connectivity which I did not experience with earlier version(s). What I'm experiencing is that IVera attempts to connect, it connects but then freezes nothing works I end up exiting the app and retrying, have been able to recreate. I'm using my ITouch via WiFi connections. Mike
Edge-1.7.2607, VRI06-1LX Dimr (6), VS05-1LX Sw (4), GE ZW3002 Dimr (1), HA01C Outlet (12), HA02C Sw (6), HA04C Sw (4), GE Sw (2), HA05 Sw (3), MiniMote Contr (5), HSM200/100 Sensor (2), ZW100A Sensor (8), Nest thermostat (1) & Protect Fire/CO (6) Kwikset Locks (3), F18918W (1) & IP3M-9 (6) Cam's

Offline iVera

  • Moderator
  • Jr. Member
  • *****
  • Posts: 96
  • Karma: +0/-0
Re: 1.0.6 update
« Reply #14 on: May 05, 2011, 02:10:00 am »
Michael, could you email me at iVera-bug@thinkiwi.com?

I am setting up a beta version so people who are experiencing issues can test out some changes prior to sending to Apple (since I can't reproduce the connection problem in house). Thanks.
iVera ... control your house!
www.thinkiwi.com