Author Topic: HSM100's all broken after latest firmware update  (Read 19137 times)

Offline Henk

  • Hero Member
  • *****
  • Posts: 820
  • Karma: +3/-0
Re: HSM100's all broken after latest firmware update
« Reply #30 on: June 18, 2011, 08:01:43 am »
@flyboybob

As you are using 3.20, Vera cannot act as a secondary controller anymore, she will always have to be primary.

As for your other issues, again, I have seen many users in different threads experiencing the same issue

Some way or another we will have to try to find the source of this issue and report it to MCV.  It seems it's introduced as of 1.1.1245
| Vera2 @ UI4 1.1.1350 / 3.20 | Vera Lite @ UI5 | Vera 3 @ UI5 | 2x Merten  504519 | 1x Duewi  064374 | 1x Everspring SM103 doorbell mod |1 Y-cam IP cam | various LUUP plugins |

Offline oTi@

  • Master Member
  • *******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: HSM100's all broken after latest firmware update
« Reply #31 on: June 18, 2011, 08:25:35 am »
[...] not sure how to verify my configuration though? [...] and need to persue fixes myself.
Yep; sounds like it will be hard to figure out what transpired. I was just wondering if more is hosed in your config than just the HSM100's. Does everything else seem to be working fine? Otherwise, fixing just the sensors may not help, and you'd have to go back to the last known-good backup, after downgrading Vera and Z-Wave firmware etc.

Quote
Also - the PRI:NO thing made no difference one way or the other.
Understood; I don't expect it to. But you want Vera to be primary (PRI:YES), otherwise you would never be able to include any devices again.

Quote
If it helps - I had tried to share a light switch between a Logitech controller [...]
Thanks for the additional info. Mmm, Logitech... ::)
« Last Edit: June 18, 2011, 08:44:49 am by oTi@ »
Dezwaved at the moment...

Offline FlyBoyBob

  • Full Member
  • ***
  • Posts: 163
  • Karma: +0/-0
Re: HSM100's all broken after latest firmware update
« Reply #32 on: June 18, 2011, 09:18:51 am »
oTi@

Can you verify that the device configuration files are new with the new box firmware? The list of "states" I see for devices is now a lot longer, supporting new features like energy usage tracking and network connection data. My problems all seem to stem from variables that are inappropriate for the device, which I doubt is a problem if the system does not address them, and more importantly invalid data values.

I am guessing that any restore of old data into the new format could experience the same merge bugs, so not a solution. Also I don't think that regressing the firmware with corrupt device data will help.

The facts, in my particular situation, is that devices definitely have variables that don't belong in that device type, and data that is invalid for the variable. The status file I get also contains CRLFs where they don't belong and innappropriate delimiters, again evidence of corruption. Everything else is my speculation... :-[

bob

Offline Henk

  • Hero Member
  • *****
  • Posts: 820
  • Karma: +3/-0
Re: HSM100's all broken after latest firmware update
« Reply #33 on: June 18, 2011, 09:57:12 am »
Ok,

Im going to contribute one more time with a pointer to the wiki.

To troubleshoot, use:
http://wiki.micasaverde.com/index.php/Troubleshooting

To wipe Vera and build her from scratch use:
http://wiki.micasaverde.com/index.php/Factory_Reset
http://wiki.micasaverde.com/index.php/Buttons_Indicators

NOTE:  the above mentioned page is only for VERA 1 hardware.

This would be usefull for Vera 2:
http://wiki.micasaverde.com/index.php/Firmware_Flash_Vera2
| Vera2 @ UI4 1.1.1350 / 3.20 | Vera Lite @ UI5 | Vera 3 @ UI5 | 2x Merten  504519 | 1x Duewi  064374 | 1x Everspring SM103 doorbell mod |1 Y-cam IP cam | various LUUP plugins |

Offline oTi@

  • Master Member
  • *******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: HSM100's all broken after latest firmware update
« Reply #34 on: June 19, 2011, 12:17:39 am »
Can you verify that the device configuration files are new with the new box firmware? The list of "states" I see for devices is now a lot longer, supporting new features like energy usage tracking and network connection data.
Yep, there's new stuff.
Dezwaved at the moment...

Offline FlyBoyBob

  • Full Member
  • ***
  • Posts: 163
  • Karma: +0/-0
Re: HSM100's all broken after latest firmware update
« Reply #35 on: June 20, 2011, 09:08:18 am »
Moderator - please move this thread to "Upgrading" where it belongs. Motion control sensors are only one of the devices affected by the upgrade, and the cause is still unresolved.

Thanks!
bob

Offline FlyBoyBob

  • Full Member
  • ***
  • Posts: 163
  • Karma: +0/-0
Re: HSM100's all broken after latest firmware update
« Reply #36 on: June 21, 2011, 10:56:31 am »
Yep, there's new stuff.
"New stuff" indeed!  :o

Fortunately I have "user_data" dumps from before the upgrade and now a dump from an HSM-100 that I recently Excluded and then Included = the differences are many and varied, and no reason to enumerate here, other than one possibility:
Quote from: non-working 3-in-1
variable="MultiChCapabilities"
value="1,33,1,49,2,33,1,49,3,33,1,49,"
Quote from: same 3-in-1 working
variable="MultiChCapabilities" value="1,33,1,96,49,112,132,133,128,114,119,134,239,32,2,33,1,96,49,112,132,133,128,114,119,134,239,32,3,33,1,96,49,112,132,133,128,114,119,134,239,32,"

Regardless of that particular variable, the Exclude/Include device has far fewer variables, and I assume they are now appropriate variables; and more importantly passes last night's Heal and today's ADD2.5 tests.

Also regardless of any and all differences in variables, Excluding and then Including any malfunctioning device seems to fix whatever the problem is/was, at least in one case in my Vera2. Better than version regression or wipe-and-start-over, IMHO.

Now only a dozen or so more devices to Exclude/Include.....joy....

Hope this helps somebody,
bob

Offline FlyBoyBob

  • Full Member
  • ***
  • Posts: 163
  • Karma: +0/-0
Re: HSM100's all broken after latest firmware update
« Reply #37 on: June 22, 2011, 08:27:10 am »
UPDATE: even the newly Included battery operated (not just HSM100's) devices are being dropped from the network by those mysterious middle-of-the-night "heals", so my progress reported here has stopped dead in its tracks until I get more information about the intent of these "upgrade"changes.

Offline Henk

  • Hero Member
  • *****
  • Posts: 820
  • Karma: +3/-0
Re: HSM100's all broken after latest firmware update
« Reply #38 on: June 22, 2011, 03:27:39 pm »
| Vera2 @ UI4 1.1.1350 / 3.20 | Vera Lite @ UI5 | Vera 3 @ UI5 | 2x Merten  504519 | 1x Duewi  064374 | 1x Everspring SM103 doorbell mod |1 Y-cam IP cam | various LUUP plugins |