Author Topic: Setting up Linksys WVC80N IP Camera  (Read 4771 times)

Offline anemati

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
Setting up Linksys WVC80N IP Camera
« on: June 19, 2011, 01:22:17 pm »
Has anyone been able to setup Vera2 (using Generic IP Camera Plugin) to receive video from a Linksys IP Camera (WVC80N) streaming video in MJPEG format. I can setup for snapshots but not streaming. I've been following the reference at the wiki below, with no success.

http://wiki.micasaverde.com/index.php/Remote_Camera_Streaming

Offline anemati

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
Re: Setting up Linksys WVC80N IP Camera
« Reply #1 on: June 26, 2011, 12:03:17 pm »
To those folks who are interested.

After a few tries over the weekend, I was able to configure the camera to do snapshots and stream video content. Procedures at the wiki (http://wiki.micasaverde.com/index.php/Remote_Camera_Streaming) are a little confusing. Here is what I had to do to made it work:

Under Settings tab:
           URL =/img/snapshot.cgi?size=2&quality=1
           User =  blank (you may need to include user & password if your camera is configure so, I don't use user an password while testing)
           Password = blank
           IP Address = xx.xx.xx.xx (IP Camera address on my internal network)
         
Under Advanced tab:
            DirectStreamingURL = /img/video.mjpeg (path to the location on your camera for mjpeg or MPEG files)
            URL = /img/snapshot.cgi?size=2&quality=1 (this automatically is filled from the URL under the Settings)



So, now under "Camera Control" panel  I see an snapshot and when I click "Streaming" option under the "Settings" tab I see streamed video from my Cam.


Enjoy!



Offline silvereagle2208

  • Full Member
  • ***
  • Posts: 118
  • Karma: +0/-0
Re: Setting up Linksys WVC80N IP Camera
« Reply #2 on: July 07, 2011, 11:44:16 am »
Thank you for taking the time to figure out how to enable the Linksys WVC80N IP Camera to stream video.   It greatly increases the usability of the camera.

I found a couple of  quirks when doing video streaming through Vera:

When using the camera in snapshot mode, you can enable lights to provide illumination for the snapshot.  However, the video streaming mode does not seem to  support this feature.

Also, I am having difficulty getting video streaming to work when accessing Vera from cp.mios.com via a dashboard.  Video streaming works fine when I access the camera via Vera on my local network.

Offline anemati

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-0
Re: Setting up Linksys WVC80N IP Camera
« Reply #3 on: July 09, 2011, 10:47:11 am »
I tried the light switch, and I have the same issue, light switch doesn't go ON while streaming. But, it works very well with snapshot.

On the second issue, I have no difficultly streaming video while connected remotely via cp.mios.com. I haven't done anything special. The only thing I missed to indicate in my instructions is that I have the attribute "embeded" (under Advance tab) checked. I don't really think that's your issue, but I thought I mention it here for completion.

Take a took at the following link, it references steps needed to enable streaming video remotely that may be helpful. However, I didn't follow it.
 
http://wiki.micasaverde.com/index.php/Remote_Camera_Streaming