Author Topic: Australian Vera2 - Z-Stick S2 question  (Read 4289 times)

Offline Mike-B

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Australian Vera2 - Z-Stick S2 question
« on: July 26, 2011, 04:58:57 am »
Hi All,

New Vera2 / Z-Wave user here (and yes I kinda knew what I was getting into  ;)). Unsurprisingly it seems I have hit a few bumps along the way.

Basically, I have a Vera2 with a Aeon Labs Z-Stick Series 2 plugged in the back (Australian user). Both have been updated to the latest firmware etc. I've added 10 of the Aeon Labs Smart Energy Switches, initially by unplugging the Z-Stick, putting it into inclusion mode and adding the devices, plugged it back into the Vera2 and all was good.

Now 10 days later I come to add some more devices but now I am unable to press the button on the Z-Stick when it's unplugged (the blue light does not flash). Instead I have to leave it connected to the Vera and press the Vera's Z-Wave button. Seems to work, but the Aeon Labs doco says the Z-Stick should be in SerialAPI mode when it's plugged in?! Does this have anything to do with the 3.20 update or is the battery on the Z-Stick likely to be suspect?

Cheers,
Mike

Offline futzle

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3258
  • Karma: +191/-9
Re: Australian Vera2 - Z-Stick S2 question
« Reply #1 on: July 26, 2011, 05:52:35 am »
Hi Mike,

Basically, I have a Vera2 with a Aeon Labs Z-Stick Series 2 plugged in the back (Australian user). Both have been updated to the latest firmware etc. I've added 10 of the Aeon Labs Smart Energy Switches, initially by unplugging the Z-Stick, putting it into inclusion mode and adding the devices, plugged it back into the Vera2 and all was good.

Yes, this is what I do.  It works pretty much all of the time.

Quote
Now 10 days later I come to add some more devices but now I am unable to press the button on the Z-Stick when it's unplugged (the blue light does not flash). Instead I have to leave it connected to the Vera and press the Vera's Z-Wave button. Seems to work, but the Aeon Labs doco says the Z-Stick should be in SerialAPI mode when it's plugged in?! Does this have anything to do with the 3.20 update or is the battery on the Z-Stick likely to be suspect?

Very likely.  I am pretty sure that the 3.20 update is intended only for the internal Z-wave radio, and perhaps only for US frequencies at that.  I'm surprised that it works at all if you're using an external Z-wave radio.

I've no idea how easy it is to back out the 3.20 update.  You might need MCV support to help you with that.

(As an aside, you can see some of my older forum posts asking MCV to clarify what the situation is with respect to users of external dongles with different Z-wave frequencies.  I've never had a response.  So I feel somewhat vindicated that their silence has forced them to do support that they could have avoided if only they'd replied at the time.)

Offline oTi@

  • Beta Testers
  • Master Member
  • *****
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: Australian Vera2 - Z-Stick S2 question
« Reply #2 on: July 26, 2011, 07:51:37 am »
@Mike-B,

Welcome!

As @futzle indicated, the 3.20 update triggered from the Dashboard is for the internal Z-Wave chip in Vera2. Aeon (in collaboration with MCV) would have to put out an update for the Z-Stick.

Have you run the 'Hack to convert 2.78 to 3.20'? If not, then please leave it that way. I think it may simplify the downgrade. I'd contact MCV Support for the best approach.
« Last Edit: July 26, 2011, 08:11:25 am by oTi@ »
Dezwaved at the moment...

Offline Mike-B

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: Australian Vera2 - Z-Stick S2 question
« Reply #3 on: July 26, 2011, 08:19:18 am »

Yes, this is what I do.  It works pretty much all of the time.

As an aside, you can see some of my older forum posts asking MCV to clarify what the situation is with respect to users of external dongles with different Z-wave frequencies.  I've never had a response. 
Hi Futzle,

I've got the helpful guys at smarthome.com.au sending out a replacement z-stick just to see if it's not a dud. I have a look through your posts and it makes for depressing reading - particularly WRT their support of z-stick (Aus) users. Frankly I'm not holding out much hope but I guess I'll have to see.  ;)


@oTi
Thanks for moving the thread (i think), perhaps the category should be changed to Downgrading! Not quite sure of the benefits of an automatic upgrade that is launched on unsuspecting new users if there are such pitfalls?!

Once I've tried a replacement z-stick I'll see how I go with MCV.

Offline oTi@

  • Beta Testers
  • Master Member
  • *****
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: Australian Vera2 - Z-Stick S2 question
« Reply #4 on: July 26, 2011, 09:27:59 am »
[...] perhaps the category should be changed to Downgrading!
:) Yeah, I prefer 'Updating'.

Quote
Not quite sure of the benefits of an automatic upgrade that is launched on unsuspecting new users if there are such pitfalls?!
I thought the Z-Wave firmware update (2.78 to 3.20) is optional/non-automatic?
Dezwaved at the moment...

Offline JOD

  • Beta Testers
  • Hero Member
  • *****
  • Posts: 1973
  • Karma: +4/-0
Re: Australian Vera2 - Z-Stick S2 question
« Reply #5 on: July 26, 2011, 10:32:51 am »
I am unable to press the button on the Z-Stick when it's unplugged (the blue light does not flash).
Hi Mike,
I had the same issue with the Aeon stick (back in UI2) which turned out to be the sticks internal battery / cap not holding the charge, it's probably the same issue with yours.

JOD.
I'm sorry, my responses are limited. You must ask the right questions.