We have moved at community.getvera.com

Author Topic: New dataMine graphing and logging plugin  (Read 287704 times)

Offline Chris

  • Moderator
  • Hero Member
  • *****
  • Posts: 821
  • Karma: +3/-0
Re: New dataMine graphing and logging plugin
« Reply #645 on: July 15, 2013, 11:12:46 am »
@mal,
The instructions you've followed are the UI4 instructions... Anyway, that's probably not the problem - there is a bug in the current version that doesn't create a directory. I hope this is now fixed and a new version has just been loaded to apps so this should be available in the next day or so. It will hopefully fix your problem  - if not, please send the data from the debug page (debug link in the plugin) and I'll take a look.

Cheers
Chris

Offline mal

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: New dataMine graphing and logging plugin
« Reply #646 on: July 16, 2013, 04:39:05 am »
Hi Chris
Thanks for the reply i read about the instructions the other night luckily i did a backup the day before i installed datamine so i went back to that and re-installed seems to be working.
Some devices are either taking a long time to update or not at all
in the datamine device it show the 8 g drive i use a 2 g for mios logging

this program is awsome well done

Code: [Select]
now: 7693976 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2dfef680>
06 07/16/13 18:14:05.213 Device_Variable::m_szValue_set device: 196 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskUsed was: 150968 now: 150976 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x2dfef680>
06 07/16/13 18:14:05.232 Device_Variable::m_szValue_set device: 196 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskFree was: 7152176 now: 7152168 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x2dfef680>
06 07/16/13 18:14:05.233 Device_Variable::m_szValue_set device: 196 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskUsedPcnt was: 2 now: 2 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2dfef680>
-2-===========================================================================
/dev/sdb1: LABEL="MiOS" UUID="0ff13b45-8da8-42a2-b40e-f918509e6bf6"
/dev/sda1: LABEL="MiOS" UUID="9638bd90-f7a8-4701-89ba-2dc5c5d8550e"
-3-===========================================================================
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock7 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,noatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/sda1 on /tmp/log/cmh type ext3 (rw,noatime,nodiratime,errors=continue,barrier=0,data=ordered)
/dev/mtdblock8 on /mios type squashfs (ro,relatime)
none on /proc/bus/usb type usbfs (rw,relatime)
/dev/sdb1 on /dataMine type ext4 (rw,relatime,barrier=1,data=ordered)
-4-===========================================================================

Disk /dev/mtdblock0: 0 MB, 524288 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/mtdblock0 doesn't contain a valid partition table

Disk /dev/sda: 2011 MB, 2011168768 bytes
62 heads, 62 sectors/track, 1021 cylinders
Units = cylinders of 3844 * 512 = 1968128 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sda1   *           1         273      524705+ 83 Linux
/dev/sda2             274        1021     1437656  83 Linux

Disk /dev/sdb: 8004 MB, 8004304896 bytes
35 heads, 21 sectors/track, 21269 cylinders
Units = cylinders of 735 * 512 = 376320 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sdb1               1       21270     7816688   b Win95 FAT32
-5-===========================================================================
SetDataDirectory-/dataMine/
SetMountUUID    -0ff13b45-8da8-42a2-b40e-f918509e6bf6
SetMountPoint   -
SetManualMount  -0
-6-===========================================================================
{"Version":"0.980","dbVersion":2,"Events":{"count":194,"last":1373957630},"guiConfig":{"_dc":"1373948266935","graphOptionShadows":true},"Variables":[{"Ghost":false,"Service":"urn:micasaverde-com:serviceId:EnergyMetering1","LastRec":1373963511,"DrowsyError":0,"LastHistory":1104516000,"FilterMaximum":0,"EnergyCat":4,"Type":0,"DataType":5,"Logging":1,"Device":4,"FilterMinimum":0,"FilterEnable":0,"DrowsyWarning":0,"Id":1,"DataOffset":0,"Name":"MAIN TV POWER - Watts","LastVal":97,"FirstRec":0,"Variable":"Watts","historyState":0},{"Ghost":false,"Service":"urn:micasaverde-com:serviceId:EnergyMetering1","LastRec":0,"DrowsyError":0,"LastHistory":1104516000,"FilterMaximum":0,"EnergyCat":2,"Type":0,"DataType":5,"Logging":1,"Device":5,"FilterMinimum":0,"FilterEnable":0,"DrowsyWarning":0,"Id":2,"DataOffset":0,"Name":"bbq ligt - Watts","LastVal":0,"FirstRec":0,"Variable":"Watts","historyState":0},{"Ghost":false,"Service":"urn:micasaverde-

Offline mal

  • Newbie
  • *
  • Posts: 8
  • Karma: +0/-0
Re: New dataMine graphing and logging plugin
« Reply #647 on: July 16, 2013, 04:59:23 am »
Spoke too soon will get back to you in a few days

is there a way to export the csv files?

Offline Chris

  • Moderator
  • Hero Member
  • *****
  • Posts: 821
  • Karma: +3/-0
Re: New dataMine graphing and logging plugin
« Reply #648 on: July 16, 2013, 05:50:46 am »
Some devices are either taking a long time to update or not at all
I've just found a bug where the logging doesn't get enabled until dataMine restarts. So, I'd advise restarting dataMine after enabling logging for new variables.

There is no way to export the CSV files from dataMine (at the moment anyway). You can always use WinSCP to grab them if you want though.

Cheers
Chris

Offline DrZWave

  • Jr. Member
  • **
  • Posts: 79
  • Karma: +0/-0
  • Z-Wave Expert
Re: New dataMine graphing and logging plugin
« Reply #649 on: July 31, 2013, 08:25:38 am »
Chris,
I rebuilt parts of my zwave network and deleted nearly all of my datamine logging.
Now I'm ready to put them back in but datamine thinks the USB stick is full.

Channels
2

Disk Space Total (kb) 6464
Disk Space Used (kb) 6464
Disk Space Free (kb) 0 100

Here is the debug page - hope that helps...
-1-=========================================================================== 50 07/30/13 20:10:30.569 luup_log:12: dataMine: Next Sun EVENT is 1.37526e+09 <0x1c08> 50 07/31/13 5:39:30.580 luup_log:12: dataMine: Next Sun EVENT is 1.37532e+09 <0x1c08> 50 07/31/13 7:54:35.139 luup_log:12: dataMine: Initialising dataMine System (0.980) <0x402> 06 07/31/13 7:54:35.140 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: errorStatus was: false now: false #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 06 07/31/13 7:54:35.141 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 2 now: 0 #hooks: 0 upnp: 0 v:0x8278c8/NONE duplicate:0 <0x402> 06 07/31/13 7:54:35.142 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 2 now: 0 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 50 07/31/13 7:54:35.144 luup_log:12: dataMine: Mounting to UUID '2402-C7CE' <0x402> 50 07/31/13 7:54:38.176 luup_log:12: dataMine: Error reading tmpfile during UUID check <0x402> 50 07/31/13 7:54:38.347 luup_log:12: dataMine: No UUID mount '2402-C7CE' was found! <0x402> 50 07/31/13 7:54:38.462 luup_log:12: dataMine: Error reading tmpfile during mountcheck <0x402> 06 07/31/13 7:54:38.463 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountLocation was: now: #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 06 07/31/13 7:54:38.464 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountType was: now: #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 50 07/31/13 7:54:39.116 luup_log:12: dataMine: Watching: D[8] S[urn:upnp-org:serviceId:SwitchPower1] V[Status] <0x402> 06 07/31/13 7:54:39.118 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 0 now: 2 #hooks: 0 upnp: 0 v:0x8278c8/NONE duplicate:0 <0x402> 06 07/31/13 7:54:39.119 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 0 now: 1 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 06 07/31/13 7:54:39.259 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 2 now: 2 #hooks: 0 upnp: 0 v:0x8278c8/NONE duplicate:1 <0x402> 06 07/31/13 7:54:39.280 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 1 now: 2 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 50 07/31/13 7:54:39.283 luup_log:12: dataMine: Startup complete <0x402> 50 07/31/13 7:55:01.019 luup_log:12: dataMine: Initialising dataMine System (0.980) <0x402> 06 07/31/13 7:55:01.020 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: errorStatus was: false now: false #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 06 07/31/13 7:55:01.022 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 2 now: 0 #hooks: 0 upnp: 0 v:0x8278c8/NONE duplicate:0 <0x402> 06 07/31/13 7:55:01.023 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 2 now: 0 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 50 07/31/13 7:55:01.024 luup_log:12: dataMine: Mounting to UUID '2402-C7CE' <0x402> 50 07/31/13 7:55:03.171 luup_log:12: dataMine: Error reading tmpfile during UUID check <0x402> 50 07/31/13 7:55:03.263 luup_log:12: dataMine: No UUID mount '2402-C7CE' was found! <0x402> 50 07/31/13 7:55:03.471 luup_log:12: dataMine: Error reading tmpfile during mountcheck <0x402> 06 07/31/13 7:55:03.472 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountLocation was: now: #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 06 07/31/13 7:55:03.472 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountType was: now: #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 09 07/31/13 7:55:03.641 JobHandler_LuaUPnP::Run device 12 dataMine graphing and logging room 0 type urn:schemas-cd-jackson-com:device:DataMine:1 id parent 0/0x7a63b0 upnp: 0 <0x400> 50 07/31/13 7:55:04.242 luup_log:12: dataMine: Watching: D[8] S[urn:upnp-org:serviceId:SwitchPower1] V[Status] <0x402> 06 07/31/13 7:55:04.413 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 0 now: 2 #hooks: 0 upnp: 0 v:0x8278c8/NONE duplicate:0 <0x402> 06 07/31/13 7:55:04.419 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 0 now: 1 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 06 07/31/13 7:55:04.858 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 2 now: 2 #hooks: 0 upnp: 0 v:0x8278c8/NONE duplicate:1 <0x402> 06 07/31/13 7:55:04.859 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 1 now: 2 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 50 07/31/13 7:55:04.921 luup_log:12: dataMine: Startup complete <0x402> 09 07/31/13 7:55:30.625 JobHandler_LuaUPnP::Run device 12 dataMine graphing and logging room 0 type urn:schemas-cd-jackson-com:device:DataMine:1 id parent 0/0x7a6388 upnp: 0 <0x400> 50 07/31/13 7:55:33.094 luup_log:12: dataMine: Initialising dataMine System (0.980) <0x402> 06 07/31/13 7:55:33.095 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: errorStatus was: false now: false #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 06 07/31/13 7:55:33.096 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 2 now: 0 #hooks: 0 upnp: 0 v:0x8278d0/NONE duplicate:0 <0x402> 06 07/31/13 7:55:33.098 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 2 now: 0 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 50 07/31/13 7:55:33.099 luup_log:12: dataMine: Mounting to UUID '2402-C7CE' <0x402> 50 07/31/13 7:55:34.791 luup_log:12: dataMine: Error reading tmpfile during UUID check <0x402> 50 07/31/13 7:55:34.836 luup_log:12: dataMine: No UUID mount '2402-C7CE' was found! <0x402> 50 07/31/13 7:55:34.904 luup_log:12: dataMine: Error reading tmpfile during mountcheck <0x402> 06 07/31/13 7:55:34.905 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountLocation was: now: #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 06 07/31/13 7:55:34.906 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountType was: now: #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x402> 50 07/31/13 7:55:35.214 luup_log:12: dataMine: Watching: D[8] S[urn:upnp-org:serviceId:SwitchPower1] V[Status] <0x402> 06 07/31/13 7:55:35.215 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 0 now: 2 #hooks: 0 upnp: 0 v:0x8278d0/NONE duplicate:0 <0x402> 06 07/31/13 7:55:35.217 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 0 now: 1 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 06 07/31/13 7:55:35.251 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 2 now: 2 #hooks: 0 upnp: 0 v:0x8278d0/NONE duplicate:1 <0x402> 06 07/31/13 7:55:35.253 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 1 now: 2 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x402> 50 07/31/13 7:55:35.255 luup_log:12: dataMine: Startup complete <0x402> 50 07/31/13 7:55:50.331 luup_log:12: dataMine: Delete backups complete - deleted 0 of 66 files __LEAK__ this:36864 start:40960 to 0x917000 <0x1c08> 06 07/31/13 7:55:50.381 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskTotal was: 6464 now: 6464 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 __LEAK__ this:4096 start:45056 to 0x918000 <0x1c08> 06 07/31/13 7:55:50.382 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskUsed was: 6464 now: 6464 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x1c08> 06 07/31/13 7:55:50.383 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskFree was: 0 now: 0 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x1c08> 06 07/31/13 7:55:50.384 Device_Variable::m_szValue_set device: 12 service: urn:cd-jackson-com:serviceId:DataMine1 variable: diskUsedPcnt was: 100 now: 100 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x1c08> -2-=========================================================================== /dev/scsi/host0/bus0/target0/lun0/part1: LABEL="MiOS" UUID="f14f7809-0175-47e6-ad8d-06d121bba91a" /dev/scsi/host1/bus0/target0/lun0/part1: LABEL="MiOS" UUID="b3bdb623-3a04-49d0-95cf-c52f5a2ec45c" -3-=========================================================================== rootfs on / type rootfs (rw) /dev/root on /rom type squashfs (ro) none on /dev type devfs (rw) none on /proc type proc (rw) tmpfs on /tmp type tmpfs (rw,nosuid,nodev) devpts on /dev/pts type devpts (rw) /dev/mtdblock/4 on /overlay type jffs2 (rw) mini_fo:/overlay on / type mini_fo (rw) /dev/scsi/host0/bus0/target0/lun0/part1 on /tmp/log/cmh type ext3 (rw,noatime,nodiratime) /dev/loop/0 on /mios type squashfs (ro) none on /proc/bus/usb type usbfs (rw) -4-=========================================================================== -5-=========================================================================== SetDataDirectory-/dataMine/ SetMountUUID -2402-C7CE SetMountPoint - SetManualMount -0 -6-=========================================================================== {"Version":"0.980","dbVersion":2,"Events":{"count":622,"last":1375185005},"LastWrite":1375271735,"Variables":[{"Ghost":true,"Service":"urn:upnp-org:serviceId:SwitchPower1","DrowsyError":0,"LastRec":0,"FilterMaximum":0,"LastHistory":1104516000,"Type":0,"DataType":3,"Logging":1,"Id":3,"FilterMinimum":0,"FilterEnable":0,"DrowsyWarning":0,"Device":7,"DataOffset":0,"Name":"cooper - Status","LastVal":0,"FirstRec":0,"Variable":"Status","historyState":0},{"Ghost":false,"Service":"urn:upnp-org:serviceId:SwitchPower1","DrowsyError":0,"LastRec":1375185173,"FilterMaximum":0,"LastHistory":1104516000,"Type":1,"DataType":3,"Logging":1,"Id":6,"FilterMinimum":0,"FilterEnable":0,"DrowsyWarning":0,"Device":8,"DataOffset":0,"Name":"Intermatic - Status","LastVal":0,"FirstRec":0,"Variable":"Status","historyState":0}],"Graphs":[],"guiConfig":{"graphOptionAnimation":false,"_dc":"1374624177631","graphOptionMarker":true},"nextId":18} -7-===========================================================================

I'll try reformating the USB stick and see if that cleans it up...

Offline DrZWave

  • Jr. Member
  • **
  • Posts: 79
  • Karma: +0/-0
  • Z-Wave Expert
Re: New dataMine graphing and logging plugin
« Reply #650 on: July 31, 2013, 12:33:41 pm »
I uninstalled datamine then reinstalled and now its woprking ok.

Offline vio

  • Sr. Newbie
  • *
  • Posts: 47
  • Karma: +0/-0
Re: New dataMine graphing and logging plugin
« Reply #651 on: August 05, 2013, 04:56:06 am »
Hello,

Is history implemented? I'm looking for hourly/daily history files, but I can see only raw files in the dataMine/database dir.
Regards,

Offline BlueFlame

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-2
Re: New dataMine graphing and logging plugin
« Reply #652 on: August 15, 2013, 07:32:23 am »
Hi,

Trying to use your plug-in, but I can't seem to get it to work.

Installed the app.
Plugged a 16GB USB stick in the Vera3 bottom port. (formatted with FAT32 file system in Windows 7)

Now when I start the GUI, it always makes me select the USB stick.

Debug log:
Code: [Select]
06 08/15/13 13:21:40.753 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: SetMountUUID was: 220F-D2F0 now: 220F-D2F0 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2ef8a680>
09 08/15/13 13:22:03.538 JobHandler_LuaUPnP::Run device 90 dataMine graphing and logging room 0 type urn:schemas-cd-jackson-com:device:DataMine:1 id  parent 0/0xc93b78 upnp: 0 <0x2adc3000>
50 08/15/13 13:22:08.123 luup_log:90: dataMine: Initialising dataMine System (0.980) <0x2b6f7680>
06 08/15/13 13:22:08.123 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: errorStatus was: true now: false #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x2b6f7680>
06 08/15/13 13:22:08.124 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 0 now: 0 #hooks: 0 upnp: 0 v:0xd261d8/NONE duplicate:1 <0x2b6f7680>
06 08/15/13 13:22:08.124 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 0 now: 0 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2b6f7680>
50 08/15/13 13:22:08.171 luup_log:90: dataMine: Error reading tmpfile during mountcheck <0x2b6f7680>
06 08/15/13 13:22:08.171 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountLocation was:  now:  #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2b6f7680>
06 08/15/13 13:22:08.172 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountType was:  now:  #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2b6f7680>
50 08/15/13 13:22:08.210 luup_log:90: dataMine: Mounting dataMine storage (/dev/sda1) to (/dataMine/) <0x2b6f7680>
50 08/15/13 13:22:08.289 luup_log:90: dataMine: Error reading tmpfile during mountcheck <0x2b6f7680>
06 08/15/13 13:22:08.290 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountLocation was:  now:  #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2b6f7680>
06 08/15/13 13:22:08.290 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: mountType was:  now:  #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2b6f7680>
50 08/15/13 13:22:08.325 luup_log:90: dataMine: Mount point error: ::/dev/sda1 <0x2b6f7680>
06 08/15/13 13:22:08.326 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: errorStatus was: false now: true #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:0 <0x2b6f7680>
50 08/15/13 13:22:08.356 luup_log:90: dataMine: ERROR: Startup state is 'uninitialised'! <0x2b6f7680>
06 08/15/13 13:22:08.357 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelCnt was: 0 now: 0 #hooks: 0 upnp: 0 v:0xd261d8/NONE duplicate:1 <0x2b6f7680>
06 08/15/13 13:22:08.357 Device_Variable::m_szValue_set device: 90 service: urn:cd-jackson-com:serviceId:DataMine1 variable: ChannelRec was: 0 now: 0 #hooks: 0 upnp: 0 v:(nil)/NONE duplicate:1 <0x2b6f7680>
50 08/15/13 13:22:08.358 luup_log:90: dataMine: Reinitialising configuration structure <0x2b6f7680>
50 08/15/13 13:22:08.358 luup_log:90: dataMine: Startup complete <0x2b6f7680>
-2-===========================================================================
/dev/sda1: LABEL="BFSPUSB7" UUID="220F-D2F0"
-3-===========================================================================
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock7 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,noatime,lowerdir=/,upperdir=/overlay)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
/dev/mtdblock8 on /mios type squashfs (ro,relatime)
none on /proc/bus/usb type usbfs (rw,relatime)
-4-===========================================================================

Disk /dev/mtdblock0: 0 MB, 524288 bytes
255 heads, 63 sectors/track, 0 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Disk /dev/mtdblock0 doesn't contain a valid partition table

Disk /dev/sda: 15.8 GB, 15833497600 bytes
256 heads, 53 sectors/track, 2279 cylinders
Units = cylinders of 13568 * 512 = 6946816 bytes

   Device Boot      Start         End      Blocks  Id System
/dev/sda1   *           1        2280    15462376   c Win95 FAT32 (LBA)
-5-===========================================================================
SetDataDirectory-/dataMine/
SetMountUUID    -220F-D2F0
SetMountPoint   -/dev/sda1
SetManualMount  -0
-6-===========================================================================
{"dbVersion":2,"Events":{"count":0,"last":0},"Version":"0.980","Variables":[],"Graphs":[],"guiConfig":[],"nextId":1}
-7-===========================================================================

Any help appreciated.

Offline Disconnect

  • Newbie
  • *
  • Posts: 2
  • Karma: +0/-0
Re: New dataMine graphing and logging plugin
« Reply #653 on: August 18, 2013, 10:57:11 am »
Hi,

Trying to use your plug-in, but I can't seem to get it to work.

Installed the app.
Plugged a 16GB USB stick in the Vera3 bottom port. (formatted with FAT32 file system in Windows 7)

Now when I start the GUI, it always makes me select the USB stick.


I had the same problem and I needed to ssh in and 'mkdir /dataMine'. After going through the setup again it started working, mostly.

Unfortunately "mostly" means "except for showing any data points or graphs".. the variables are all listed in the configuration side, but the graphs side is completely blank.

(Update: I figured it out. You have to turn on logging individually in the config for each sensor. I see it in the docs now, but it could probably be highlighted better..)
« Last Edit: August 18, 2013, 12:58:10 pm by Disconnect »

Offline BlueFlame

  • Newbie
  • *
  • Posts: 17
  • Karma: +0/-2
Re: New dataMine graphing and logging plugin
« Reply #654 on: August 19, 2013, 09:06:44 am »
I had the same problem and I needed to ssh in and 'mkdir /dataMine'. After going through the setup again it started working, mostly.
Thanks! I created the dataMine dir on the USB stick. Don't know what I was thinking at that moment...
It works ok now :)

Offline chris66

  • Sr. Member
  • ****
  • Posts: 318
  • Karma: +9/-8
Re: New dataMine graphing and logging plugin
« Reply #655 on: August 29, 2013, 11:59:02 am »
Hi Chris, when I select month or year, after downloading data, I have Warning: Data truncated due to timeout. Is there a place to increase timeout ? Thanks.

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1985
  • Karma: +61/-193
Re: New dataMine graphing and logging plugin
« Reply #656 on: September 06, 2013, 10:18:38 am »
UPDATED

Chris,
This morning I woke up to a graph that has flat-lined, literally. All has been perfectly fine since I removed the USB logging feature - until today. I have not rebooted the Vera well over a month.

This morning...
Datamine graph did not show any datapoints & the \root\Datamine folder 'looked' empty - no files or folders.
 
After reboot it started logging again and the graph is working, even historical - and the folder had files and folders in it again?

All Vera functions were working fine prior to the reboot... except DM

Debug log attached.

Channels: 30
Disk Space Total (kb): 524640
Disk Space Used (kb): 6672
Disk Space Free (kb): 517968

« Last Edit: September 06, 2013, 11:03:39 am by Aaron »

Offline HansW

  • Full Member
  • ***
  • Posts: 109
  • Karma: +1/-0
Re: New dataMine graphing and logging plugin
« Reply #657 on: September 15, 2013, 06:27:52 am »
Hello,

After upgrading my Vera 3 to the latest .622 firmware, Datamine stopped logging and showing data. All I get is flat lines....

I disabled USB logging on Vera without effect and donot dare change anything else since I am afraid to loos the datamine log data.

Please Help!

Attached is the log

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1985
  • Karma: +61/-193
Re: New dataMine graphing and logging plugin
« Reply #658 on: September 15, 2013, 10:55:55 am »
Hello,

After upgrading my Vera 3 to the latest .622 firmware, Datamine stopped logging and showing data. All I get is flat lines....

I disabled USB logging on Vera without effect and donot dare change anything else since I am afraid to loos the datamine log data.

Please Help!

Attached is the log

Try removing the existing DM logs. I have had a problem for at least a year now where DM will stop working (graphing and/or logging) if there are too many files in the folder. How many is too many? No clue. It just happens. I remove the files an it starts working again after a reload.

Offline HansW

  • Full Member
  • ***
  • Posts: 109
  • Karma: +1/-0
Re: New dataMine graphing and logging plugin
« Reply #659 on: September 15, 2013, 11:36:06 am »
Aaron thanks but do you have any concrete pointers on how to accomplish that?

I did manage to login the Vera but cannot see any data letalone logs....

root@MiOS_30102864:~# cd /dataMine
root@MiOS_30102864:/dataMine# ls
Notifications [R2250].txt
Notifications [R2251].txt
Notifications [R2252].txt
Notifications [R2253].txt
Notifications [R2254].txt
Notifications [R2255].txt
Notifications [R2280].txt
dataMineConfig.json
dataMineConfig.json.Fri Sep 13 00-25-26 2013.backup
dataMineConfig.json.Fri Sep 13 02-18-46 2013.backup
dataMineConfig.json.Fri Sep 13 03-00-34 2013.backup
dataMineConfig.json.Sat Sep 14 02-22-47 2013.backup
dataMineConfig.json.Sat Sep 14 02-23-31 2013.backup
dataMineConfig.json.Sun Sep 15 02-16-05 2013.backup
dataMineConfig.json.Sun Sep 15 11-49-36 2013.backup
dataMineConfig.json.Sun Sep 15 12-12-12 2013.backup
dataMineConfig.json.Sun Sep 15 13-39-21 2013.backup
database
sunriseSunset.txt
root@MiOS_30102864:/dataMine# cd database
root@MiOS_30102864:/dataMine/database# ls
1
root@MiOS_30102864:/dataMine/database# cd 1
root@MiOS_30102864:/dataMine/database/1# ls
config.json
root@MiOS_30102864:/dataMine/database/1#
« Last Edit: September 15, 2013, 11:41:55 am by HansW »