Author Topic: openLuup with Imperihome  (Read 299 times)

Offline reneboer

  • Hero Member
  • *****
  • Posts: 1377
  • Karma: +79/-30
openLuup with Imperihome
« on: April 19, 2018, 07:03:57 am »
Hi,

I created this https://github.com/reneboer/openLuup-ImperiHome to get ImperiHome linked with openLuup. It supports all standard types of devices and if you would set includeVeraBridge to true you could even remove your Vera(s) and do all via openLuup. It is also fairly simple to add support for any plugin. To access local is simple, but also remote is possible as you can read in the instructions.

Cheers Rene
« Last Edit: April 19, 2018, 07:06:21 am by reneboer »
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline Buxton

  • Full Member
  • ***
  • Posts: 129
  • Karma: +9/-0
Re: openLuup with Imperihome
« Reply #1 on: April 30, 2018, 02:18:06 am »
Have you been able to get the Imperihome Vera plugin to work on openLuup.  I have not, though, my skills are not what they should be.  I do have the plugin working on a Vera lite, primarily for an inexpensive TTS engine.  The plugin and its TTS works fine on Vera, but I'd like to load the plugin on openLuup for the added trigger type flexibility that ALtUI gives you.  This document outlines the steps to get the plugin talking to an Android device running imperihome:  http://soggyweasels.blogspot.com/2016/03/vera-initiated-amazon-echo-voice.html

Offline Buxton

  • Full Member
  • ***
  • Posts: 129
  • Karma: +9/-0
Re: openLuup with Imperihome
« Reply #2 on: April 30, 2018, 02:23:39 am »
Now it is working, but I had to copy "ihjson.lua" (as well as the regular device files), from the vera overlay folder to the cmh-ludl folder on the openLuup server, then edit the imperihome "I_ImperiHomeDevice1.xml" to say "local ihjson = require('ihjson')" instead of "local ihjson = require('ihjson.lua')", then reload luup. 

The plugin works well.  I also had to download google TTS to my android tablet that hosts imperihome.  Then choose google TTS in the system settings for voice.
« Last Edit: May 05, 2018, 02:26:15 am by Buxton »