We have moved at community.getvera.com

Author Topic: Ecobee App Ported to Openluup  (Read 911 times)

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: Ecobee App Ported to Openluup
« Reply #15 on: May 12, 2018, 11:54:29 am »
In ALTUI try add a device (you probably deleted it) and use the D_Ecobee1.xml and I_Ecobee1.xml as your device files. Your device should come back up.
Alternatively, you could reinstall from the AltAppStore on version 2.02. Having old files should not be a problem anymore.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline bwillette

  • Sr. Newbie
  • *
  • Posts: 47
  • Karma: +3/-0
Re: Ecobee App Ported to Openluup
« Reply #16 on: May 12, 2018, 03:00:19 pm »
I tried both of those without any luck.  I think the device is there, just not showing up in the device display for some reason...I?ll keep digging

Offline bwillette

  • Sr. Newbie
  • *
  • Posts: 47
  • Karma: +3/-0
Re: Ecobee App Ported to Openluup
« Reply #17 on: May 12, 2018, 04:21:50 pm »
Ok, looks like it was an issue with my browser oddly.  I now see the device, and entered my API key in the control panel field and then clicked the 'Get Pin' button.  The API Key field goes blank when I click the button.  Same result as before, and I don't see the Variable you mentioned in my list (see attachment).

Offline bwillette

  • Sr. Newbie
  • *
  • Posts: 47
  • Karma: +3/-0
Re: Ecobee App Ported to Openluup
« Reply #18 on: May 12, 2018, 05:10:10 pm »
Figured it out.  Turns out the instructions to run the 'luarocks' command assumed you had the luarocks package installed and I didn't!  That's why the https call was failing.  Installed that package and now it's all working as expected.

Thanks again for the plugin and the help (and openLuup!)

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: Ecobee App Ported to Openluup
« Reply #19 on: May 12, 2018, 06:02:39 pm »
Glad you got it working! And thank you for the report! I think if you have a recent install of openLuup, https would be embedded. It was not at the beginning but I had installed luarock on mine a while ago and forgot about it.
I will update the instructions in a bit.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.

Offline rafale77

  • Community Beta
  • Hero Member
  • ******
  • Posts: 1749
  • Karma: +101/-27
  • HA ≠ IoT as a blue sky is cloudless.
Re: Ecobee App Ported to Openluup
« Reply #20 on: October 25, 2018, 03:55:28 pm »
For those using this plugin. I just released version 2.1 on the AltAppStore which has a fix for the recent ecobee API update.
openLuup (79 devices, 141 scenes, 19 apps) master to VeraPlus (142 zwave nodes, 8 Zigbee nodes, 221 devices,  20 scenes , 2 apps) +  Hubitat (15 Zigbee nodes) + Home-Assistant (API Integrations). Bridged to Siri and Alexa. Homewave. VeraPlus ExtRooted and mios server independent.