Author Topic: Bug with spinner_horizontal in new UI7 1030  (Read 488 times)

Offline rigpapa

  • Hero Member
  • *****
  • Posts: 670
  • Karma: +101/-1
Bug with spinner_horizontal in new UI7 1030
« on: May 16, 2018, 10:48:20 am »
I just upgraded my Vera3 to 1030 from 1017, and now the default display (non-hover, non-active) for spinner_horizontal buttons is broken, the buttons are too large. If you hover over the buttons, however, they go to the expected size.

@Sorin, is this the correct forum/procedure for bugs like this? In the past, when I've reported these directly to support, half the time I get no replies whatsoever. I don't think they really know how to handle developer issues.

Attached image shows the problem.
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline rgadagno

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Bug with spinner_horizontal in new UI7 1030
« Reply #1 on: May 16, 2018, 02:14:26 pm »
I also upgraded.  I have 3 CT32 in my system and they buttons look fine.  Not sure if this help troubleshoot the issue.

Offline rigpapa

  • Hero Member
  • *****
  • Posts: 670
  • Karma: +101/-1
Re: Bug with spinner_horizontal in new UI7 1030
« Reply #2 on: May 16, 2018, 04:56:17 pm »
Is that the one that uses the "Radio Thermostat Wi-Fi Plugin"? That plugin uses different controls (slider_vertical).
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline rigpapa

  • Hero Member
  • *****
  • Posts: 670
  • Karma: +101/-1
Re: Bug with spinner_horizontal in new UI7 1030
« Reply #3 on: May 16, 2018, 06:55:56 pm »
Just to confirm, the case here seems to be an errant CSS change that occurred sometime between 7.0.23 and 7.0.26. Specifically, the definition of the "spinner_horizontal_arrow_down" and "..._up" classes were changed. For example:

7.0.23:
Code: [Select]
.spinner_horizontal_arrow_up {
  background: url("../img/devices/device_thermostat_arrow_up_static.png") no-repeat;
  background-size: 32px 32px;
  cursor: pointer;
  width: 32px;
  height: 32px;
}

7.0.26:
Code: [Select]
.spinner_horizontal_arrow_up {
    background-size: 32px 32px;
    cursor: pointer;
    width: 32px;
    height: 32px
}

.spinner_horizontal_arrow_up {
    background: url(../img/devices/device_thermostat_arrow_up_static.png) no-repeat
}

So you can see in 7.0.26, the URL spec was moved to a second declaration, but this has the effect of overriding and killing the background-size spec in the earlier declaration, so the icons take the default (large/incorrect) size. The hover declarations, unchanged between the two versions, are coded like 7.0.23, incorporating both the URL and size, and that's why the hover sizes correctly. Not sure why this change would be made, but it seems a mis-step.
« Last Edit: May 16, 2018, 07:00:43 pm by rigpapa »
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 974
  • Karma: +82/-10
Re: Bug with spinner_horizontal in new UI7 1030
« Reply #4 on: May 18, 2018, 04:11:05 am »
Hello Guys,

Checking this with the web team.
I will report it to our bug tracker.
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7