Author Topic: Homewave not Connecting outside LAN  (Read 214 times)

Offline sk1.publicc

  • Sr. Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
Homewave not Connecting outside LAN
« on: June 14, 2018, 01:21:35 am »
I saw the threads about people having issues connecting directly to Vera and bypassing MiOS when on the LAN.
My issue is the opposite.  I can only connect when on the LAN, regardless of if I go direct or via MiOS.

It never connects when I try via 4G or a friend's Wi-Fi service.

I've re-entered the MiOS login name & password to match the one that I use when connecting via the VeraMobile app or browser.  It's definitely correct.  Those apps connect OK via 4G and friend's Wi-Fi.

I've also checked with Vera support that the correct Mios server names are used (they wouldn't help me beyond that confirmation).

My settings are...

Vera IP Address:             <controller IP>
Vera Device ID:              <controller ID>
MiOS UserName:            <Vera username>
MiOS Password:             <Vera password>
Name:                           VeraPlus
URL (internet):               <blank>
Direct to Vera (no Mios): OFF
Ignore MiOS IP setting:   OFF
UI5 Firmware:                OFF
Authenticate locally:       OFF

MiOS Servers

Has anyone else experienced these issues?
I'm running iPhone 8, iOS 11.4, Homewave app v2.9.  VeraPlus FW 1.7.3831

Offline intveltr

  • Moderator
  • Hero Member
  • *****
  • Posts: 1706
  • Karma: +96/-5
Re: Homewave not Connecting outside LAN
« Reply #1 on: June 18, 2018, 06:10:00 am »
Try to connect remotely with logging enabled on the app, then send me the log please. 

There are a few others affected by this issue but thus far I have not been able to reproduce it.  Do you have any weird (non ASCII) characters in your Mios password?
HomeWave is available in the App Store!  Turn your iPhone/iPad into an easy-to-use remote control for Vera.

Offline sk1.publicc

  • Sr. Newbie
  • *
  • Posts: 21
  • Karma: +1/-0
Re: Homewave not Connecting outside LAN
« Reply #2 on: July 01, 2018, 07:12:43 am »
Thanks for looking at this.  Have just sent the logs to you via the in-app email and noted this topic discussion.

I don't have any non-ASCII characters in my password but it is a longer password... 20char+