Author Topic: Another bug in newest firmware (?)  (Read 444 times)

Offline kwieto

  • Hero Member
  • *****
  • Posts: 558
  • Karma: +27/-12
Another bug in newest firmware (?)
« on: June 14, 2018, 12:16:13 pm »
The new firmware introduced change of the icon in devices that have category 3 (switch) subcategory 3 (in wall) - the bulb changed into a plug. This is only visual change but trying to change some device's category I found that the "Turn all on/off" shortcut in dashboard, meant to turn all lights on or off at once doesn't react to changes in devices categories anymore.
For example changing device category to 3, sub 4 (refridgerator switch) should make it dissapear from that shorcut. It doesn't, the current status of such device is still reflected there.
What's strange, if device's category already was 3 sub 4 before the upgrade, its status is not reported in the shortcut, everything works fine.

I tried every subcategory there - from 1 to 6, none did any change - devices are still reported as "lights" in the shortcut, no matter what subcategory i choose.
And I checked two different controllers, so it is not a glitch of the specific unit.

Any idea how to correct this?

Offline HSD99

  • Sr. Member
  • ****
  • Posts: 273
  • Karma: +11/-0
Re: Another bug in newest firmware (?)
« Reply #1 on: June 14, 2018, 01:52:24 pm »
A thought---did you do a LUUP reload after making the change? It may be that the system won't rebuild that database unless there is a reload.

Offline kwieto

  • Hero Member
  • *****
  • Posts: 558
  • Karma: +27/-12
Re: Another bug in newest firmware (?)
« Reply #2 on: June 14, 2018, 03:07:37 pm »
Yes, I did, luup reload is not enough.

I figured it out, you have to do a reboot, only then changes are updated in "my shortcuts" section (devices themselves are updated immediately).
As a sidenote: there is no device category/subcategory which would have a plug icon and wouldn't be considered as "light" by "my shortcuts" at the same time.