Author Topic: Beta 7.0.27b (1036/3917/3918/3919)  (Read 1563 times)

Online rigpapa

  • Hero Member
  • *****
  • Posts: 621
  • Karma: +91/-1
Beta 7.0.27b (1036/3917/3918/3919)
« on: June 19, 2018, 09:37:22 am »
Installed on my Vera3 system that I use as a development sandbox. Bricked. Flashing orange/green. Off to boot my old XP laptop!

EDIT: Before hitting it with the big bat, I tried two full power-off resets. On the second, it came back up. Whew!
« Last Edit: June 19, 2018, 10:08:40 am by rigpapa »
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline rafale77

  • Hero Member
  • *****
  • Posts: 1230
  • Karma: +62/-22
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #1 on: June 19, 2018, 03:56:24 pm »
ran the upgrade too as I somehow got my 7.0.26 suddenly corrupted by editing a scene and ended up having to do a factory reset... I have not observed any changes.
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!

Offline reneboer

  • Hero Member
  • *****
  • Posts: 1353
  • Karma: +76/-30
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #2 on: June 20, 2018, 05:44:28 am »
Managed to install it on VerLite after manually making sufficient flash space available. If there is not sufficient space it quietly fails to do anything.

Seems to be running fine still.

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline kwieto

  • Hero Member
  • *****
  • Posts: 558
  • Karma: +27/-12
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #3 on: June 20, 2018, 09:05:31 am »
I upgraded on of my Plus'es. Controller needed manual reboot after upgrading (it was stuck with BT/Z-wave/Zigbee lights off), except that everything is fine.
I have an impression that it is a little faster, (at least some scene triggered by remote controller seem to react faster than before) but it might be temporary.
I didn't notice any significant change in storage memory or RAM after upgrading

Online rigpapa

  • Hero Member
  • *****
  • Posts: 621
  • Karma: +91/-1
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #4 on: June 23, 2018, 03:13:39 pm »
Day 5 with this firmware on my Vera3. So far, no functional problems, but, I am now noticing two UI oddities, and these occur on both Firefox and Chrome, so I don't think it's a browser issue:

1) Very frequently, the dashboard device display mixes up the icons for devices, and multiple devices will get the icon of some other device; occasionally, a default icon will be assigned to a device. A short time later, the problem rights itself, and then some time after that, the problem repeats itself. Once this begins, it is not a steady state, right or wrong;

2) With alarming frequency, clicking the "Advanced" tab will display the data for a completely different device from the one you are in. There is no warning of this, and no rhythm to it.

In both cases, browser refreshes and Luup reloads do not consistently solve the problem. In fact, the problem seems to occur most often after a Luup reload with a non-refreshed browser (that is, Luup reloads but you don't do a refresh after, which is common because you never really know when Luup is going to reload on its own).

@Sorin, I think this is something you guys need to look into before releasing.
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline Nameless

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-0
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #5 on: June 23, 2018, 06:56:31 pm »

2) With alarming frequency, clicking the "Advanced" tab will display the data for a completely different device from the one you are in. There is no warning of this, and no rhythm to it.

I'm seeing this in the latest non-beta release, at least to some degree. Many times a device name will change after visiting the Advanced section. The names are like "Zigbee Network". Very odd. So, this may have started partially in the last stable version.

EDIT: I'm now seeing icons change, too. My thermostat shows as a camera, etc.
« Last Edit: June 23, 2018, 07:11:54 pm by Nameless »

Offline rafale77

  • Hero Member
  • *****
  • Posts: 1230
  • Karma: +62/-22
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #6 on: June 25, 2018, 01:45:16 am »
This latest firmware broke support for the Jasco 45602W dimmers. Some zwave communications from the vera seem to eventually make the dimmer unresponsive and hang.
openLuup (97 devices, 134 scenes, 20 apps) controlling HomeAss + VeraPlus (138 zwave nodes, 8 Zigbee nodes, 205 devices, 20 scenes , 2 app) Bridged to Homekit and Alexa. VeraPlus ExtRooted!

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 953
  • Karma: +81/-10
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #7 on: June 25, 2018, 04:42:22 am »
Day 5 with this firmware on my Vera3. So far, no functional problems, but, I am now noticing two UI oddities, and these occur on both Firefox and Chrome, so I don't think it's a browser issue:

1) Very frequently, the dashboard device display mixes up the icons for devices, and multiple devices will get the icon of some other device; occasionally, a default icon will be assigned to a device. A short time later, the problem rights itself, and then some time after that, the problem repeats itself. Once this begins, it is not a steady state, right or wrong;

2) With alarming frequency, clicking the "Advanced" tab will display the data for a completely different device from the one you are in. There is no warning of this, and no rhythm to it.

In both cases, browser refreshes and Luup reloads do not consistently solve the problem. In fact, the problem seems to occur most often after a Luup reload with a non-refreshed browser (that is, Luup reloads but you don't do a refresh after, which is common because you never really know when Luup is going to reload on its own).

@Sorin, I think this is something you guys need to look into before releasing.

Thanks, rigpapa, giving a heads up to the team as we speak. However, if you have ongoing trouble with your setup, I advise logging a ticket with our Customer Care team as well.
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7

Online rigpapa

  • Hero Member
  • *****
  • Posts: 621
  • Karma: +91/-1
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #8 on: June 25, 2018, 10:11:21 am »
OK. Child devices seem to be the culprit here. Now that I'm digging into it more, I'm seeing some of the same thing on my Plus with 3232... if I click on a child device, it gives me the attributes of a completely different (non-child) device. If I refresh the browser, I can get it work once, but then it goes off the deep end again. I've been able to reproduce this with the built-in support for Aeotec Multisensor 6 (creates child devices for temperature, humidity, etc.), as well as various plugins that create children (Sonos, HTD, and my own).
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline kwieto

  • Hero Member
  • *****
  • Posts: 558
  • Karma: +27/-12
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #9 on: June 28, 2018, 03:39:34 am »
OK. Child devices seem to be the culprit here.

I don't have such issues with child devices (Vera Plus)
@Nameless reported similar issues after instaling your Reactor plugin (though he blamed Vera's UI, later mentioning that uninstalling the plugin cured the issue).
Maybe this is not related to beta but to your plugin somehow?

Online rigpapa

  • Hero Member
  • *****
  • Posts: 621
  • Karma: +91/-1
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #10 on: June 28, 2018, 07:23:58 am »
Indeec. I'm hoping he'll confirm his issues have abated, but I haven't heard. Tnis seems to rsolve the issues with the Advanced tab. It has not resolved the issue of the icons changing, howver.
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline Nameless

  • Full Member
  • ***
  • Posts: 179
  • Karma: +3/-0
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #11 on: June 28, 2018, 01:35:28 pm »
Indeec. I'm hoping he'll confirm his issues have abated, but I haven't heard. Tnis seems to rsolve the issues with the Advanced tab. It has not resolved the issue of the icons changing, howver.
I haven't had much time to research, but can say I am not having the problems after removing the plugin. I am not on the Beta firmware, just the standard version.

I plan to further test the plugin when I have some free time.

Icon problems have gone away for me, so there may be a correlation existing with the Beta firmware, but I cannot confirm.

Sent from my LGUS992 using Tapatalk


Offline kwieto

  • Hero Member
  • *****
  • Posts: 558
  • Karma: +27/-12
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #12 on: June 28, 2018, 04:41:58 pm »
I don't have icon problems on beta, but I don't look much at UI recently, and I don't have much devices on the controller where beta is installed.

Online rigpapa

  • Hero Member
  • *****
  • Posts: 621
  • Karma: +91/-1
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #13 on: July 02, 2018, 12:33:37 pm »
@Sorin, it looks like the UI trouble was caused by an error on my part in the JavaScript tab for a plugin. I was sorting the array returned by api.getListOfDevices(), assuming it would already be a clone of the UI's official list, but it's clear that it's actually a reference and sorting that list disrupts the UI's expected order of things. Wrapping it in api.cloneObject() easily fixes that issue.

Sorry for raising a false alarm.
Author of Reactor, DelayLight, SiteSensor, Rachio, Deus Ex Machina II, Intesis WMP Gateway, Auto Virtual Thermostat and VirtualSensor plugins. Vera Plus w/100+ Z-wave devices. Vera3 sandbox.

Offline cokeman

  • Full Member
  • ***
  • Posts: 112
  • Karma: +1/-0
Re: Beta 7.0.27b (1036/3917/3918/3919)
« Reply #14 on: July 04, 2018, 04:52:21 pm »
will qubion ZMNHXD1 be supported in the next version ??
Vera 3 in the summerhouse, Vera Plus at home
@Denmark