We have moved at community.getvera.com

Author Topic: Another LUUP script help request...  (Read 1407 times)

Offline M.E.

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Another LUUP script help request...
« on: January 11, 2012, 11:06:16 am »
Hello everyone.  First time on this board and I'd like to say thanks to everyone for the plethora of information here.  Its been a great learning resource.  This is a bit of trivial problem but have not found the answer on this forum or elsewhere.

I'm having no luck getting the the value from the "ConfiguredName" variable from a scene script I have that sends and email notifications for a couple of CT30 thermostats.  In fact I'm not able to get the "ConfiguredName" for any of my Z-wave devices on my network.

The code I'm using is:

local deviceName = luup.variable_get("urn:micasaverde-com:serviceId:ZWaveDevice1", "ConfiguredName", THERMOSTAT_ID)

The "THERMOSTAT_ID" is set before-hand in the script.  The script fails to run successfully, i.e. I don't get an email notification if I include the above line.  If I remove the above from the script it all is well and I'm able to get values from the CT30 "related" variables like "temperature" and "mode".

I did notice the "S_ZWaveDevice1.xml" file which defines the UPNP service and variables is not listed in the list of files on the "LUUP Files" tab.  Not sure if thats the problem but would greatly appreciate some guidance/help in getting the "ConfiguredName" value for Z-wave devices.

My setup is a VERA2 at version 1.1.1362 and ZWAVE version 3.20 L:1 (with 2 x CT30, 2 x GE45609 and 1 x LFM-20)

Many thanks.

Offline oTi@

  • Community Beta
  • Master Member
  • ******
  • Posts: 4041
  • Karma: +32/-6
  • UI what ?!
Re: Another LUUP script help request...
« Reply #1 on: January 11, 2012, 12:01:00 pm »
@M.E.,

Welcome!

You can use luup.devices[THERMOSTAT_ID].description to get that info.
« Last Edit: January 11, 2012, 12:02:32 pm by oTi@ »
Dezwaved at the moment...

Offline M.E.

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
Re: Another LUUP script help request...
« Reply #2 on: January 11, 2012, 12:36:22 pm »
Brilliant!.  Thanks very much oTi@