We have moved at community.getvera.com

Author Topic: Plugin for the USB RFXtrx from RFXCOM  (Read 308098 times)

Offline b_weijenberg

  • Full Member
  • ***
  • Posts: 129
  • Karma: +3/-1
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #645 on: November 17, 2012, 08:37:12 am »
The latest RFXtrx433 firmware is version 57.
Version 52 has an improvement for the Mertik Maxitrol G6R-H4T1

After the firmware update check with RFXmngr if the Mertik remote is received.

Disable the oregon protocol because this protocol will stop receiving of Mertik. See chapter 2.3 in the RFXtrx User Guide

Offline DRuw

  • Jr. Member
  • **
  • Posts: 93
  • Karma: +0/-0
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #646 on: November 17, 2012, 09:59:40 am »
TNX! Solved!
I had to remove the RFXcom controller widget and add it again (it kept v49) but now its v57 and it works with the fireplace (just in time for chrismas!)
I think its best when I give commands to the fireplace in a scene, Ill repeat the command after 2 and 4 seconds, just to be sure (its still not zwave:() but this is really nice!
Now to add the KaKu units again because I lost all things related to the RFXCOM...
Tnx again, you guys made my weekend!

Edit: got the Kaku also reinstalled (forgot I turned it off in the config..) The shutting off of the fireplace works every time but the surning on is a bit buggy... I need to hit the button to turn off first (sometimes several times) untill I hear a *beep* and then turn it on and then it works.
Can't seem to get the logic here since I've tried to put it in a scene where I turn it off first 2 times with 2 secs interval and then after 10 secs turn it on but doesn't seem to work either.. Is this something purely because its RF and do you guys have the same thing or am I overlooking something?
Btw: the *beep* is the end of the gas valve I think but it looks like when I give the "turn on" command without having heard the *beep*it opens the gas valve but doesn't ignite the thing (first step BEFORE opening the gas valve further than pilot mode) which seems a bit unsafe to say the least...
« Last Edit: November 17, 2012, 10:47:01 am by DRuw »

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #647 on: November 17, 2012, 10:45:16 am »
Here's what I did,
I walked to the RFXCOM and held my remote 10 cm away from it when I pushed the two buttons that start my fireplace.
code: Last received message:04 02 01 07 00
When I press the off button: Last received message:04 02 01 07 00
So apparently the RFXCOM doesnt pick it up for some reason (my fireplace lit up and shutted down since he did receive the remote control signals...)
ps: ive got firmware version v49 of the rfxcom controller according to the settings tab... is that correct?

Yes, please update the firmware, if you check the history of versions for the RFXtrx firmware, you will see changes relative to the Digimax after v49.

Offline nlrb

  • Sr. Member
  • ****
  • Posts: 444
  • Karma: +13/-0
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #648 on: November 18, 2012, 08:25:11 am »
...The shutting off of the fireplace works every time but the surning on is a bit buggy... I need to hit the button to turn off first (sometimes several times) untill I hear a *beep* and then turn it on and then it works.
Can't seem to get the logic here since I've tried to put it in a scene where I turn it off first 2 times with 2 secs interval and then after 10 secs turn it on but doesn't seem to work either.. Is this something purely because its RF and do you guys have the same thing or am I overlooking something?
Btw: the *beep* is the end of the gas valve I think but it looks like when I give the "turn on" command without having heard the *beep*it opens the gas valve but doesn't ignite the thing (first step BEFORE opening the gas valve further than pilot mode) which seems a bit unsafe to say the least...
The way it has been implemented is as follows.
  • First On will send the 'On' command (turning valve open, start-up beeps)
  • Second On will send the 'Runup' command (go to maximum setting, no beeps!)
  • First Off will send the 'Rundown' command (go to minimum setting, no beeps!)
  • Second Off will send the 'Off' command (close valve, beeps)
Once the fireplace is off, you won't be able to turn it on without waiting 5 minutes first (see the manual).

Offline DRuw

  • Jr. Member
  • **
  • Posts: 93
  • Karma: +0/-0
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #649 on: November 18, 2012, 08:35:34 am »
Once the fireplace is off, you won't be able to turn it on without waiting 5 minutes first (see the manual).
Wow, I think thats it... I dont have the manual.. it was in my house when I bought it and never looked for it actually.
Thanks for the info!

Offline wrc55

  • Newbie
  • *
  • Posts: 5
  • Karma: +0/-0
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #650 on: November 20, 2012, 04:37:04 am »
Hi

This is my first post, so sorry if it's a stupid one

I have added the RFXtrx it sees devices such as Owl energy monitor and next doors rain sensor :-)

I am trying to add a LightwaveRF dimmer light switch (I disabled all functions apart from AD and Oregon and upgraded to v57 firmware on a PC) - want to test it as these look so much better than any z-wave switches I can find (and are cheaper)

But It doesn't see it

I saw that if no remote exists it needs to be added manually - but if I try and do anything in the master device it just says "invalid service" (hence the reason for changing the enabled protocols on a PC)

Can anyone help?

- Andrew

Offline shapa

  • Jr. Member
  • **
  • Posts: 95
  • Karma: +0/-0
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #651 on: November 20, 2012, 01:41:07 pm »
LWRD is disabled by default in the newest FW's

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #652 on: November 20, 2012, 02:13:51 pm »
I saw that if no remote exists it needs to be added manually - but if I try and do anything in the master device it just says "invalid service" (hence the reason for changing the enabled protocols on a PC)

It looks like the plugin is not well installed. Either the files you donwloasded are corrupted or you fogot to upload few of them.

Offline lolodomo

  • Moderator
  • Master Member
  • *****
  • Posts: 3484
  • Karma: +74/-10
Re: Plugin for the USB RFXtrx from RFXCOM
« Reply #653 on: November 20, 2012, 03:26:29 pm »
I lock this topic.
Please use the topic relative to a recent version of the plugin or create a new topic to explain your problem or ask your question.