We have moved at community.getvera.com

Author Topic: Vera App slow start  (Read 1919 times)

Offline shady.hamilton

  • Jr. Member
  • **
  • Posts: 70
  • Karma: +5/-2
Vera App slow start
« on: June 27, 2018, 08:47:02 am »
Hello All,

when i start my VERA app, it take a very long time to load, when i contacted the support they said that is because i have many devices and the app has to confirm (Every time) what is new with my system.  obviously this is not ideal and when somebody wants to control something via mobile, he/she is in a hurry, so waiting all that time is not convenient at all.

why can't we have the same options as Fibaro or Impirihome, the apps just lunch directly without refreshing the info, and if you need to referesh the info you just go to the settings and do that. every 20 or more times i Launch the app, one time i will have something new which needs that needs refresh, all the other times i am just waiting for the app to load for nothing.

can somebody from the admins advice if we can have this option please.

thank you,

shady

Offline Sorin

  • Administrator
  • Hero Member
  • *****
  • Posts: 1135
  • Karma: +103/-11
Re: Vera App slow start
« Reply #1 on: June 27, 2018, 09:53:09 am »
Hello Shady,

I'm really sorry to hear this. Even with preloading, it should not take more than 5-10 seconds. On my personal Vera unit with ~30 devices and plugins, I counted 8 seconds via 4G network and under 5 seconds over wifi.
Sorin M. ▾ Community Manager
Vera Control, Ltd. ▾ Smarter Home Control  ▾ support@getvera.com ▾www.getvera.com ▾ +1 (866) 966-2272

HOURS OF OPERATION for Customer Care Department - 24/7

Offline gniknalu

  • Full Member
  • ***
  • Posts: 195
  • Karma: +4/-2
Re: Vera App slow start
« Reply #2 on: June 29, 2018, 12:15:36 pm »
On a Samsung Galaxy Note 8 (64 GB) it takes 10 seconds to load the app and then 8 more seconds to wait for the "Establishing Connection" to go away - even when I'm on WiFi. Pretty SLOW if you ask me.

Offline shady.hamilton

  • Jr. Member
  • **
  • Posts: 70
  • Karma: +5/-2
Re: Vera App slow start
« Reply #3 on: June 29, 2018, 05:33:54 pm »
That is my point, it is pretty slow, it is much slower with me, the question is why we are pooling the devices every time, it is wrong and should not be the case.

Offline kwieto

  • Hero Member
  • *****
  • Posts: 624
  • Karma: +27/-15
Re: Vera App slow start
« Reply #4 on: June 30, 2018, 09:47:28 am »
I think there is something about Android app in general.
I'm testing that app for a couple of days (before I used Windows Phone app) and found that sometimes it is not updating devices status properly (presenting the device as off while it is in fact off). Yesterday I couldn't connect to my Vera at all. I thought that there are again issues with memory (common symptom is device becoming unavailable to access) but when I logged through web browser (on the same Android device) everything was correct (including devices' status).
Windows app seemed to be working fine as well.

Offline Don Phillips

  • Hero Member
  • *****
  • Posts: 1464
  • Karma: +41/-36
Re: Vera App slow start
« Reply #5 on: June 30, 2018, 10:32:48 am »
The iOS app takes almost 10 seconds to load including loading data from Vera. I have an iPhone 6 so a lot of my apps take about that long to load as well.
Vera 3, 1.7.1040, CT101, Everspring Motion, GE/Jasco Switch/Dimmer, Leviton outlet, AeonLabs sensor, NuTone garage door, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual/Multi Switch, LB60Z-1 bulb, Hue, Alexa, Zooz 4-1

Offline HSD99

  • Sr. Member
  • ****
  • Posts: 384
  • Karma: +20/-0
Re: Vera App slow start
« Reply #6 on: June 30, 2018, 11:18:56 am »
On an iPhone 7, running on my LAN, the Vera app takes 5 seconds to open, as compared to the VeraMate app which takes almost 10 seconds. Google Maps takes about 5 seconds,  as do many other apps that need to update external data.

Offline shady.hamilton

  • Jr. Member
  • **
  • Posts: 70
  • Karma: +5/-2
Re: Vera App slow start
« Reply #7 on: June 30, 2018, 11:23:24 am »
Compare vera app with fibaro app with impirihome.....  fibaro and impirihome are almost instant....  vera take 10 seconds at best.... again the problem is cashing everything everytime. The argument is why we are doing that?

Offline Don Phillips

  • Hero Member
  • *****
  • Posts: 1464
  • Karma: +41/-36
Re: Vera App slow start
« Reply #8 on: June 30, 2018, 11:57:32 am »
I just checked SceneFlow in iOS - it was a little peppier at about 7 seconds to open and a second to populate the device statuses.
Vera 3, 1.7.1040, CT101, Everspring Motion, GE/Jasco Switch/Dimmer, Leviton outlet, AeonLabs sensor, NuTone garage door, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual/Multi Switch, LB60Z-1 bulb, Hue, Alexa, Zooz 4-1

Offline gniknalu

  • Full Member
  • ***
  • Posts: 195
  • Karma: +4/-2
Re: Vera App slow start
« Reply #9 on: July 04, 2018, 08:43:34 am »
I'm really sorry to hear this. Even with preloading, it should not take more than 5-10 seconds. On my personal Vera unit with ~30 devices and plugins, I counted 8 seconds via 4G network and under 5 seconds over wifi.

Hello Sorin. Have you seen the comments since your reply?

In the house, my Note 8 takes advantage of our 802.11 AC network which is pretty quick. And, on the Note 8, I've tried it after a fresh restart and no other apps running. It still takes ~10 seconds to just open and additional time to "connect".

Funny story: We turned off the TV and were going to bed but the motion sensor on one of our lights has been removed (because it is unreliable). I told everyone, "Hold on - I'll turn it on with the app!" Waiting in the dark, by the time it opened, add 5 more seconds for the light to respond. With the light on, I noticed I was standing there alone because no one wanted to wait that long in the dark. . . .

Looking forward to application updates for Android that would provide a performance boost.