We have moved at community.getvera.com

Author Topic: Killing running jobs / reset secure connection.  (Read 327 times)

Offline Dr.Penny

  • Newbie
  • *
  • Posts: 3
  • Karma: +1/-0
Killing running jobs / reset secure connection.
« on: July 05, 2018, 11:43:24 pm »

So I've had on a few occasions, had a job that's running which doesn't seem to want to stop. In this particular case I was tweaking the dimming level on a light when vera became unresponsive to further changes. I think there was too many tweaks in a short space of time.

After this there was a whole pile of:


Code: [Select]
24      07/06/18 11:34:45.190   ZWaveJobHandler::DoReceivedFrame m_iFrameID 759 gwf_ach node 14 command 0x4 data  <0x76d16520>
24      07/06/18 11:34:45.191   ZWaveJobHandler::DoReceivedFrame m_iFrameID 759 collission with job#69 :Level 98 node 13 dev:26 (0x11c3580) N:13 P:70 S:7 Id: 69 <0x76d16520

in the logs, and eventually the device became unresponsive.

I did connect the device using the secure protocol, after the failure the logs show:

Code: [Select]
02      07/06/18 11:37:48.221   ZWaveSerial::GetFrame 0x76715a2c timed out now 0 m_listGetFramePending 0 <0x76716520>
01      07/06/18 11:37:48.221   ZWaveNode::GetNonce node 13 failed <0x76716520>
24      07/06/18 11:37:48.222   GetFramePending::~GetFramePending 0x76715a2c <0x76716520>
24      07/06/18 11:37:48.222   ZWaveSerial::CancelInterceptFrame 0x76715a2c now 0 m_listGetFramePending 0 <0x76716520>
01      07/06/18 11:37:48.222   ZWaveNode::EncryptFrame m_iFrameID 952 cannot get nonce node 13 command class 0x26 command 0x2 <0x76716520>
02      07/06/18 11:37:48.222   ZWaveSerial::Send m_iFrameID 952 type 0x0 command 0x13 sent ok - can't encrypt <0x76716520>
10      07/06/18 11:37:48.222   UserData::m_iDataVersion_Variables_incr zwpoll user data 847485006 variables 847486185 <0x76716520>

and then it won't reconnect again.

Is there

- A chance that the secure connection will reconnect?
- Any point to using a secure connection, is it always gonna do this?
- Any way of killing a job that's failing?

The device in question is an Aeotec Nano Dimmer, and the controller is a Vera Plus.

Thanks