Vera - Smarter Home Control Forum

General => General => Topic started by: Kryckmeister on January 30, 2016, 11:21:28 am

Title: RFXcom - adding new devices => RFXtrx : CreateNewDevice: invalid arguments
Post by: Kryckmeister on January 30, 2016, 11:21:28 am
I upgraded to UI7 in december and haven't added any new devices to the RFX after the upgrade. When I do try to add devices (AC or ARC, which both are enabled) I get "Vera will reload to validate the changes..." followed by "RFXtrx : CreateNewDevice: invalid arguments" at the top.

I can't figure out what to do. The 433 devices already created work as they are supposed to.
Title: Re: RFXcom - adding new devices => RFXtrx : CreateNewDevice: invalid arguments
Post by: dreynolds09 on October 13, 2017, 04:07:22 am
Hi - did you resolve this? I am having the same issue. It comes up as "Vera will reload to validate changes...." , and then nothing happens!
Title: Re: RFXcom - adding new devices => RFXtrx : CreateNewDevice: invalid arguments
Post by: TDMA on October 16, 2017, 11:21:43 am
I have this issue as well after upgrading to newest firmware on Vera Edge.
I can't manually add a new device for the RFXtrx or start to auto creation mode.
Title: Re: RFXcom - adding new devices => RFXtrx : CreateNewDevice: invalid arguments
Post by: blupo on October 30, 2017, 02:08:49 pm
I meet the same issue with Vera plus after upgrading the last firmware version 1.7.3232.
I have a Rfxtrx with which I created 11 blindcovers Somfy RTS during August 2017.
Now I want to create a new RFY device, and this message appears on screen "Vera will reload to validate changes...." , and after nothing happens.
Any idea to fix that?
Thanks
Title: Re: RFXcom - adding new devices => RFXtrx : CreateNewDevice: invalid arguments
Post by: zedrally on October 30, 2017, 06:52:27 pm
Do not upgrade to new FW, there is a documented bug with ports.
Best to revert to previous software and wait until MIOS fix the problem they created.
Title: Re: RFXcom - adding new devices => RFXtrx : CreateNewDevice: invalid arguments
Post by: Cricri on December 23, 2017, 04:06:21 am
Hi,

I had the same problem (impossible to create new device RFY).

I have downgraded to 1.7.1754 and now it's working fine.

The URL to use for downgrade is http://dl.mios.com/firmware/mt7621/mios/release/mt7621_Luup_ui7-1.7.3015-en-mios.squashfs