Recent Posts

Pages: [1] 2 3 ... 10
1
I'm having this problem again as well. It was a backend problem last time so I'm assuming it's that again. Can someone please take a look?
2
General / Security Cert and get vera down
« Last post by Priest on Today at 09:40:41 am »
the getvera site has a cert issue and is returning "NET::ERR_CERT_DATE_INVALID".  once I tell my PC to connect anyway I cannot log in.
3
Alternate UI to UI7 / Re: ALTUI : Version Log
« Last post by amg0 on Today at 08:44:12 am »
V 2.07.2273

    "Asynchronous calls to IFTTT web service",
    "update loadash.js to 4.17.4",
    "add ability to have multiple data push providers for a given device variable",
    "automatically save the data push parameters when the user close the device variable window",
    "fix color in quality chart"

NOTES
multiple data push providers for a given device's variable enable to send simultaneously variable changes to a thingspeak and a IFTTT scenario for instance. cf more info here : http://forum.micasaverde.com/index.php/topic,35860.msg336754.html#msg336754
4
Plugins & Plugin Development / Re: New Plugin: Deus Ex Machina
« Last post by Priest on Today at 08:40:57 am »
I have a ridiculously stupid question . . .

I have searched for the plugin/app and installed it.  I see the device it has created, and I can toggle it to enable/disable it.  But where is the configuration tab that the documents reference?  I've looked and looked and I can't find it . . . probably because it's staring me in the face . . .

Thanks!
5
Hi All of the scenes i ran last week to turn on my TV and etc not longer run on Alexa.  Alexa "Scene Name doesn't support that"  DO we have an update around that issue? :'( :'( :'( :'(
http://stspg.io/8c2629545

Quote
Amazon Alexa communication IssuesIncident Report for Vera Control, Ltd.New Incident Status: IdentifiedUPDATE: Regular on/off switches and thermostats should work now. Dimmers and Scenes are still having issues. We are closely working with the Amazon team and will post updates here.Dec 18, 01:02 PSTPREVIOUS UPDATESInvestigatingWe have reports that some users may experience an issue controlling devices with Amazon Alexa. We are actively investigating with Amazon and will post updates here.

Sent from my SM-G930P using Tapatalk

6
General / Re: lua expressions with less than
« Last post by akbooer on Today at 06:48:54 am »
Well, that's the point.  It's NOT meant to be escaped.  No excuse for that it Lua.

However, in XML device files, where Lua is embedded, you do need the XML escape.
7
Amazon Alexa / Re: Today's Alexa App Update Now Controls Devices
« Last post by darbey on Today at 06:48:00 am »
It also allows you to add Vera devices to routines.
8
General / Re: lua expressions with less than
« Last post by dualarrow on Today at 06:42:07 am »
According to vera's Settings/Firmware I'm running the latest. It say version 1.7.3231

Any idea how it's meant to be escaped ?
9
General / Re: lua expressions with less than
« Last post by akbooer on Today at 06:38:46 am »
No, it's Vera that has got things wrong.  They really screwed up special character handling on some firmware releases.  I had thought that it was fixed... are you not running the latest version?

An even better alternative is to install the AltUI plugin which gives you a much better interface and, in particular, a Test Lua window which actually works and also allows use of a print statement, which really help debugging.  Try it, you'll like it!
10
General / lua expressions with less than
« Last post by dualarrow on Today at 06:29:31 am »
I'm tring to get a less than "<" operator working in lua using the "Test Luup code (Lua) in Apps/Develop Apps

If I use a line like

local yy=12
local xx=yy==100

then clicking "go" says "Code sent successfully" as expected, but if I enter

local yy=12
local xx=yy<100

then clicking "go" says "Failed to test code, please try again"

Anywhere I try to use a less than sign I get the same result. I tried using &lt; in case it needed to be html escaped bu that didnt help.

Am I doing anything obviously wrong ?
Pages: [1] 2 3 ... 10