The Vera Community forums have moved!

General => Upgrading => Topic started by: deepsnow on August 09, 2018, 02:19:04 pm

Title: Problem after update to 1.7.4001
Post by: deepsnow on August 09, 2018, 02:19:04 pm
Hello.

Everything was working perfectly until I did this update.

Now, everything still seems working, except my scenes to shut off my lights at sunrise. I have to manually reboot my Vera Plus every morning, then I can turn the lights off through the web interface. They turn on at sunset, but never turn off.

I can see the event is being triggered like it should, but the communication seems lost with my z-wave LED bulbs until I reboot. I can still communicate with my door lock, so it is just the light bulbs.

I have 4 of these units in 4 different homes. This is the only one I have upgraded so far. Soon I will not be at this house to reboot the controller, so my home automation is a lot less automated.

Any ideas?

Is there an automatic reboot scheduler I can run in the middle of the night that would simulate me rebooting the controller?

Can I downgrade firmware?

Any other options you know of?

Thank you,
Scott
Title: Re: Problem after update to 1.7.4001
Post by: Sorin on August 10, 2018, 03:59:07 am
Hello there,

I'm sorry to hear this, but before trying anything else I would suggest having our Customer Care having a look at it.
Contact details are in my signature.
Title: Re: Problem after update to 1.7.4001
Post by: HSD99 on August 10, 2018, 10:04:19 am
I'm sure that Customer Care will sort things out for you. It's quite easy, however, to create a scene that will reboot your Vera on a schedule. Search the forum---there are a number of examples. If you still have questions, let us know.
Title: Re: Problem after update to 1.7.4001
Post by: Sammy2 on August 13, 2018, 04:16:03 pm
I'm sure that Customer Care will sort things out for you. It's quite easy, however, to create a scene that will reboot your Vera on a schedule. Search the forum---there are a number of examples. If you still have questions, let us know.

I was unsuccessful in the suggested search. Can you say how this is done? Currently I use a WiFi switch from afar to reboot the Vera when necessary.
Title: Re: Problem after update to 1.7.4001
Post by: jswim788 on August 13, 2018, 04:45:01 pm
See this thread for one example: http://forum.micasaverde.com/index.php?topic=60670.0
Title: Re: Problem after update to 1.7.4001
Post by: HSD99 on August 13, 2018, 05:51:04 pm
That's the thread I had in mind.  There is a terminology issue that we should mention. The thread discusses using the OS "reboot" command to restart Vera. This has various names: warm boot, restart, warm start. Power is not cycled to the Vera. The OS does a clean shutdown before the restart.

Power cycling is different. The OS probably doesn't do a clean shutdown (unless Vera has a power-fail interrupt), but the design of embedded Linux systems should prevent problems with a sudden power loss. When power is restored, the power-on reset hardware in Vera resets the hardware to a known state. This does not occur with an OS reboot.

This is why you may see a difference between an OS reboot and a power cycle. Hopefully, the OS reboot will do what you want. For example, the Z-Wave co-processor seems to be able to get itself wedged, with a power cycle the only thing that will fix it. In my experience, this is rare.
Title: Re: Problem after update to 1.7.4001
Post by: Maegda on August 31, 2018, 10:58:32 am
Hello,

I sent you an email, you may reply if you still need assistance.

Thank you!