The Vera Community forums have moved!

General => Remote Control => SQ Remote / Square Connect (iOS) => Topic started by: MTB on December 02, 2012, 05:19:57 pm

Title: Problems Connecting SQ Blaster to Home Network
Post by: MTB on December 02, 2012, 05:19:57 pm
I bought the SQ Blaster + a few weeks ago and tried for two weeks working with Square Connect Tech Support to get it to work with my Netgear 6300 router.  I was never able to get it to work.  I finally got the SQ Blaster + to connect to my network and could see it as a connected device, but in the SQ Remote HD software I could not get the Blaster to show as connected.  On the Setup screen it showed connected [1/2].  When I installed the Blaster after downloading the USB drivers and updating the firmware, it stated successfully connected to the network.  John for SQ Tech Support had me turn of the 5GHZ part of my router and this seemed to help me get the Blaster connected to the network but I could never get the Blaster to work in the SQ Remote HD app. 

I have since returned the Blaster to Amazon for a refund, but I think the SQ Blaster is the best option for me.  John suggest that my Blaster might be defective.  So my question is has anyone else had a problem connecting the SQ Blaster to their network?  If so, what was your solution?  I am trying to decide if I should order another Blaster and see if I just had a defective one.  Any suggestions?

Also, I just purchased the Netgear 6300 about 6 weeks ago and I think it is a newer more powerful router.  This is why I purchased it for my home.  Maybe the router is the problem?
Title: Re: Problems Connecting SQ Blaster to Home Network
Post by: mwp on January 26, 2013, 02:36:43 pm

I had purchased the SQ Blaster Plus and I had problems with my first one.  I worked with John quite a bit over emails.  The problem that I had was the "learning mode".  I could use some database IR codes but couldn't get it to learn.  We went through Bonjour on my MAC to test communications directly.  After about three days back and forth, we performed numerous tests and changed a number of settings on my Netgear 3800 router.  Finally, John determined that I had a bad SQBlaster Plus.  I shipped it back and he immediately sent me a replacement.  The second SQBlaster Plus worked better but "learning mode" still gave me problems.  I persevered by using Pronto codes for the devices that the SQBlaster could not learn.  I stabilized my setup and didn't try anything more extensive for about 4 months.  After adding some more equipment last month I decided to give it another go and whoa and behold things started to work like they should.  I didn't look a gift horse in the mouth and have actually added a bunch of devices to my Home Theater configuration with relative ease. 

The quirks that I noticed in learning is that you sometimes have to retry learning, even after it says "learning successful". Make sure you "test" after each learned IR code and be real patient.  I had great hopes for the SQBlaster Plus but it kinda leveled off.  I like the SQBlaster Plus capabilities and have even installed a "15 year old Radio Shack" IR to RF to IR remote in my Upstairs Great Room to control my Great Room AV system from my Downstairs Home Theater SQBlaster Plus.  It works well. 

One thing I remember was to make sure you "quit" (double click the button and wait for "jiggle" then "-"  SQRemoteHD) the iOS App each time you make changes to "setup" or in some cases if you update your vera or add devices or scenes. The SQ Remote HD didn't pick up the changes until I quit then reloaded SQRemoteHD App.  I'm sure I will remember more. If you are still interested (I know this has been about 1 1/2 months old posting) I may be able to shed some light on problems to help.

Good Luck.

Title: Re: Problems Connecting SQ Blaster to Home Network
Post by: MTB on January 30, 2013, 06:41:42 pm
Thanks MWP!  I have been waiting to hear from someone and also for SQ Blaster to be back in stock.  Over Christmas there were none available.  i wanted to order another one and see if mine was just not working correctly.  I am concerned however that Square Connect is under staffed and not as responsive or attentive to the SQ Blaster as they should be!  I will let you know if I order one!!!  Thanks again!
Title: Re: Problems Connecting SQ Blaster to Home Network
Post by: nathanhall on March 23, 2013, 10:02:26 am
I've had continuous problems with my SQ blaster plus and I would not recommend the product to anyone at this point.  I'm on the latest firmware, have a static IP set on the blaster and on the SQ blaster iOS software configuration, and the SQ blaster hardware still drops offline intermittently.  The unit is located about 3 feet from my wifi router so it isn't a signal problem.   I logged some data for the SQ blaster's connectivity through a day long ping test - the unit drops off the network every few hours, stays inaccessible for about an hour or two, and then sometimes manages to reconnect itself.

Great concept - but poor execution, and no response on the SQ blaster company's forums resolving this known issue that I can find.
Title: Re: Problems Connecting SQ Blaster to Home Network
Post by: Piwtorak on March 23, 2013, 12:41:38 pm
My is connected to apple airport extreme and no problem occurs for months.
Maybe the problem is with the router.
Title: Re: Problems Connecting SQ Blaster to Home Network
Post by: bucko on March 23, 2013, 08:19:48 pm
I've been teating my SQ + since I got it in Jan. I am finding that it will stop working about once a week. The only cure to get it back online is to reboot it. I have static IP set up as well.

There is definitely something amiss that is causing the SQ to crash. My fix will be to run it's power through one of my Elk relays so I can reset it remotely. I may even just have it reboot every 24 hrs via a rule.

But I wish SQ Blaster people would look into this. Something is not right.
Title: Re: Problems Connecting SQ Blaster to Home Network
Post by: KennyB on March 26, 2013, 10:01:22 am
I have 2 SQ Blaster+ connected to Verizon FIOS routers. I found that a 2.4ghz cordless phone was causing network communication issues. I switched to 5.8ghz phones and the SQ Blasters have been rock solid ever since.
Title: Re: Problems Connecting SQ Blaster to Home Network
Post by: StarkInd on May 07, 2013, 02:48:52 am
I have SQ IR Blaster with my Vera 2 + Fibaro Modules controlling from SQRemote HD on my iPhone

Whole system work very fine except the SQ IR Blaster. Most of the time there is no connectivity. In the SQ Remote HD it shows 'Connected 1/2'. Randomly it will get connected. 

And i dont think it has got to do with it being defective cz i have 2 more SQ IR Blaster & all seem to give me same trouble.

 Not able to figure out what exactly creates this trouble. Its a very nice good product for me but its getting annoying due to such issues.