The Vera Community forums have moved!

General => Remote Control => ImperiHome (Android) => Topic started by: BOFH on September 02, 2013, 07:02:08 pm

Title: cannot read stream when camera is on different WiFi WLAN
Post by: BOFH on September 02, 2013, 07:02:08 pm
I'm noticing this weird behavior in Imperihome and could have sworn this used to be no problem.

Android device connected to my main WiFi on the 192.168.0.x subnet
Vera 3's WAN port is on that same subnet with a static IP assigned.
Vera 3's WiFi has it's DHCP assign addresses on its 192.168.10.x subnet (I want to keep my HA network separate from my main data network)
My Foscam FI8910W camerasare connected to Vera's WiFi
I can access the camera's from any web browser on my  192.168.0.x subnet
all camera's are setup in Vera, including the FI8905W

When attempting to obtain the camera stream on any of the FI8910W cameras, Imperihome fails with a 'unable to read stream'.

This happens on both my HP Touchpad with CyanogenMod 9 and my RikoMagic TVStick with Android 4.1.1
When running AuthomationHD on either device (under the same conditions), it can access the camera streams without an issue

I hooked up a Foscam FI8905W camera to the 192.168.0.x subnet and ImperiHome has no issues accessing the camera stream for that camera.

When I connect the HP Touchpad to Vera's Wifi, Imperihome has no problems accessing all camera's on both subnets.

When I am at work and run ImperiHome on my HP Touchpad (We have a public WiFi) I can access all camera streams without an issue.

 

Title: Re: cannot read stream when camera is on different WiFi WLAN
Post by: BOFH on September 02, 2013, 07:26:01 pm
Interesting. I switched Local WIFi SSID from my main data LAN (where the android devices are connected to) to the HA LAN and now it's working fine. So when in local mode it seems to be a bit picky where camera's are concerned (As other devices work fine)
Title: Re: cannot read stream when camera is on different WiFi WLAN
Post by: MalikAutomation on September 14, 2013, 09:29:50 am
I have two cams installed and its only picking up Foscam Fi8910W but the other Foscam its not picked up yet. today I installed the latest update on my android but still with no luck. All devices are installed with only one Camera. I checked Vera Mobile, AuthomationHD and HomeBuddy, both cams are working.