The Vera Community forums have moved!

General => Remote Control => AutHomation (Android) => Topic started by: KJBond on September 23, 2014, 04:17:35 pm

Title: Remote Access
Post by: KJBond on September 23, 2014, 04:17:35 pm
Hi There

i am in the first week of using my vera system still trying to figure things and terminology out.

i seem to have AutHomation working correctly when connected to my local network but if i turn Wifi off my phone it comes up with invalid unsername/password.

is there something i am missing?

from other post it seems as if the firmware version makes a difference i am on version 1.7.318

any help would be appreciated.

Thanks

Title: Re: Remote Access
Post by: garrettwp on October 15, 2014, 10:29:22 am
You need to make sure that MMS is checked and you have the appropriate remote server urls entered in the active, primary and secondary url fields for the Vera connection settings.

- Garrett

Title: Re: Remote Access
Post by: stridera on October 21, 2014, 11:48:02 pm
I get MMS Unknown Auth Error.  Any way I can get logs?
Title: Re: Remote Access
Post by: garrettwp on October 22, 2014, 06:21:15 am
Can you be more specific, are you on firmware UI6 or UI7?

Do you have an account on home. getvera.com?

Has this worked previously or first time trying this?

- Garrett

Title: Re: Remote Access
Post by: charlesmerceriii on October 31, 2014, 12:21:22 pm
Hello there, I am also having issues with remote access and thought I would jump in here in lieu of creating a new thread.

Allow me to explain the goofy scenario that I have created for myself!

1. Vera was set up with ui5
2. Login was created, which i believe is linked to here - https://cp.mios.com/login.php
3. Was working alright, device was added to account and everything, with ip of 192.168.1.151
4. figured out how to upgrade firmware, upgraded to ui7
5. At this point, I believe i created a duplicate account or somehow introduced some redundancy into the system.
6. with the new login, i use that to log into here - https://home.getvera.com/users/login
7. Linked vera to that account and now the ip is 192.168.1.152

So now, whenever i try to auto configure the vera, it is still picking up the .151 ip somehow, which doesnt work, and then when i log into the cp.mios with the old info, I can no longer access anything through that interface to try to un link it from that account, and im stumped. the original mios login used to work with remote access before i upgraded firmwares, and now i can't get either login to work. still works locally though.


Here is what I have for my settings -

(https://scontent-b-dfw.xx.fbcdn.net/hphotos-xpa1/v/t1.0-9/10712755_593347467436226_8392692048736324274_n.jpg?oh=5facedf56ae7bb409ed1ec63c9360aca&oe=54EBD504)

that login is for the cp.mios account, not the updated vera home login. my new ui7 login returns an invalid password error, which is not the case.

Does any of htis make sense? can you assist? thank you so much !
Title: Re: Remote Access
Post by: charlesmerceriii on November 11, 2014, 09:06:44 am
Got this all figured out! Posting my solution if anyone has the same issue. lots of confusion with transfer from ui5 to ui7. Here is what I did.
these are just my preferred settings on the app but i am including them here as well if anyone would like to use this configuration

(first make sure you have ui7 fully updated, this is in settings > firmware in your vera, click upgrade)

1. log into cp.mios.com account
2. changed all user info to void@void.com etc to avoid any duplication of notifications etc.
3. go to users and remove vera from account (this will stop it from picking up the old IP that no longer works in autoconfig)
4. go to home.getvera.com and log into or create your new account (you can use the same username as your old cp.mios.com ui5 account as it appears they are totally unrelated)
5. set this up as normal
6. uninstall whatever authomationHD app you have (i was using the version from google play and this would not work for me)
7. install the newest beta app, 3.3.1.4, download link - https://drive.google.com/file/d/0B5d_AVk_5HmgSEZqM05UREFjVmM/edit?usp=sharing
8. determine your relay server by taking your phone off of wifi and going to home.getvera.com and logging in
       the url will be https://vera-us-oem-relay11.mios.com/blahblah or similar, make note of the first portion of the URL
9. start app, skip the auto config, it wouldn't let me type in the fields, maybe this is because of my 3rd party keyboard app? unsure
10. enter your configuration settings as follows
11. now everything should work, no matter if you are on your home wifi or away from the house!


my preferred app settings are included here as well if anyone would care to use, this seemed to perform the best for me

under connections -
check auto refresh
check refresh on resume

under application settings -
set default tab to devices
set tab style to icons & text
set default panel to devices
set device style view to compact tiles
un check both vibrate settings (i had to reboot my phone to get this to take effect)

turn your wifi on and off and confirm that everything works correctly

back up your settings

and everything should be good to go!

one other thing, i found that if you long press on a device, you can hide sensors that you dont want to see, and can re name your items within the app to your preference. This was useful to hide my garage tilt sensor that i am using with the garage door vera app plugin, and to be able to display all my devices at once, but keep them grouped with alphabetization.

hope this helps anyone who may be having issues.

Thankyou again sir for your wonderful software! please let me know if you have a donation link anywhere.
Title: Re: Remote Access
Post by: garrettwp on November 11, 2014, 09:44:35 am
When using UI6 or UI7 you must check MMS. This is the new authentication used by these firmwares. The back server url is used if the primary server for your vera is down. The backup server url will be different than the primary. In this case yours was vera-us-oem-relay31.mios.com. This will be auto populated for you on first sync and will be updated as they change on your vera.

- Garrett
Title: Re: Remote Access
Post by: stridera on November 14, 2014, 12:33:59 am
Application Version: 1.7.388
I do have a home.vera.com account.  On Relay 12.  Able to login to the website anywhere.
It worked a long time ago.  Maybe back when I was on ui6.  I used to have it integrated with Tasker.

Now it won't connect at all.  I just get the  MMS Unknown Auth Error.
Title: Re: Remote Access
Post by: garrettwp on November 14, 2014, 07:24:59 am
You can email me the logs found under Settings -> Development -> Send Logs.

Sent from my Nexus 5 using Tapatalk