The Vera Community forums have moved!

Advanced => Plugins & Plugin Development => Programming => Nest => Topic started by: Hippogriff on June 08, 2015, 01:47:12 pm

Title: Initial install of the Nest Plugin with Vera Edge, UI7
Post by: Hippogriff on June 08, 2015, 01:47:12 pm
Hello,

It's my first day doing things with my new Vera Edge. I've got my head around some things, but I've not yet managed to set up Nest. I wondered if someone might help me get past this hurdle as I'm not too sure how to get beyond it.

From the Vera Edge UI I go to Apps - Install Apps, I type "nest" and press Search, I see 2 options come back and I select the "Nest Thermostat and Protect" one, then press Details followed by Install. The version of the plugin is said to be 1.8.

After I set it installing, I get a popup box, things seem to progress - it does say "Config: Config data was not found. Waiting for it..." but then says "Config: found config data." followed by "Config: checking if user attention is required." and finally "Config: Device doesn't need configuration. Click Back to return to app list."

At the top of the Vera UI it then says "Nest : Please specify username and password." so I click on My Apps and select "Nest Thermostat and Protect"... and select the device it has created. I go to enter the username and password (no funny characters) and the message asking for username and password goes away when I press "back".

However, in Devices, all I see is a Z-Wave icon for the Nest device. I'd expected to see some kind of representation of my 2 Nests. When I click through to look at variables I can see my username and password and they are correct. I can log into my Nest account with those credentials.

Have I missed something very obvious indeed? I'm sorry if so, but it would be nice if someone helped me past this hiccup.
Title: Re: Initial install of the Nest Plugin with Vera Edge, UI7
Post by: Hippogriff on June 09, 2015, 03:35:08 am
P.S. - I just found in the log this bright red line:

luup_log:13: Nest: error getting status from nest.com with HTTP code=nil, status=nil <0x75a15520>

Which is different to what I see if I, intentionally, put in the wrong Nest login credentials. So I'm a bit baffled at the moment.
Title: Re: Initial install of the Nest Plugin with Vera Edge, UI7
Post by: Hippogriff on June 09, 2015, 06:13:34 pm
Scratch all that - I only just realised there is an 'in-built' plugin for Nest. I've made further progress with that... still had - and have - trouble, but at least it got somewhere.
Title: Re: Initial install of the Nest Plugin with Vera Edge, UI7
Post by: eboily on July 09, 2015, 11:28:37 am
Hey Hippogriff!

any luck to connect with nest?  the VeraConnect WWN plugin always reject my token and ask me to "Vera Connect WWN : Invalid or missing TOKEN! Please go to 'Authorize' tab and authorize VeraConnect once again!"

thanks

Eric
Title: Re: Initial install of the Nest Plugin with Vera Edge, UI7
Post by: andreimios on July 10, 2015, 03:12:46 am
Hi all,

Please take a look at this topic :http://forum.micasaverde.com/index.php/topic,31828.0.html. A new plugin version is now available that should fix the authentication issue on WWN plugin.

All the Bests,

- Andrei -