Vera - Smarter Home Control Forum

General => Getting Started & Initial Setup => Topic started by: CarloZ on December 22, 2015, 04:08:56 am

Title: d-link DCH-Z110
Post by: CarloZ on December 22, 2015, 04:08:56 am
Hi to all,
I'm new in this world. I bought vera edge and  Door & Window Sensor d-link DCH-Z110. As far as i see they are the same of philio PST-02 C. I've tried to install and pair them with the gateway using the default procedure for philio but unexpectedly it didn't work. Can someone help me in what to do  in order to configure those sensors?
Thank you
Title: Re: d-link DCH-Z110
Post by: psixilambda on December 27, 2015, 02:07:24 pm
The DCH-Z110 needs to be configured to Using Sensor Binary Report. This is configuration setting 7, bit 4.

To enable DCH-Z110 on the Vera you add it as a generic Zwave device. After adding it should show up as 4 devices, Temperature, Light, Door and Window and the general Sensor.

Click the general sensor, then select device options, add configuration setting. Variable 7, 1 byte dec, desired value: 16.

Now you can use the sensor input from the DCH door sensor on your Vera.

Regards

Alex

Title: Re: d-link DCH-Z110
Post by: CarloZ on December 28, 2015, 06:08:34 pm
Thank you so much. I reached the same conclusion after reading and reading again the manual, before Your ansare...  :-X  :-\ Aniway this solution seems to works fine. Tank you again.
Title: Re: d-link DCH-Z110
Post by: steccio on March 31, 2016, 05:33:15 pm
Hello I've bought DCH-Z210 and used the same configuration, but the sensor stays always triggered, does anyone can help me?
Title: Re: d-link DCH-Z110
Post by: CelticWebs on April 08, 2016, 03:34:55 pm
I've just tried the procedure above too, I've added it as a Generic device then made the suggested modification. 

It appears to reporting lux and temperature but it's not reporting the door and window sensor reading, the sensor is there in UI7 on my Vera Plus but it done'st change no matter how I set the actual door/window sensor.  Still just remains the same on Vera.

Any further suggestions would be gratefully accepted.

Thanks
Title: Re: d-link DCH-Z110
Post by: steccio on April 08, 2016, 07:12:25 pm
I found the correct configuration for DCH-Z210 : Variable 7, 1 byte dec, desired value: 22

I hope this will help someone
Title: Re: d-link DCH-Z110
Post by: CelticWebs on April 09, 2016, 04:04:43 am
I'll give that a try now.  I got it to update but the door sensor still doesn't respond. Hopefully if I update with your settings it will.  Does that setting need to go on the binary device Steccio?
Title: Re: d-link DCH-Z110
Post by: steccio on April 09, 2016, 05:38:13 am
Hi CelticWebs, I've confingured DCH-Z210 the Movement Sensor, not the DCH-110 the Door/Window Sensor; for this sensor you should try : Variable 7, 1 byte dec, desired value: 20.
This one goes on the main device
Title: Re: d-link DCH-Z110
Post by: CelticWebs on April 09, 2016, 07:43:38 pm
Thanks fir the reply.
Just to confirm, these settings are set on the binary device not on the actually door sensor device correct?
Title: Re: d-link DCH-Z110
Post by: steccio on April 09, 2016, 08:02:21 pm
correct
Title: Re: d-link DCH-Z110
Post by: CelticWebs on April 09, 2016, 08:16:25 pm
Ok thanks, I'll give it a go tomorrow and see if the sensor comes to life
Title: Re: d-link DCH-Z110
Post by: CelticWebs on April 11, 2016, 09:40:44 am
Unfortunately changing Variable 7 to 16, 20 and 22 and none result in a working Door & Window sensor.

Doe anybody actually have this sensor setup and working on their UI7 Vera?  I'm on a Vera plus but I don't believe the plus bit would effect the settings.

Any further help would be very much appreciated, I don't want this thing to beat me!

Many thanks
Title: Re: d-link DCH-Z110
Post by: sibay on April 28, 2016, 03:09:43 pm
Hi CelticWebs,

i just bought a DCH-Z110 and had problems with the door sensor. I followed the description from psixilambda. I dont know what this makes, but it works.

>Click the general sensor, then select device options, add configuration setting. Variable 7, 1 byte dec, desired value: 16.

Title: Re: d-link DCH-Z110
Post by: CelticWebs on April 28, 2016, 04:00:31 pm
Interestingly for me this did not work.  After a lot of investigation we discovered that on my Vera plus, the communication with the main device was encrypted (zwave plus) but the child devices, door, light and temperature was unencrypted and Vera was seeing them report but ignoring them.

Further investigation showed that the device used a multi command class.  Disabled the multi command class by setting variable 6 to 54 and everything started working perfectly, light and temperature sensors update as light and temperature change and the door sensor now works perfectly too :).

Maybe there's variations of firmware for the dlink.  Are you in Europe sibay?
Title: Re: d-link DCH-Z110
Post by: MichuP on March 19, 2017, 02:34:52 am
Hi everyone, my first post here. Nice to meet you.
I found good explanation for D-link sensors configuration in Vesternet site. It works well in Vera Plus.
Dch-z110: http://www.vesternet.com/resources/application-notes/apnt-136

Dch-z120:
http://www.vesternet.com/resources/application-notes/apnt-135

By the way I have problem with association D-link Dch-z120 PIR sensor with Qubino 2x relay.
It doesn't work.
 In D-link there is parent device which make possible define association in device options. In embedded device 'motion sensor' isn't possible association definition. Only motion sensor detects movement and change state. I suppose that parent device doesn't send order to relay.

Anybody solve this kind of problem?

Scenes of course works well but controller has to be on line.
Regards

Wysłane z mojego ONEPLUS A3003 przy użyciu Tapatalka
Title: Re: d-link DCH-Z110
Post by: Domoworking on April 15, 2018, 12:41:28 pm
Thx MichuP
I configured my z110 as suggested in the link you posted, but I'm still struggling reading light and temperature.
It Always reports 1 Lux and 25? C...

Any suggestion?

Regards
Title: Re: d-link DCH-Z110
Post by: Florin on December 06, 2018, 01:50:56 pm
Since this is the first topic that google lists when searching for DCH-Z110 and Vera, I'm going to post here.

My sensor also works with variable 7 set to 16 and variable 6 set to 54. Again these are for Z110 and my sensor is produced for Europe. On its back the model has EU at the end.

Thanks to those who found these values and made this sensor work.