Vera - Smarter Home Control Forum

Advanced => Plugins & Plugin Development => Programming => USB RFXtrx Transceiver Plugin => Topic started by: Gabriel on August 01, 2016, 06:15:18 am

Title: WS1700 temp/hum sensors changing their IDs - how to handle that?
Post by: Gabriel on August 01, 2016, 06:15:18 am
Hello,

I have several cheap WS1700 sensors (temp/hum/battery level). The issue with those is that whenever the battery is removed (when replacing it), those sensors seems to change their reported ID.
I thus end up with new detected devices, and all the scenes/watches have to be re-configured.

Would there be a way to "reconciliate" the newly detected devices with the old ones, in order to avoid having to reconfigure everything?
Title: Re: WS1700 temp/hum sensors changing their IDs - how to handle that?
Post by: lolodomo on August 07, 2016, 04:05:00 am
Yes there is. I don't remember exactly how. Do a search on the forum.
Title: Re: WS1700 temp/hum sensors changing their IDs - how to handle that?
Post by: tinman on September 23, 2018, 02:21:08 pm
OK - it's been a very long time since you posted this but I just found the posting. I've encountered this often. The way to do it is turn on auto create. When the device shows up (hopefully there aren't too many and you can identify it by noting the sensor readings) look at the advanced tab for the device and note the altid. Copy the numeric part at the end. Turn off auto create. Delete the newly created device. Open the advanced tab for the original device before you changed batteries. Modify the numeric part of the altid to be that of the newly created device (the rest of the altid should be the same as before). It may take a little while for the 'old' device to be registering sensor readings again but this has worked for me often. You can also try this from a new browser tab: <your Vera IP address>:3480/data_request?id=reload