The Vera Community forums have moved!

Advanced => Plugins & Plugin Development => Programming => Ademco Vista Alarm Panel with EVL3 => Topic started by: Dolphran on November 06, 2017, 12:59:13 pm

Title: Triggering a zone arms all zones
Post by: Dolphran on November 06, 2017, 12:59:13 pm
Hi - I'm only just getting back into HA after moving. The new house has a Vista 20P to which I added a Envisalink 4. I just upgraded my VeraLite to UI7. The alarm plugin seems to be working well EXCEPT for the following: Whenever I trigger a zone (i.e. actuate a door or window sensor), afterwards ALL my zones get automatically set to ARMED! I have been assuming that zone arming  (as opposed to partition arming) is just for Vera, and has nothing to do with the Vista20P. I have my UI7 HOME Mode set with all zones Disarmed except for one (a panic button) and if an armed one trips, it will set off my Z-Wave Siren (nothing to do with my Vista 20P siren). So because of this strange behavior, after opening a door or window, the Next time I open one, my Z-Wave siren goes off! Help?!
Title: Re: Triggering a zone arms all zones
Post by: Dolphran on November 06, 2017, 04:10:45 pm
As I think about it, it occurs to me that this may be purely a UI7 issue. It has to do with how UI7 handles the Zone sensors. Once they were created via the Vista panel plugin, they automatically showed up in the 'Mode' (HOME/AWAY/NIGHT/VACATION) area, with the behavior of triggering my Z-Wave siren when armed and tripped. The broken behavior of all the sensors becoming armed after an unarmed one is tripped may be purely within UI7 and have nothing to do with the plugin. Thoughts?
Title: Re: Triggering a zone arms all zones
Post by: Dolphran on November 07, 2017, 06:58:45 pm
I figured it out. The individual zone sensor arming state was set to show the BYPASS state in the Vista20P. Apparently this state was only reflected when the alarm went to the ready to arm state. Setting the "Disable BYPASS Display:" plugin setting to DISABLED fixed the problem.