Vera - Smarter Home Control Forum

General => Connected Objects => Nest => Topic started by: gtallan on February 12, 2018, 11:36:07 am

Title: WWN auth token expiry?
Post by: gtallan on February 12, 2018, 11:36:07 am
I got a "device not communicating" error from my WWN devices - since other posts here made it sound like a simple re-auth might not always help, I contacted support.
They determined that it wasn't authorized with Nest, so I re-authed, and that seemed to fix it.

It occurs to me that it's almost exactly a year since I added WWN to vera. Does that correspond to an expiry time in the auth token?

If so it would be nice if the plugin could tell us (it does sound like the API should return an explicit "expired" status).
Title: Re: WWN auth token expiry?
Post by: rigpapa on February 12, 2018, 12:00:11 pm
Similar experience over the weekend. Noticed that my device was offline, did a re-auth and all continues. Not sure when my original auth was, but I know it's been less than a year, because I hard reset and rebuilt my configuration from scratch right around the end of October/early November.
Title: Re: WWN auth token expiry?
Post by: therealdb on February 12, 2018, 12:03:45 pm
same here.

I'm trying to write a function to check its validity to be part of my daily check, because I had a couple of scenes using nest temp that were stuck to a wrong humidity/temperature.
Title: Re: WWN auth token expiry?
Post by: beachboync on February 12, 2018, 08:36:40 pm
I had to re-auth also. Not sure how long since the last one,

Bob
Title: Re: WWN auth token expiry?
Post by: bruine01 on February 13, 2018, 12:28:25 pm
Same here. Installation was 14 months ago.
Title: Re: WWN auth token expiry?
Post by: therealdb on February 18, 2018, 05:22:16 am
token expired again tonight.

WWN was pretending it was authorized (but the header error was clear), so I had to manually change the "authorized" variable to 0 and authorize it again. the deauthorize feature was not working.
Title: Re: WWN auth token expiry?
Post by: gtallan on February 18, 2018, 02:28:08 pm
token expired again tonight.

WWN was pretending it was authorized (but the header error was clear), so I had to manually change the "authorized" variable to 0 and authorize it again. the deauthorize feature was not working.

What do you mean by "header error"? The status messages which appear at the top of the web interface (like when it's "configuring devices" etc)?

I only ask because these disappeared for me completely since a recent firmware update. I remember seeing something about that and how to re-enable them, but csn't find it...
Title: Re: WWN auth token expiry?
Post by: therealdb on February 19, 2018, 01:01:58 am
Yes. I re-enabled them via settings and actively monitoring (and reporting) them via a custom script (mainly used to catch lua errors).
Title: Re: WWN auth token expiry?
Post by: gtallan on February 19, 2018, 04:07:56 pm
Yes. I re-enabled them via settings and actively monitoring (and reporting) them via a custom script (mainly used to catch lua errors).

Can you remind me where to find that in the settings? Feel a bit stupid but I looked and couldn't find it!
Title: Re: WWN auth token expiry?
Post by: therealdb on February 19, 2018, 05:11:00 pm
Sure.
Go to Users & Account Info > Notifications Settings and enable the notification header option again.
Title: Re: WWN auth token expiry?
Post by: gtallan on February 21, 2018, 06:19:28 pm
Sure.
Go to Users & Account Info > Notifications Settings and enable the notification header option again.

Thanks, must have been the one page I didn't check!

I don't get the logic of where it's placed, but then the reboot button is on the network page so i expect that!