Vera - Smarter Home Control Forum

General => Connected Objects => Nest => Topic started by: therealdb on April 08, 2018, 05:09:17 am

Title: Nest device not found error
Post by: therealdb on April 08, 2018, 05:09:17 am
I have 3 Nest thermostats and everything was working OK until yesterday.

Now, when I try to act to one of them, I get this error (taken from logs):

JobHandler_LuaUPnP::HandleActionRequest device: 161 service: urn:upnp-org:serviceId:HVAC_UserOperatingMode1 action: SetModeTarget <0x72dc5520>
JobHandler_LuaUPnP::HandleActionRequest argument DeviceNum=161 <0x72dc5520>
JobHandler_LuaUPnP::HandleActionRequest argument serviceId=urn:upnp-org:serviceId:HVAC_UserOperatingMode1 <0x72dc5520>
JobHandler_LuaUPnP::HandleActionRequest argument action=SetModeTarget <0x72dc5520>
JobHandler_LuaUPnP::HandleActionRequest argument NewModeTarget=HeatOn <0x72dc5520>
JobHandler_LuaUPnP::HandleActionRequest argument rand=0.5229552721063049 <0x72dc5520>
luup_log:30: VeraConnectWWN::setModeTarget> Nest device not found <0x77a1e000>

Other applicationts accessing the nest API are working OK and I double checked the ID, just in case, and it's OK.

The devices (both temp and humidity) seem to be frozen and cannot be updated from the plugin anymore. Any help is appreciated. Thanks.
Title: Re: Nest device not found error
Post by: therealdb on April 09, 2018, 06:20:26 am
I found that the not working device as "_" in its ID, something like ABCD_EFG, while working one has not letters and numbers.

I enabled verbose logging and I can clearly see that it's searching for the wrong device ID:

VeraConnectWWN::getChildDevices> ERROR: Found device #161 with Nest ID 'EFG', but no equivalent device found in the Nest data

The plugin uses a structure like nest_devicetype_id to store the Nest internal ID and I suspect it's something updated and breaking the parse. I tried to encode the values with no luck. If I remove the devices (both thermostat and humidity sensor), the WWN plugin recreates them, but then the same problem applies.

I opened a ticket with support and I'll update this thread when they'll reply in order to help others with the same problem.
Title: Re: Nest device not found error
Post by: stardobas on April 25, 2018, 01:09:07 pm
nothing news about it?
Title: Re: Nest device not found error
Post by: therealdb on April 25, 2018, 02:49:08 pm
They did something and fixed it. I don't know what exactly and they did not responded to my request about it. But it's working solid now.
Title: Re: Nest device not found error
Post by: stardobas on April 25, 2018, 05:23:35 pm
in my case Nest don't work.....pairing ok, code insered...but don't comunicate to nest.
Title: Re: Nest device not found error
Post by: therealdb on April 26, 2018, 12:53:21 am
Open a ticket. Support will help you.
Title: Re: Nest device not found error
Post by: stardobas on April 26, 2018, 04:58:01 am
Open a ticket. Support will help you.

I made it.... support is fantastic, I enabled support remote and they solve the problem...In less 24 our...never seen so fast, kind and efficent support...I think is the best!!! They solve my problem when I was sleeping..giving me a a gift when I get off the bed... I started this day smiling :)
Title: Re: Nest device not found error
Post by: Sorin on April 26, 2018, 08:34:37 am
Customer Care team loves to see when their work is compensated with some good words.  8)

Thanks everyone.