The Vera Community forums have moved!

General => Remote Control => SQ Remote / Square Connect (iOS) => Topic started by: chixxi on November 18, 2011, 08:21:23 am

Title: SQ Blaster Plugin for Vera - Almost Working
Post by: chixxi on November 18, 2011, 08:21:23 am
Hello Everybody.

I am using a Vera2 and a SQ Blaster remote, both controlled by the SQ Remote HD App. My target now is to send commands to the SQ Remote by running a scene on the Vera. The SQ Remote Plugin is installed and everything seems to work, if a scene is activated the the SQ Blaster blinks, but the TV shows no reaction.

Here is what I did in detail:

1. I Am using a Vera2 running on the Beta Firmware 1.1.1338. The following plugins are installed: dataMine, Ping Sensor, Generic IP Camera, Google Weather, Smart Phone Web Interface. The SQ Blaster is running on the Firmware A079.

2. I installed this plugin (http://code.mios.com/trac/mios_sqblaster) according to this procedure (http://code.mios.com/trac/mios_sqblaster/wiki/Installation-UI4).

3. I created a device using the both files from the plugin D_SQBlaster1.xml and I_SQBlaster1.xml and called the device "SQ Blaster". In the Advanced-Tab of this device I entered the IP of my SQ Blaster. This seems to work fine since the device is shown as "up" and all information's about the SQ Blaster are shown.

4. According to this procedure (http://forum.micasaverde.com/index.php/topic,7239.0.html) I then created the two files D_SQdev1073736426.xml and I_SQdev1073736426.xml out of the SQ Blaster Backup from box.net. All three files are attached to this post.

5. I then created a new device to represent my TV using the two files created in step 4 and called in "Sony Bravia". In the tab "Settings" of this device I added the SQ Blaster as it's infrared transmitter.

6. Then I created a scene and in the tab "Advanced" added a step "Sony Bravia - Toggle OnOff".

Now if I run the scene the SQ Blaster blinks, so something seems to be sent, but the TV shows no reaction at all. When I use the SQ Blaster App on the iPhone everything works just perfectly. So I thought the wrong Pronto Code might be send, but by using "http://192.168.x.xxx/cgi-bin/cmh/log.sh?Device=LuaUPnP" I found that the pronto code which is sent is exactly the one which is also in the file dev1073736426.xml and I_SQdev1073736426.xml, basically the correct one:

Code: [Select]
02 11/17/11 18:30:45.012 LOG_CHECK_MEMORY_LEAK pMem start 0xa2a000 now 0xa4a000 last 0xab0000 leaked 131072 <0x803>
02 11/17/11 18:31:00.824 UPnPCallbackEventHandler 0 start PIDLOG2 23279 <0x2c0c>
08 11/17/11 18:31:00.824 JobHandler_LuaUPnP::HandleActionRequest device: 0 service: urn:micasaverde-com:serviceId:HomeAutomationGateway1 action: RunScene <0x2c0c>
08 11/17/11 18:31:00.825 JobHandler_LuaUPnP::HandleActionRequest argument SceneNum=15 <0x2c0c>
08 11/17/11 18:31:00.826 Scene::RunScene running 15 DREAM <0x2c0c>
08 11/17/11 18:31:00.826 JobHandler_LuaUPnP::HandleActionRequest device: 41 service: urn:micasaverde-com:serviceId:TogglePower1 action: OnOff <0x2c0c>
08 11/17/11 18:31:00.827 JobHandler_LuaUPnP::HandleActionRequest device: 36 service: urn:micasaverde-com:serviceId:IrTransmitter1 action: SendProntoCode <0x2c0c>
08 11/17/11 18:31:00.828 JobHandler_LuaUPnP::HandleActionRequest argument ProntoCode=P6501 802c 4a32 dbaa dc4d dd2c a526 3d20 427f 8cc4 0f67 d291 9f35 bff7 d926 dda7 137d eb0b ac1e eba4 fd0d 8a2b 872c e5aa 4772 7189 036c b892 7b93 8c96 7836 00af   <0x2c0c>
50 11/17/11 18:31:00.860 luup_log:36: Web request returned status=200 response=
in 0ms <0x2c0c>

Now I don't know what else to do. Did I miss a step in the installation procedure? Did anyone of you have similar problems? Can you help me analyse the log, although it seems right to me? Are the attached files correct or do I need to adjust them?

Any ideas are greatly appreciated, thanks so much for your help!



P.S: Thank you very very very much @guessed for creating the plugin and providing all these information's to this community!
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: guessed on November 18, 2011, 10:24:49 am
Ok, you've managed to stump me.  The generated files look correct, and the snippet of log file is showing it being passed through as well as a valid response status.

Have you tried other codes, ones like discrete on/off or. Volume perhaps?

If they don't work I'll have to ping Mat and see if he can help.  My Pucks are running older firmwares, but I doubt they changed any thing material.


Btw: Thanks for the detailed outline, it captures a perfect amount of information, and is well written.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on November 21, 2011, 09:58:55 am
First off all, thank you for taking the time to go through this!

Yes, I have tried other pronto codes. I have even tried other devices (dreambox) with other codes, the result is always the same: Log from Vera shows correct codes are sent, SQ Blaster is Blinking, but devices are not reacting.

The next step is going to be a complete re installation of the plugin an its according devices. Since the steps of converting are not very specificly noted I kind of messed around till I figured out how to do that, so I want to make sure everything is installed straight and clean. I will let you know about the results during this week.

To be honest, I wanted to try this that weekend, but the release of Minecraft 1.0.0 keept me from doing anything smart.  8)

Is it possible to send codes via http directly to the SQ Blaster? As you can with the following example through Vera?:
http://192.168.x.xxx:49451/data_request?id=lu_action&DeviceNum=202&serviceId=urn:micasaverde-com:serviceId:DiscretePower1&action=On

Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: SquareConnectMat on November 21, 2011, 12:52:49 pm
@Chixxi,

Sony codes (and many otehrs) require multiple 'repeats' for them to actually control a device. In SQRemote, we have two modes of blasting: 'press and hold' and macro mode. Press and hold emulates a traditional hard remote and will send the initial 'start IR command followed by multiple 'repeat commands' unitl you lift your finger off the button. In macro mode, you specifiy the number of repeats you want to be sent. Typically 3 to 5 is a good number, if your device needs a repeat. By default, SQRemote uses press and hold (it can be changed in the device configuration) fro buttons and macro mode when used in SQRemote macros.

I believe Guessed's plugin uses macro mode so when you use @Guessed's plug in, you must make sure you are also specifying the right number of repeats.. The best way to way to find out the number of repeats you need for a particular device and codeset is to use SQDesigner and try the various combinations from within that app. I find the best way to manage the IR devices and device files is through SQDesigner.

Hope this helps....

Let me know ifg it doesnt.

Regards,


Mat

Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on November 22, 2011, 03:36:06 am
@Mat:
WOW that sounds interesting! I tried very shortly yesterday afternoon and I realized that if I run a macro from the SQ Blaster App the result is the same as if
a command is sent by the Vera: SQ Blaster blinking but no reaction from device. Then I run out of time, I am going to try adding "repeats" in the macro till it works tonight and give you an update right away. Thank you!

@guessed:
So once i figured out the number of repeats necessary, where could I specify that in the Vera devices? I guess it should be added to the file I_SQdev1073736426.xml, but how?
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: guessed on November 22, 2011, 10:26:08 am
There's no mechanism in MiOS to specify repeats against their IR stuff.

A few potential alternatives.  The first is to copy/paste the code multiple times within the I_ declaration.  It's just a sequence of bytes to be transmitted so a few more copies shouldn't hurt.

The second is that Mat mentioned this is a problem
With Pronto codes but not with UEI codes that SQRemote can also use.  To do this you'd have to pick the UEI code based Sony device in the SqRemote interface instead of the Pronto code based one.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on November 23, 2011, 02:40:09 am
Yeahhhh it's working! Thank you @guessed! Thank you @mat!  :-*

I first tried to add the Pronto Codes to the I_Declaration multiple times, without success. And to be honest it seemed kind of an unclean solution to me so I didn't like it.

Then I went for the UEI Code solution. I have not realized anything about beeing able to choose different kind of codes in the SQ Remote App, but of course you were right and after about one hour of searching I addded a new device based on UEI codes. Using the same procedure mentioned in my first post in this thread I the created my new I_*.file and D_*.file and added a new device to the Vera using those files. All files are attached to this post. An this works! The UIE codes sent by Vera Scenes arrive at the SQ Blaster and the TV reacts according to it.

But one new Problem occurred:

In the Vera the commands to change the Inputs are completely missing, they are just not available in the drop down list when you want to add steps to a scene. But in the I_SQdev4285574198.xml they are specified. For example the code "VID6,AV2,VDP,DVD,DVI" in line 356 is the code for choosing HDMI3. I figured that out by using the direct commands from the iPhone SQ Remote App.

I thought it could be that the commas in the device names are confusing the Vera, i removed them, re uploaded the I_SQdev4285574198.xml. No success, still no possibility to choose "VID6AV2VDPDVDDVI".

Then I saw that in the line 355 "urn:squareconnect-com:serviceId:PlaceHolderAV1" the command is added to the section "PlaceHolderAV1", since I couldn't see this section in the drop down at all I thought it might be smart to change this to "Misc1" since all the commans which are added to "Misc1" are actually shown in the drop down list. No success, still not being able to choose this command in the commad list.

Now I just realized that compared to the files I uploaded in the first post in the D_*.file I am missing the lines:
Code: [Select]
      <service>
        <serviceType>urn:micasaverde-com:service:InputSelection:1</serviceType>
        <serviceId>urn:micasaverde-com:serviceId:InputSelection1</serviceId>
        <SCPDURL>S_InputSelection1.xml</SCPDURL>
      </service>

But now it's getting way over my understanding of this plugin. Do I need to add that section? How to the D_*.file and the S_InputSelection1.xml (which is already available in the Vera) play together or connect? How can I make the command "VID6,AV2,VDP,DVD,DVI" show up as HDMI3 in the drop down list on the Vera?
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on November 23, 2011, 04:00:53 am
I just figured out that the file "SQBlaster_I.xls" provided by guessed to transform the file dev4285574198.xml into the file I_SQdev4285574198.xml is not able to recognize a command named "VID6,AV2,VDP,DVD,DVI" as an command for Input selection. Therefore I renamed the commands to "INPUT HDMI X" and "INPUT VIDEO X".

After transforming the files D_*.file now includes the section for Input Selection and in the I_*.file the commands are now assigned to this section. All files are attached to this post.

After adding a new device with these new files I am now actually able to choose these commands in a Vera Scene.

So basically I know the command "VID6,AV2,VDP,DVD,DVI" is HDMI3, in the file dev4285574198.xml I changed its name to "INPUT VIDEO 2" so that its recognized as an input selection during transformation. In the file I_SQdev4285574198NEW.xml this command is assigned to "Input 6". So running the command Input6 from the Vera should switch the TV Input to HDMI3.

But since I am not at home and I have no camera seeing my TV and for some reason I can't see the log I can not yet confirm that my TV is actually changing the Input. I'll let you know as soon as possible...

EDIT: According to the log the right code for choosing the Input6 is sent:

Code: [Select]
02 11/23/11 10:57:18.852 UPnPCallbackEventHandler 0 start PIDLOG2 11499 <0x2c0c>
08 11/23/11 10:57:18.852 JobHandler_LuaUPnP::HandleActionRequest device: 0 service: urn:micasaverde-com:serviceId:HomeAutomationGateway1 action: RunScene <0x2c0c>
08 11/23/11 10:57:18.853 JobHandler_LuaUPnP::HandleActionRequest argument SceneNum=13 <0x2c0c>
08 11/23/11 10:57:18.854 Scene::RunScene running 13 PS3 <0x2c0c>
08 11/23/11 10:57:18.854 JobHandler_LuaUPnP::HandleActionRequest device: 44 service: urn:micasaverde-com:serviceId:InputSelection1 action: Input6 <0x2c0c>
08 11/23/11 10:57:18.855 JobHandler_LuaUPnP::HandleActionRequest device: 36 service: urn:micasaverde-com:serviceId:IrTransmitter1 action: SendProntoCode <0x2c0c>
08 11/23/11 10:57:18.856 JobHandler_LuaUPnP::HandleActionRequest argument ProntoCode=UT081067 <0x2c0c>
50 11/23/11 10:57:18.918 luup_log:36: Web request returned status=200 response=in 0ms <0x2c0c>


BTW: Sorry for those long posts, I am just trying to give you descriptions as accurate as possible.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: guessed on November 23, 2011, 07:30:07 am
Yes, MiOS has a fixed number of predefined IR names (and ServiceIds).  My transforms attempt to map the SQBlaster codes to their MiOS equivalents but there isn't always an obvious mapping.

For the most part it uses the sqkey's but there's a limited amount of fallback logic for the "named" IR codes that SQBlaster sometimes uses
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: drag0n on November 23, 2011, 09:25:40 am
after about one hour of searching I addded a new device based on UEI codes.

Can you explain how to add a device based on UEI codes?
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on November 23, 2011, 09:44:55 am
after about one hour of searching I addded a new device based on UEI codes.

Can you explain how to add a device based on UEI codes?

Yes, example for Sony Bravia TV with UEI code:
1. Open the "SQ Remote HD" App on our iPhone/iPad.
2. Goto "Setup".
3. Goto "SQ Blaster & Devices".
4. Goto "Add New Device to Blaster" (of course you need to have an SQ Blaster connected to the iPhone to do that)
5. Choose the brand. In this case "Sony".
6. Choose the device Type. In this case "TV".
7. Now you can choose the code type (underlined in green in the attached screenshot) on the top with "left" and "right" (circled in yellow in the attached screenshot)
8. Use the TEST buttons to see which code works for your device.

I don't know if this option exists for every device.

I hope this is understandable, i think its hidden quite nice, or at least i didn't realize the option...

EDIT: This selection is not available for all devices. For example I can not choose the code for my Dreambox.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on November 24, 2011, 03:20:23 am
I CAN CONFIRM EVERYTHING IS WORKING!

Brief Summary:
Problem: Vera is sending commands to SQ Blaster, but Sony Bravia TV does not react.
Problem resulting from: Vera plugin not supporting repeating of Pronto Codes.
Solution: Switch to UEI Codes.

Now all that's left to say again: My very greatest appreciations to guessed and mat for helping me solve this problem and providing this plugin. Thank you GUESSED! Thank you SQUARECONNECTMAT!
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: teonebello on December 02, 2012, 02:07:11 pm
I CAN CONFIRM EVERYTHING IS WORKING!

Brief Summary:
Problem: Vera is sending commands to SQ Blaster, but Sony Bravia TV does not react.
Problem resulting from: Vera plugin not supporting repeating of Pronto Codes.
Solution: Switch to UEI Codes.

Now all that's left to say again: My very greatest appreciations to guessed and mat for helping me solve this problem and providing this plugin. Thank you GUESSED! Thank you SQUARECONNECTMAT!

Hi chixxi, I have the same problem mentioned in the tread but I cannot solve it. Sqbalster plus is working correctly with Sq remote. But it is not working using the IR remote or scene in Vera.
When you say "Solution: Switch to UEI Codes", where should I do it? Do you mean in Vera? If you mean in Sqremote, then how can I use this command from VEra?

Thank you in advance
Regards,
Matteo
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: guessed on December 02, 2012, 05:03:59 pm
When you configure a TV via the SQRemote application, you select the Vendor (etc) and it presents you with a screen of the commands for that Model.

eg

[POWER TOGGLE]      [Test]
[POWER ON       ]       [Test]
(etc)

The default list is presents is that of the build-in catalog.  In addition to these codes, there's a control at the top of the UI that says:

    <   Select Code Set (1 of 5)   >

You can use this to page through the other potential codesets that might work for your TV.  IF you've got a well known TV, then there will be additional sets of "UEI" codes for that brand/device.

The UEI codes represent IR-sets from a built in "chip" catalog that the SQBlaster has in it's hardware.  "UEI" comes from the name of the chip vendor, since they're a large provider of IR Remote control chips.

When you select from this set, you're natively using the built in chip functionality.

Either way, once you've made the selection, then the devnnnnnnnnn.xml file from the backup will contain either a Pronto code from the Installer catalog, a Learned code or a UEI Code.

Each one brings with it different reliability characteristics.
Title: SQ Remote Plugin for Vera - Almost Working
Post by: teonebello on December 02, 2012, 05:11:55 pm
When you configure a TV via the SQRemote application, you select the Vendor (etc) and it presents you with a screen of the commands for that Model.

eg

[POWER TOGGLE]      [Test]
[POWER ON       ]       [Test]
(etc)

The default list is presents is that of the build-in catalog.  In addition to these codes, there's a control at the top of the UI that says:

    <   Select Code Set (1 of 5)   >

You can use this to page through the other potential codesets that might work for your TV.  IF you've got a well known TV, then there will be additional sets of "UEI" codes for that brand/device.

The UEI codes represent IR-sets from a built in "chip" catalog that the SQBlaster has in it's hardware.  "UEI" comes from the name of the chip vendor, since they're a large provider of IR Remote control chips.

When you select from this set, you're natively using the built in chip functionality.

Either way, once you've made the selection, then the devnnnnnnnnn.xml file from the backup will contain either a Pronto code from the Installer catalog, a Learned code or a UEI Code.

Each one brings with it different reliability characteristics.

Thank you for your explanation.

I found the XML with the code

  <command_info command_name="On,Power On/Off" SQKeyCode="2" ir_data="2" source_id="1" SQSource="U" UEIDeviceType="T" UEISetupCode="0810"/>
  <command_info command_name="Off,Power On/Off" SQKeyCode="3" ir_data="3" source_id="1" SQSource="U" UEIDeviceType="T" UEISetupCode="0810"/>

Now it miss the last step. Where should I put the uei code in Vera.

Doing a scene I can add the action choosing the sqblaster "send pronto code".

Can I put the uei code there? E.g. O810?

Thank you
Matteo
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: guessed on December 02, 2012, 05:17:44 pm
I have an XSLT that I use to process the devnnnnnnnnn.xml files into Vera files.  This line has the relevant transformation rule:
    http://code.mios.com/trac/mios_sqblaster/browser/trunk/xslt/SQBlaster_I.xsl#L417

basically... If it's a UEI code then the thing to send is:

    <UEIDeviceType><UEISetupCode><ir_data>

In your case:

Code: [Select]
  <command_info command_name="On,Power On/Off" SQKeyCode="2" ir_data="2" source_id="1" SQSource="U" UEIDeviceType="T" UEISetupCode="0810"/>
this translates to:

   T08102



at least for the first one...
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: teonebello on December 30, 2012, 01:51:37 pm
I have an XSLT that I use to process the devnnnnnnnnn.xml files into Vera files.  This line has the relevant transformation rule:
    http://code.mios.com/trac/mios_sqblaster/browser/trunk/xslt/SQBlaster_I.xsl#L417

basically... If it's a UEI code then the thing to send is:

    <UEIDeviceType><UEISetupCode><ir_data>

In your case:

Code: [Select]
  <command_info command_name="On,Power On/Off" SQKeyCode="2" ir_data="2" source_id="1" SQSource="U" UEIDeviceType="T" UEISetupCode="0810"/>
this translates to:

   T08102



at least for the first one...

Hi Guessed,

I tried in different way but I'm not able to generate the files needed to created the devices in Vera.

May I ask you to support me? I attach the xml file .

Thank you very much in advance
Regards,
Matteo
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: guessed on December 30, 2012, 05:38:44 pm
@teonebello,
Can you post either a copy of the output you got, from running the conversion process, or a screenshot of the error that stopped you from getting the output?

This will allow me to better diagnose any process-oriented problems you're experiencing.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: teonebello on January 02, 2013, 04:29:38 pm
@teonebello,
Can you post either a copy of the output you got, from running the conversion process, or a screenshot of the error that stopped you from getting the output?

This will allow me to better diagnose any process-oriented problems you're experiencing.

Hi Guessed,

I'm not able to run the XML transformer.

May I ask you if you could create the I and D file?

Thank you in advance
I should send some swiss chocolate as gift :-)
Matteo
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: guessed on January 03, 2013, 12:55:04 am
@ teonebello,
See attached.  I haven't tested them, but visually they look about right.

Quote
I'm not able to run the XML transformer.
Can you paste screenshots of the specific problem you're having from the online service?

I'd like to fix any problems at the source, and I rely upon users like yourself showing me the problems you're having so I can address them.  It's help from users like yourself that let me improve the processes (etc)

ie. it's not practical to manually convert everyone's files, so I do it in order to get the problem test cases.

Please provide screenshots at your earliest convenience.

Quote
I should send some swiss chocolate as gift :-)
Appreciated, but no need.  My Mrs travels to Europe all the time, more chocolate & wine than we can poke a stick at   ;)
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: teonebello on January 03, 2013, 01:16:43 pm
@ teonebello,
See attached.  I haven't tested them, but visually they look about right.

Quote
I'm not able to run the XML transformer.
Can you paste screenshots of the specific problem you're having from the online service?

I'd like to fix any problems at the source, and I rely upon users like yourself showing me the problems you're having so I can address them.  It's help from users like yourself that let me improve the processes (etc)

ie. it's not practical to manually convert everyone's files, so I do it in order to get the problem test cases.

Please provide screenshots at your earliest convenience.

Quote
I should send some swiss chocolate as gift :-)
Appreciated, but no need.  My Mrs travels to Europe all the time, more chocolate & wine than we can poke a stick at   ;)

Hi Guessed,

first thanks.

Bit I have an issue. I created the device as per screenshot. Vera said device create, e.g. ID 209. I see the device and as soon as I reload is gone. Then trying to recreate the device i receive the same ID, e.g. 209. Very strange.



Matteo
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: guessed on January 03, 2013, 02:58:25 pm
You don't specify the Parent Device during device creation.  That will do bad things....  honestly I have no idea why they put that into the Developer dialog anyhow, but that's another story.

PS: The "IR Transmitter" (aka "SQBlaster") isn't the parent, it's just associated (manually by you), at a later stage, as the IR Transmitter element of the "IR Device" (JVC TV or whatever)
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: Robjsewell on April 09, 2013, 03:44:37 am
Hi to those who know what they are asking about! I don't... Guessed, I tried following your instructions to link my SQBP Pro with my Vera3 (latest firmware) and after a couple of false starts all was fine - to a point. I now see the blaster and four more IR's in Mios, but where from here? I have a load of dnnnnnnn.xml files from my Box.net backup, and understand from John at Squareconnect t that I need to upload these to the Vera. I have done so with one, and it shows up at first on the display, but later seems to disappear. What I can't find anywhere, and John was unable to help with this, was a full set of instructions from start to being able to see he available commands for each device. Is this anywhere for a real novice like me to follow please? One caveat - I tank the de ice file I have uploaded is a learned one, basically my Sky NZ box which doesn't work with the standard code st in the SQ Blaster. Here's hoping you can point me in the right direction! Cheers, Rob
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on April 09, 2013, 04:02:34 am
I think you first need to convert the xml files from box.net. Then you upload the two created files to the vera. Then on the vera you create a new device using these files. After that you can use scenes to execute the commands.

I think all the links needed are included in the first post of this thread.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: Robjsewell on April 09, 2013, 04:54:02 am
Thanks Chixxi, but that's exactly what I've done, I took the inputs guessed kindly provided, added a device file from my box backup and loaded the output file to my vera. My question is what next, I can see the file there in the listing of apps, but I'm missing what next? I appreciate your prompt reply, it's lonely out here!
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: Robjsewell on April 09, 2013, 05:08:02 am
Just a thought, do I need the D and I files? I read somewhere that as the I was input to the second transform I just needed the D file? I've been trying again, and I do the create device bit, specifying the D file, I don't specify a parent, and then in devices I see my new device. After I edit it to say what the parent is (SQ Blaster) and save, the device disappears. Even when I can see it, where are the commands that it can issue, e.g. Volume up/down - I see nothing but the device name. Thanks again!
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on April 09, 2013, 05:26:53 am
Yes, you just need the D and I files, which you create out of the xml files from  box.net. So far it seems like you are doing everything correctly.

You need to create scenes to execute the commands. Create a new scene, then go to the advanced tab. Select the device you created out of the D and i files, then add it. Then it should provide you with a list of the available commands. Select one, then save the scene. One you execute the scene the commands should be sent.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: Robjsewell on April 09, 2013, 06:03:21 am
Many thanks - again! I now have the files there, but when I go to the new scene section, the device (and others) are greyed out, and when I select the Advanced tab the device is not in the drop down list to select. I'm using UI5. I feel I must be so close but missing something simple!
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: chixxi on April 09, 2013, 06:07:06 am
If you created the device it should be in the list. Try reloading  your lua engine again (top right reload button in UI5), then clear your browsers cache and reload UI5.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: Gordon on July 20, 2013, 04:48:45 pm
I was able to successfully control my Sony Bravia KDL-55NX720 using the SQ Blaster Plus and my Vera Lite UI5 and these instructions.  I wanted to turn my TV on and off with a scene.  It was confusing for me to follow the thread of this post, so I will summarize how I did this:

1.  From the Vera UI5 web control panel I installed the SQ Blaster plugin via the menu apps > install apps
2.  I downloaded the files proved in reply #7 by Chixxi (thank you for providing these files)
3.  I uploaded these files to my Vera using the UI5 menu apps > develop apps > Luup files
4.  I created a new device (Sony TV) using the UI5 menu apps > develop apps > create device.  I roughly followed the print screen from reply #20 by Teonebellow, but I ONLY filled in the description, upnp devicefile name, upnp implementation filename, and room. 
5.  I then modified the new device (Sony TV) using the UI5 menu devices and added the SQ Blaster plugin as the infrared transmitter on the settings tab.
6.  I then created a new scene > advanced > selected my device (Sony TV) and then selected action of OnOff to toggle TV on.  I then added a delay to this scene of 180 minutes and again selected the Sony TV with action of OnOff to turn TV off. 
7.  When I call this scene, the TV goes on and then goes off 180 minutes later.

Thank you all for your help.  I hope my reply will help any other newbies out there to do the same.
Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: conradodse on August 08, 2013, 04:44:36 pm
HI All

Just transformed the DEVxxxx file
now i got 3 files

devLOGITECH
D_LOGITECH
I_LOGITECH
changed the name inside of the dev and D_ files to devLOGITECH

3.  I uploaded these files to my Vera using the UI5 menu apps > develop apps > Luup files
4.  I created a new device (LOGITECH) using the UI5 menu apps > develop apps > create device.  I roughly followed the print screen from reply #20 by Teonebellow, but I ONLY filled in the description, upnp devicefile name, upnp implementation filename, and room.
5.  I then modified the new device (LOGITECH) using the UI5 menu devices and added the SQ Blaster plugin as the infrared transmitter on the settings tab.

NOthing hapens!!! Were are the comands of my Logitech? on/off, volume up down?

i can only use the 4x ir emmiter at the back of the SQ? to control more devices i must use the IR cable spliters?
the regular blaster wont work?

PLease help its the last thing a need to do here =)

Title: Re: SQ Remote Plugin for Vera - Almost Working
Post by: bluman on November 24, 2013, 02:36:03 am
I was able to successfully control my Sony Bravia KDL-55NX720 using the SQ Blaster Plus and my Vera Lite UI5 and these instructions.  I wanted to turn my TV on and off with a scene.  It was confusing for me to follow the thread of this post, so I will summarize how I did this:

1.  From the Vera UI5 web control panel I installed the SQ Blaster plugin via the menu apps > install apps
2.  I downloaded the files proved in reply #7 by Chixxi (thank you for providing these files)
3.  I uploaded these files to my Vera using the UI5 menu apps > develop apps > Luup files
4.  I created a new device (Sony TV) using the UI5 menu apps > develop apps > create device.  I roughly followed the print screen from reply #20 by Teonebellow, but I ONLY filled in the description, upnp devicefile name, upnp implementation filename, and room. 
5.  I then modified the new device (Sony TV) using the UI5 menu devices and added the SQ Blaster plugin as the infrared transmitter on the settings tab.
6.  I then created a new scene > advanced > selected my device (Sony TV) and then selected action of OnOff to toggle TV on.  I then added a delay to this scene of 180 minutes and again selected the Sony TV with action of OnOff to turn TV off. 
7.  When I call this scene, the TV goes on and then goes off 180 minutes later.

Thank you all for your help.  I hope my reply will help any other newbies out there to do the same.



Gordon, Does the HDMI 1 input work for you on the 55NX720 using the device? I'm using the 40NX720 and the TV acknowledges receipt of the code, however, it does not switch to the HDMI inout. I've searched everywhere and cannot find the discrete UEI code for HDMI 1, HDMI 2 and HDMI 3 anywhere.