The Vera Community forums have moved!

General => Remote Control => AutHomation (Android) => Topic started by: Odeen on April 02, 2012, 06:58:05 pm

Title: (Fixed in 2.0 Beta 6) Was: AutHomation issue on Sprint 4G
Post by: Odeen on April 02, 2012, 06:58:05 pm
EDIT: This is fixed in 2.0 Beta 6


Hi guys,

I have recently upgraded to a new cell phone - Samsung Galaxy SII Epic 4G Touch, and installed AutHomation (non-HD version 2.0.1.5) on it.  The Samsung puts the 4G (Wimax) radio to sleep when the data connection is not used.  It also turns the 4G radio off when Wi-Fi is on.  This doesn't seem to prevent Gmail notifications or Yahoo Messenger from working. 

I'm encountering a problem with AutHomation, though.  AutHomation consistently gives a "No internet connection" error message when 4G is enabled.

It works perfectly well if I disable 4G and run on the 3G radio alone.  It also works perfectly well at home on WiFi.  AutHomation doesn't see the 4G connection even if I wake the 4G radio up manually (by, say, opening the web browser).

It's probably something peculiar about how Sprint manages its 3G and 4G networks, or something funky about Samsung's 4G.  It's not showstopper bug, but it is an issue.  I just need to surreptitiously turn 4G off before I demo the app to others.  :)
Title: Re: AutHomation issue on Samsung Galaxy S2 Epic 4G Touch (Sprint, 4G network only)
Post by: garrettwp on April 02, 2012, 09:35:14 pm
Odeen,

I am a Sprint user as well, but no 4G service in my town. Before getting data I check to make sure there is an internet connection, e.g. wifi, mobile network. It looks like the 4G radio uses a different state than the mobile network state. Let me look into it and I'll provide a fix in the next beta build.

Thanks for pointing it out,

- Garrett
Title: Re: AutHomation issue on Samsung Galaxy S2 Epic 4G Touch (Sprint, 4G network only)
Post by: garrettwp on April 03, 2012, 07:27:25 am
Looked at the Android API for the connection settings and it looks like wimax has it's own connection details where all other mobile networks use the mobile connection details. I have added code to check for wimax.

- Garrett
Title: Re: AutHomation issue on Samsung Galaxy S2 Epic 4G Touch (Sprint, 4G network only)
Post by: pgrover516 on April 03, 2012, 01:47:28 pm
Geez Garrett you are a coding machine, lol, Nice Work!    8)
Title: Re: AutHomation issue on Samsung Galaxy S2 Epic 4G Touch (Sprint, 4G network only)
Post by: tomcat on April 04, 2012, 05:48:58 pm
It could be your carrier, I have two days using a S2 LTE and AutHomation over a HSPA+ (waiting real LTE soon) network here in Colombia and haven not got a single connection issues ....I think I'll buy Garrett a coffee......!
Title: Re: AutHomation issue on Samsung Galaxy S2 Epic 4G Touch (Sprint, 4G network only)
Post by: Odeen on April 04, 2012, 09:14:27 pm
Leave it to Sprint to make things complicated!

Thank you for your efforts, Garrett.  I look forward to the next release :)
Title: Re: AutHomation issue on Samsung Galaxy S2 Epic 4G Touch (Sprint, 4G network only)
Post by: garrettwp on April 04, 2012, 10:12:07 pm
Hopefully the fix I have added will work. I have no way of testing it as I do not have wimax in my area. :(

- Garrett
Title: Re: AutHomation issue on Samsung Galaxy S2 Epic 4G Touch (Sprint, 4G network only)
Post by: Odeen on April 05, 2012, 02:33:00 pm
I'll be happy to test the updated version on Wimax - as long as reasonable care has been taken that the Wimax fix doesn't reroute all calls through Djibouti.  :)

Then again, Wimax is for data only, and shouldn't affect calls....  :) :)