Author Topic: Russound RNET Plugin v1.4  (Read 38729 times)

Offline jamenjay

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: Russound RNET Plugin v1.4
« Reply #165 on: October 10, 2015, 09:46:12 pm »
@Sundayfun     I would love to see some better developments with this.....  I abandoned using it and now control with casatunes...  Great music server that can control russound via ios or android        I would still like to get everything in one app

I have
 lutron radio Ra    "first generation"   controlled via usb serial and the lutron rs232 device
 russound caa-66
 casatunes
 nest
 honeywell lynxx alarm

i also use veramate and had made some adjustments to the app layout files to make button sizes larger and remove buttons i didnt need

Im also using the vera edge I might add ...... my lite died :(
 

Offline silverhaze

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Russound RNET Plugin v1.4
« Reply #166 on: October 21, 2015, 11:58:39 pm »
I have 2 russound C3 6 zone amps in my system. I can get the app to control the first 6 zones perfectly but it will not allow me to add the zones on my second amp.  It will add zone 7 and 8 which do not work. I assume they would be for a single C5 amp?

Has anyone out there had experience with this that could help?

Offline joelc73

  • Sr. Newbie
  • *
  • Posts: 28
  • Karma: +0/-0
Re: Russound RNET Plugin v1.4
« Reply #167 on: October 22, 2015, 09:37:48 am »
Does anyone know if this plug-in would work with Integra A-bus (which I believe is just a licensed version of Russound)?

Thanks,
JC

Offline LeonPhelps

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
Re: Russound RNET Plugin v1.4
« Reply #168 on: March 29, 2016, 02:12:13 am »
Upgraded to Vera Edge today and got RNET running, but it keeps saying cant detect device on the notification panel.

Offline jamenjay

  • Newbie
  • *
  • Posts: 10
  • Karma: +0/-0
Re: Russound RNET Plugin v1.4
« Reply #169 on: June 03, 2016, 09:16:01 pm »
did you re setup your serial port with the correct baudrate etc ?

Offline amikolajczyk

  • Newbie
  • *
  • Posts: 7
  • Karma: +1/-0
Re: Russound RNET Plugin v1.4
« Reply #170 on: July 18, 2016, 11:16:12 pm »
I know this plugin hasn't been developed for a good long while now, but I was wondering if anyone out there had any advice. Trying to use it with an MCA-C5. Serial-USB port looks good, logs check out OK but I'm getting a "Can't Detect Device"

Verified my USB-Serial is located at \dev\ttyUSB0 and that's what's listed in my controller's path variable as well as my serial port config.

What I'm seeing in the logs is lots and lots of these:
Code: [Select]
luup_log:281: Received full buffer from controller via serial F0 00 00 7D 00 00 7F 06 16 00 90 01 10 36 F7 <0x2e6e8680>
Is there something in particular that you have to do to tell the plugin which model of Russound controller it's using? Is there anywhere else to look or anything else to look for in the logs?

Thanks for any advice,
Adam

Offline e50golf

  • Sr. Newbie
  • *
  • Posts: 22
  • Karma: +0/-0
Re: Russound RNET Plugin v1.4
« Reply #171 on: February 12, 2017, 08:54:58 am »
Change Baud rate 38400. This solved problem for me.

Offline drweiler

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: Russound RNET Plugin v1.4
« Reply #172 on: October 22, 2017, 02:21:38 pm »
Just got my VeraPlus, one of the first things to try was connecting to my Russound CAM6.6 using this Russound RNET plugin.  I may be missing something (am I?), but I didn't find any documentation other than this thread on the forum, which was somewhat helpful.
I did get it to connect almost right away, but I had two problems.  The first was that I was only able to control the first two of 6 zones, i.e. other than the master device, there were only 2 zone devices created.  After much experimentation, I got it to work by uninstalling and installing in this order:
1. install the plugin from the "Install apps" menu
2. From the Advanced settings, Variables tab, edit "ZoneIds" - was "01,02", changed to "01,02,03,04,05,06"
3. From Developer apps, Serial Port configuration - set "Used by device:" to "Russound RNET Controller"
At some point the 6 zone devices get created, I'm not sure exactly when, it seemed to be the first time I clicked "All on" or "All off".  But the trick seemed to be to add the 4 extra zone IDs before the zone devices get created, because if only two zone devices are created, there seems to be nothing you can do to add the other 4 except start over.
So control seems to be working reliably for what I wanted - turning zones on and off, setting the volume, and muting.
The second problem is minor - for the master device (all on/ all off), I have a permanent "Can't Detect Device" message in red, a minor annoyance.