Author Topic: OpenTherm Gateway plugin  (Read 50390 times)

Offline graafish

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
Re: OpenTherm Gateway plugin
« Reply #255 on: January 16, 2017, 10:33:14 am »
Hi, I think I found a bug.

When the plugin looses the IP connection with the OTG it reloads the Vera (UI7) but can?t reconnect.
Somehow the port number after the IP address on the settings page gets removed.

I assume this is how you fill in the IP:PORT address: 192.168.1.130:1001
I my case the :1001 is missing after the reload.

Offline reneboer

  • Hero Member
  • *****
  • Posts: 1104
  • Karma: +59/-30
Re: OpenTherm Gateway plugin
« Reply #256 on: January 16, 2017, 04:51:21 pm »
Hi,

The plugin only reads the IP address value, it never sets it. So I am puzzled how this could have happened. It is more likely a Vera thing.

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline pcvdhurk

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
Re: OpenTherm Gateway plugin
« Reply #257 on: January 20, 2017, 05:34:44 am »
Hi, I think I found a bug.

When the plugin looses the IP connection with the OTG it reloads the Vera (UI7) but can?t reconnect.
Somehow the port number after the IP address on the settings page gets removed.

I assume this is how you fill in the IP:PORT address: 192.168.1.130:1001
I my case the :1001 is missing after the reload.

Yes that happened to me before, that is why i put this in the startup LUA (with your IP and port filled in):

Code: [Select]
luup.ip_set("192.168.1.130:1001",XX)

Where XX is the device number of your OTGW plugin.

Never lost connection again.

Offline reneboer

  • Hero Member
  • *****
  • Posts: 1104
  • Karma: +59/-30
Re: OpenTherm Gateway plugin
« Reply #258 on: January 23, 2017, 04:49:04 pm »
Hi all OTG users.

The last couple of weeks my VeraEdge started to become unstable and was restarting luup very frequently. Initially Vera support pointed to the SmartMeter plugin as the culprit and after disabling that, things got mildly better. From reloading hourly, to twice an hour. Now i also disabled the OTG plugin and all reloads stopped. Happy VeraEdge, not so happy me.

Both plugins process quite a bit of data via the incomming method. So now I am wondering if that may be the problem.

So is any of the other OTG users experiencing very frequent luup reloads?

I have both plugins now running on openLuup and while porting the OTG plugin I found that the string:split function in OTG caused ALTUI to crash quite badly. But maybe that was also happening with the latest UI7 release. I fixed that and will try to enable OTG on my VeraEdge again, but with all functionality i use OTG for that takes me a whole evening.

Interested in your experiences.

Cheers Rene

2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline pcvdhurk

  • Newbie
  • *
  • Posts: 14
  • Karma: +0/-0
Re: OpenTherm Gateway plugin
« Reply #259 on: January 24, 2017, 08:58:49 am »
Hi all OTG users.

The last couple of weeks my VeraEdge started to become unstable and was restarting luup very frequently. Initially Vera support pointed to the SmartMeter plugin as the culprit and after disabling that, things got mildly better. From reloading hourly, to twice an hour. Now i also disabled the OTG plugin and all reloads stopped. Happy VeraEdge, not so happy me.

Both plugins process quite a bit of data via the incomming method. So now I am wondering if that may be the problem.

So is any of the other OTG users experiencing very frequent luup reloads?

I have both plugins now running on openLuup and while porting the OTG plugin I found that the string:split function in OTG caused ALTUI to crash quite badly. But maybe that was also happening with the latest UI7 release. I fixed that and will try to enable OTG on my VeraEdge again, but with all functionality i use OTG for that takes me a whole evening.

Interested in your experiences.

Cheers Rene

Not that i know. I am running both the OTG and the Smartmeter plugin and no instability issues at all. Maybe luup restarts without noticing, so I added a log function to my startup lua to monitor luup restarts.

Will monitor it for a while.

Edit: still one day left and no restarts at all. Seems pretty stable to me so far!

Edit: one restart in the meantime.
« Last Edit: January 30, 2017, 05:54:24 am by pcvdhurk »

Offline reneboer

  • Hero Member
  • *****
  • Posts: 1104
  • Karma: +59/-30
Re: OpenTherm Gateway plugin
« Reply #260 on: February 17, 2017, 07:28:04 am »
Hi,

While porting to openLuup I found some issues, and did a bit of clean up in the code. Nothing major. So version 1.19 is now on the MIOS App Market and on the ALTUI App Store.

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline bartandeweg

  • Jr. Member
  • **
  • Posts: 58
  • Karma: +0/-0
Re: OpenTherm Gateway plugin
« Reply #261 on: April 18, 2017, 11:04:33 am »
Hi All,


Fomr some strange reason my OT gateway is acting strange in the last couple of weeks. Every now and then i get the error "Communication failure: last communication at <DATE> / <TIME>" in UI7 of my Vera. The gateway becomes unresponsive.


Anyone. Any ideas on this?




Offline fabstar81

  • Full Member
  • ***
  • Posts: 116
  • Karma: +2/-0
Re: OpenTherm Gateway plugin
« Reply #262 on: April 18, 2017, 11:23:26 am »
I have exactly the same, only thing that works is either rebooting vera or the OTGW. Mine is a USB version by the way.

But because of all the scenes that are relying on the OTGW it's become pretty useless ever since I'm getting those errors.

Sometimes the communication failure error appears even after several minutes after reboot. So any scenes I should manually trigger within those minutes before losing communication again...

Any help is desperately appreciated

Offline reneboer

  • Hero Member
  • *****
  • Posts: 1104
  • Karma: +59/-30
Re: OpenTherm Gateway plugin
« Reply #263 on: April 19, 2017, 04:25:22 am »
Hi,

I am using the Ethernet version and I had the OTGW it self be unresponsive maybe twice in three years. Other than that its been solid. I am not running the very latest firmware of the OTGW.

Not sure if having the USB version puts a bigger load on the Vera or not. I have noticed that a reboot command on the Vera clears a lot more memory than just a lua reload. Have you tried that?

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline bartandeweg

  • Jr. Member
  • **
  • Posts: 58
  • Karma: +0/-0
Re: OpenTherm Gateway plugin
« Reply #264 on: April 19, 2017, 05:07:24 am »
Tried everything. Hard rebooting, soft rebooting, LUA reload. Mine is also the USB version. Tried a direct connection without an usb-hub. Nothing seems to help.
It's a new issue which is now happening for a couple of weeks. Maybe it started after the latest firmware update but not totally sure about this.

Offline reneboer

  • Hero Member
  • *****
  • Posts: 1104
  • Karma: +59/-30
Re: OpenTherm Gateway plugin
« Reply #265 on: April 20, 2017, 05:09:49 am »
Hi,

What is the OTGW software version you are running? Can you check the Vera log file for any clues? Or maybe connect it to your PC and look with the OTG monitor program to make sure nothing is wrong with the OTGW itself?

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline fabstar81

  • Full Member
  • ***
  • Posts: 116
  • Karma: +2/-0
Re: OpenTherm Gateway plugin
« Reply #266 on: April 21, 2017, 08:16:27 am »
i find it hard to believe that it has something to do with the OTGW itself. Because we both have same issues around the same time (vera update) that it stopped working reliably.

the vera log files i might be able to check, hopefully that will tell us something. what directory are they present in?

Offline reneboer

  • Hero Member
  • *****
  • Posts: 1104
  • Karma: +59/-30
Re: OpenTherm Gateway plugin
« Reply #267 on: May 22, 2017, 01:31:06 pm »
Hi,

I found an issue with the plugin were each variable change caused four variable watches to fire. As there are a lot of varaibles in the OTG plugin this may be why there is some instability.

Attached is version 1.12 . Can you test it with me and let me know if your stability problems?

Cheers Rene
2xVeraLite, VeraEdge, openLuup, ALTUI, 20 switches, 10 dimmers, 20 sensors, 10 scene controllers, 1 Harmony Hub, many plug-ins. Not enough time.

Offline fabstar81

  • Full Member
  • ***
  • Posts: 116
  • Karma: +2/-0
Re: OpenTherm Gateway plugin
« Reply #268 on: May 23, 2017, 03:28:56 am »
Hi,

I found an issue with the plugin were each variable change caused four variable watches to fire. As there are a lot of varaibles in the OTG plugin this may be why there is some instability.

Attached is version 1.12 . Can you test it with me and let me know if your stability problems?

Cheers Rene

surprisingly the last week the OTGW has been more stable than before. i didn't have to reload or restart the vera for days now. however, i just uploaded the new version of the I_*.*.lua file to see if it improves even more.

i'll let you know.

ik laat het weten.

Offline fabstar81

  • Full Member
  • ***
  • Posts: 116
  • Karma: +2/-0
Re: OpenTherm Gateway plugin
« Reply #269 on: May 26, 2017, 05:42:35 am »
up till now the communication has not failed yet. so positive change. "unfortunately" was very stable the last time so i cannot tell for sure, that this is the new version at work, or something else just happened to be the solution.