Author Topic: Vera and an ISY994i  (Read 74406 times)

Offline PurdueGuy

  • Hero Member
  • *****
  • Posts: 1169
  • Karma: +21/-0
Re: Vera and an ISY994i
« Reply #405 on: August 17, 2016, 01:46:06 am »
That fixed it. I'm using the model 2342-2. I linked it with the ISY using the RemoteLinc 2 option under Link Management. Now it shows up.

I'll let you know if any scene issues come up.
Glad to hear that.   Keep me posted on any other issues!
Vera3, Leviton, Intermatic, SQ Blaster, HomeWave, DSC 1832, Insteon/Altsteon

Offline 93732

  • Jr. Member
  • **
  • Posts: 87
  • Karma: +2/-0
Re: Vera and an ISY994i
« Reply #406 on: August 17, 2016, 05:00:42 pm »
Thank you very much PurdueGuy!  I will have to look into buying some insteon Hidden Door Sensors. 

Secondly, perhaps you can include the variable name change in the first post so that is is more visible?  I was going ask you if you implemented that "revision" in the currently version but luckily stumbled upon your post.




Well, I just commited/pushed changes for the following:

- Fixed UI7 "Cannot detect device" error
- Added Insteon Thermostat support
- Added Hidden Door Sensor (HDS) support

If you can't get the changed from git, I will be updating the first post momentarily.

WARNING: This changes one of the variable names for calling ISY scenes.   See the post here:
http://forum.micasaverde.com/index.php/topic,17309.msg224364.html#msg224364
I don't know what the old code had, so I wanted everyone to be made aware now.

Offline PurdueGuy

  • Hero Member
  • *****
  • Posts: 1169
  • Karma: +21/-0
Re: Vera and an ISY994i
« Reply #407 on: August 17, 2016, 05:24:45 pm »
Thank you very much PurdueGuy!  I will have to look into buying some insteon Hidden Door Sensors. 

Secondly, perhaps you can include the variable name change in the first post so that is is more visible?  I was going ask you if you implemented that "revision" in the currently version but luckily stumbled upon your post.
Happy to help!   And updated!
Vera3, Leviton, Intermatic, SQ Blaster, HomeWave, DSC 1832, Insteon/Altsteon

Offline boojew

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +0/-0
Re: Vera and an ISY994i
« Reply #408 on: October 31, 2016, 09:55:10 pm »
After following this thread for a while, I finally got this setup and its great! Incredibly responsive!

Two issues that I have run into:
1. This may be superficial as everything appears to be working, but the plugin shows "Running" and "Disconnected"
2. The local status of the devices I am controlling from the Vera is not getting updated. eg from Vera, I turn on a light through the plugub (and it works), but the Vera continues to show the light as off. Same issue if I initiate it from the ISY and/or the light switch. I have tried changing the poll timer to 5s, but that didnt help


Note, I'm on the latest public release of UI7.

Similarly, is there anyway I can trigger ISY programs from my Vera? Or even just scenes? 

EDIT: I came back to this today and #1 seems to have resolved itself. Perhaps just patience? #2 still seems to an issue and I still dont see my programs. Hoping there is a fix for these 2 items

Thanks!
« Last Edit: November 03, 2016, 09:33:44 am by boojew »

Offline Aaron

  • Hero Member
  • *****
  • Posts: 1940
  • Karma: +60/-193
Re: Vera and an ISY994i
« Reply #409 on: December 04, 2016, 01:53:26 am »
After following this thread for a while, I finally got this setup and its great! Incredibly responsive!

Two issues that I have run into:
1. This may be superficial as everything appears to be working, but the plugin shows "Running" and "Disconnected"
2. The local status of the devices I am controlling from the Vera is not getting updated. eg from Vera, I turn on a light through the plugub (and it works), but the Vera continues to show the light as off. Same issue if I initiate it from the ISY and/or the light switch. I have tried changing the poll timer to 5s, but that didnt help


Note, I'm on the latest public release of UI7.

Similarly, is there anyway I can trigger ISY programs from my Vera? Or even just scenes? 

EDIT: I came back to this today and #1 seems to have resolved itself. Perhaps just patience? #2 still seems to an issue and I still dont see my programs. Hoping there is a fix for these 2 items

Thanks!

Is everything working for you now?  if not, did you try the latest beta (1.7.2349)?

Offline boojew

  • Jr. Member
  • **
  • Posts: 74
  • Karma: +0/-0
Re: Vera and an ISY994i
« Reply #410 on: January 08, 2017, 09:23:35 pm »
After following this thread for a while, I finally got this setup and its great! Incredibly responsive!

Two issues that I have run into:
1. This may be superficial as everything appears to be working, but the plugin shows "Running" and "Disconnected"
2. The local status of the devices I am controlling from the Vera is not getting updated. eg from Vera, I turn on a light through the plugub (and it works), but the Vera continues to show the light as off. Same issue if I initiate it from the ISY and/or the light switch. I have tried changing the poll timer to 5s, but that didnt help


Note, I'm on the latest public release of UI7.

Similarly, is there anyway I can trigger ISY programs from my Vera? Or even just scenes? 

EDIT: I came back to this today and #1 seems to have resolved itself. Perhaps just patience? #2 still seems to an issue and I still dont see my programs. Hoping there is a fix for these 2 items

Thanks!

Is everything working for you now?  if not, did you try the latest beta (1.7.2349)?


I am on 1.7.902 now (and pretty sure I was on 1.7.2349 previously) and I'm still seeing frequent disconnects on the  ISY plugin, and hence status not updated, but it does appear to be better. I have added the scene that restarts the daemon, so I am guessing that is what helped. I actually just came back to this thread today for the first time in a while to try and understand the best way to call ISY scenes and/or programs from the Vera. Would be great if someone would add this to post #1.