Author Topic: Fibaro Roller shutter FGRM-222 calibration solution  (Read 2012 times)

Offline Sayhello

  • Newbie
  • *
  • Posts: 3
  • Karma: +3/-0
Fibaro Roller shutter FGRM-222 calibration solution
« on: August 14, 2016, 04:18:41 pm »
Configuration and calibration Fibaro Roller Shutter module FGRM-222.

Hi All,

First I had many problems to calibrate the module. Percentage didn?t work.
The FGRM-222 needs to be a calibration process first.

The module needs a minimum ballast of 1W or more (230V screen motor with end switches)
If you use  a relay on the outputs, the calibration didn?t work.

I have a solution for this:

First 1 connect a toggle switch(1 - 0 - 2)on the outputs Q1 and Q2  from the FGRM-222.
1 to output Q1, 2 to output Q2 and the P (middle contact) connect to a 230V/20W bulb, other site of the bulb connect to N.
If I put the switch on 1 and connect S1 to L the bulb is on. Put the switch on 2 the bulb is on if I connect S2 to L

With a stopwatch I measuring the time that the screen needs to be go up and down. (For me 40s up and 40s down).

Set the switch to position2
Now I start the calibration function (Zwave options  variable 29>1 didn?t work fine for me) so I use the manual option: Connect S1 3x fast to L, 3xfast to L, 3x fast to L and the calibration function will start
The bulb go on.
Start the stopwatch and put the switch in position 1 after the time is expire that the screen needs to be go up.
Now put the switch in position 2 after the time is expire that the screen needs to be go down.
After  these process the FGRM-222  calibration is almost completed.

NOW FIRST: go to your device option of the FGRM-222 in the vera. (Devices>FGRM-222>Device Options)

Set the variable 18 to 0 and save this. You can check this if you select back and select device options for the 2 time. Now you will see the current value. If it?s ok? it?s 0. If it is 1 or more it is not ok? and you will be need to store the variable for the 2 time.
If it is be 0 the calibration process is completed  and the FGRM-222 is ready for use. Percentage will work fine now.
« Last Edit: August 14, 2016, 04:22:49 pm by Sayhello »

Offline conchordian

  • Sr. Member
  • ****
  • Posts: 304
  • Karma: +4/-1
Re: Fibaro Roller shutter FGRM-222 calibration solution
« Reply #1 on: January 12, 2017, 09:09:55 pm »
Thank you very much for this.  My roller shutter module wouldn't calibrate either. I could use the Vera to initiate the calibration process, but as soon as the curtains got to one end, it would just stop and the module would blink red, instead of moving back in the opposite direction.

I hooked up a light in parallel with the motor, so that I didn't have to worry about timing it. I just flicked the attached light with a toggle switch when the curtains got to one end, and hey presto, the curtains moved back in the opposite direction like they should, and the percentage now has shown up in the UI properly.  Before doing this, if you clicked on anything in between 0 and 100%, the curtains would automatically open or close entirely; there was no in between.

I think there is still something dodgy about the Watts being reported, as it seems to be constantly on 1 Watt, but that doesn't really matter.

This was in conjunction with a DOOYA DT82TV motor.  I think perhaps the electronic limiting of the motor interferes with the calibration process as it slows down automatically, and is not relying on the Z-Wave module to find, and set the limits.

Offline conchordian

  • Sr. Member
  • ****
  • Posts: 304
  • Karma: +4/-1
Re: Fibaro Roller shutter FGRM-222 calibration solution
« Reply #2 on: February 05, 2017, 10:39:24 pm »
I found a setting which helps this combination of module, ( Fibaro Roller Shutter 2 - FGR-222 v2.5 ) and motor.  Parameter 22 sets the time out of the motor which is necessary because otherwise the Z-Wave module keeps powering the motor, even after it has reached the end.

It doesn't matter because the motor has its own limit switch, but if you press the button on the wall, then you need to press it twice, (once to stop the Fibaro from still keeping the motor running, and then again to do what you want).  By timing, (in my case the curtains fully opening, or closing takes ~12 seconds), I set the motor to run for a maximum of 15 seconds, as per the picture below.

Now it works with just one press, no matter if it was operated with Z-Wave via Alexa, PC, tablet, etc. or the physical switch.

The other way to avoid the problem would be to set scene activation on, (parameter 50 to 1) and monitor when you get a single keypress, and run a scene that opens, or closes.

For some reason I can't turn on scene activation on one of my Fibaro modules, even thoough it accepts the parameter.  Weird: one does, one doesn't.  You need to press the physical button and scene activation variables then show up.
« Last Edit: February 10, 2017, 05:59:34 pm by conchordian »

Offline bixy

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
Re: Fibaro Roller shutter FGRM-222 calibration solution
« Reply #3 on: February 19, 2017, 02:35:53 pm »
I could not calibrate this motor Dt88TV with Fibaro and I have changed all the motors with DT82TS and everything is perfect now the procentage works fine: I can close 20% or 75% or 100%.

Offline Angstrom

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
Re: Fibaro Roller shutter FGRM-222 calibration solution
« Reply #4 on: March 25, 2017, 08:20:52 am »
Hi,

Is it possible for you to explain this wiring a bit further - maybe with a diagram?

I am trying to manually calibrate my Fibaro roller shutter controller as the automatic process doesnt work (the shutter makes for a second and then stops). I have tried to follow what you have outlined, but I dont seem to get power to the light switch in any position of the switch.

I have connected a toggle switch (1 - 0 - 2) with position 1 connected to Q1 and position 2 connected to Q2. Position 0 is connected to the lamp, and the other side of the lamp is connected to the neutral. The Line and Neutral on the Fibaro module are both connected. (The line is branched to go into the Fibaro and S1 or S2, and the neutral is branched to go the Fibaro and the lamp).

In this set up, I have the following results:

A. The cable from the switch to Q1 is hot when the switch is in position 1 (and the Q2 cable is not hot);
B. The cable to Q2 is hot when the switch is in position 2 (and the Q1 cable is not hot) and
C. Both cables are hot when the switch is in position 0.
D. The cable from position 0 to the lamp is not hot in any switch position of 1, 2 or 0.

When I connect an active line cable to S1 or S2, the results stay the same - there is no power to the light bulb in any position, the cable to Q1 only is hot in position 1; the cable to Q2 only is hot in position 2; and both Q1 and Q2 cables are hot in position 0; but never the cable from position 0 to the light bulb.

I wonder if I've made a mistake in the wiring somewhere. There seems to be power to the Fibaro unit, because if I press the small button on it the LED light changes colour.

Do you have any suggestions? Thanks in advance!



The module needs a minimum ballast of 1W or more (230V screen motor with end switches)
If you use  a relay on the outputs, the calibration didn?t work.

I have a solution for this:

First 1 connect a toggle switch(1 - 0 - 2)on the outputs Q1 and Q2  from the FGRM-222.
1 to output Q1, 2 to output Q2 and the P (middle contact) connect to a 230V/20W bulb, other site of the bulb connect to N.

<I think this part is ok>

If I put the switch on 1 and connect S1 to L the bulb is on. Put the switch on 2 the bulb is on if I connect S2 to L

<When I put the switch on 1 and connect to S1, the light bulb doesnt come on (there is no power from the live cable at position 0 of the switch to the lamp). When I put the switch on position 2, I have the same results with no power to the bulb>.