Author Topic: Hide the Hub  (Read 293 times)

Online tomtcom

  • Hero Member
  • *****
  • Posts: 832
  • Karma: +18/-30
Hide the Hub
« on: December 28, 2016, 04:01:14 pm »
Hello,

I use this plugin for access to the Ring Video Doorbell. I do not have a Wink Hub. I noticed that the hub device does not have the parameter "onDashboard". Is there a method to hide the Wink Hub device so I don't see it as a failed device?

Online tomtcom

  • Hero Member
  • *****
  • Posts: 832
  • Karma: +18/-30
Re: Hide the Hub
« Reply #1 on: January 01, 2017, 02:13:39 pm »
Hello,

I use this plugin for access to the Ring Video Doorbell. I do not have a Wink Hub. I noticed that the hub device does not have the parameter "onDashboard". Is there a method to hide the Wink Hub device so I don't see it as a failed device?

Found the answer from another thread, this works >

luup.set_failure(false,83)
return true

(83 is my Wink device number)

Offline Don Phillips

  • Sr. Member
  • ****
  • Posts: 411
  • Karma: +10/-3
Re: Hide the Hub
« Reply #2 on: January 01, 2017, 07:51:44 pm »
+1 - hides my DVR plug-in error very nicely.
Vera 3, UI7 1.7.919, CT101 t-stat, Everspring motion detector, GE/Jasco switch, Leviton outlet, AeonLabs door sensor, Insteon garage control, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual & Multi Switch, Weather, Sys. Mon.

Offline treetop777

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-2
Re: Hide the Hub
« Reply #3 on: March 17, 2017, 10:04:03 pm »
Where do you put that code?  and what is the code to "un"- hide it?

Thanks in advance.

Offline Don Phillips

  • Sr. Member
  • ****
  • Posts: 411
  • Karma: +10/-3
Re: Hide the Hub
« Reply #4 on: March 18, 2017, 02:29:07 pm »
I put it in my startup LUA, specifically:

luup.set_failure(false,88) -- DVR plug-in
luup.set_failure(false,73) -- garage man-door
return true

That second one is for a door sensor.  Does not work, it still shows "can't detect device" from time to time although the device works fine.
Vera 3, UI7 1.7.919, CT101 t-stat, Everspring motion detector, GE/Jasco switch, Leviton outlet, AeonLabs door sensor, Insteon garage control, Blue Iris, Sricam SP011, iPhone locator, APCUPSD, VeraMate, VeraAlerts, PLEG, House Modes, Countdown Timer, DVR, Virtual & Multi Switch, Weather, Sys. Mon.

Offline treetop777

  • Full Member
  • ***
  • Posts: 141
  • Karma: +3/-2
Re: Hide the Hub
« Reply #5 on: March 18, 2017, 10:57:10 pm »
I put it in my startup LUA, specifically:

luup.set_failure(false,88) -- DVR plug-in
luup.set_failure(false,73) -- garage man-door
return true

That second one is for a door sensor.  Does not work, it still shows "can't detect device" from time to time although the device works fine.

Thanks!