Author Topic: Device is not responding  (Read 337 times)

Offline marksand

  • Sr. Newbie
  • *
  • Posts: 25
  • Karma: +0/-0
Device is not responding
« on: March 08, 2017, 09:58:27 am »
I've noticed that several other members suffer from this too:
Alexa "thinks", says "Sorry, device X is not responding", and soon later vera does turn on\off the requested light.

Has anyone found a workaround?

My setup - VeraEdge with 18 devices mapped in alexa, no groups

Offline anthonyris

  • Full Member
  • ***
  • Posts: 221
  • Karma: +4/-1
Re: Device is not responding
« Reply #1 on: March 08, 2017, 12:41:32 pm »
Still seeing the delay irregularly. Devices sometimes respond immediately, sometimes a long delay. Doesn't really seem to be reproducible under X circumstance. About 50% of the time I will get the "OK" confirmation from Alexa, rest of the time I get "Device not responding" and then the device responds or scene activates.

I wonder if the Vera server that is interfacing with Alexa is a bit underpowered, laggy. Am not seeing the lag when I run Vera scenes directly, only via the Alexa-Vera interface. All other Alexa functions are immediate and snappy, including 3rd party integrations like adding items to my Evernote account, etc.   

Using Alexa Groups vs using Vera Scenes also doesn't seem to make *too much* of a difference either, perhaps a half-beat faster using Vera scenes. The lag originates elsewhere.

I *do* see UI7 sending a lot of seemingly spurious alerts about Devices not responding/changing state (cams, locks, etc.). Wonder if that is gumming her up...

!!! Overall, it's pretty cool, hope we can get the kinks ironed out. !!!
.//A.
Vera3x2, Leviton, GE dimmers, relays and lamp modules, Sonos, Nests...

Offline ilikelife

  • Full Member
  • ***
  • Posts: 126
  • Karma: +2/-0
Re: Device is not responding
« Reply #2 on: March 09, 2017, 10:45:48 am »
I have the same problem every time.  "Sorry, device (name) is not responding".  Then it does whatever was requested.

I may have the dates wrong, but I installed the first beta and it worked correctly (no "Sorry" message) and was quick.  Then when the new beta was released (Feb 1?) I installed that, and the General release on Feb 22, and have had the slow response and Sorry since then.  It all crashed yesterday, but today's Skill Update (2) installer brought me back to everything working again, but still with the slow message.

I have a fairly complex system, but I've tried lots of things to simplify it.  I have a Harmony Skill on my Echo, and 2 controllers (Vera Plus and Vera 3)

I did submit a ticket to Vera Tech support on Feb 6.  On Feb 10 I received a reply reminding me it's beta.  I followed up on Feb 22 after that install, and the May 5 reply says:

Quote
"we have addressed this case to our development team and they are working on this as we speak, but I don?t have an ETA for this.When we?ll have a resolution it will be posted on our official release notes:"

My case is #222913

Offline fossilnews

  • Sr. Newbie
  • *
  • Posts: 32
  • Karma: +0/-0
Re: Device is not responding
« Reply #3 on: March 09, 2017, 11:00:36 am »
My alexa skill is completely gone from my app and when I use the link in the email they sent two days ago the page says "{"message":null}".  Perhaps the skill was pulled from the alexa store?

Update: here is the new link to download the alexa skill: http://forum.micasaverde.com/index.php/topic,48139.0.html
« Last Edit: March 09, 2017, 11:03:13 am by fossilnews »