Author Topic: VeraPlus Firmware 1.7.2608 - unable to connect  (Read 460 times)

Offline slockhart

  • Newbie
  • *
  • Posts: 9
  • Karma: +1/-0
VeraPlus Firmware 1.7.2608 - unable to connect
« on: March 13, 2017, 09:50:56 pm »
After my VeraPlus updated to firmware version 1.7.2608, the controller has been completely unstable.  Tonight, I figured I would bite the bullet and restore to factory and re-install.  After I reset to factory by pressing the reset button 6 times, I started to re-add the controller.  I go to get.vera.com and delete and re-add the controller and all appears to go well.  The VeraPlus is detected and then I get the my vera needs to update software, please wait.  Now for about an hour, the Internet and Service account blink.  All the other light are on steady.  I know the port works and nothing on the network has changed.  Reset the Router as well as the ATT modem and same results. 

Before all of this, the VeraPlus would only show the power light, nothing else.  It did come up after a reboot for about 1 minute and was able to access my controlled lights, then just the power light was on.   If anyone has any suggestions, that would be awesome.

Thanks

Scott

Offline ember1205

  • Sr. Member
  • ****
  • Posts: 325
  • Karma: +4/-19
Re: VeraPlus Firmware 1.7.2608 - unable to connect
« Reply #1 on: March 13, 2017, 10:24:36 pm »
I've had a problem crop up with my controller of late, and I don't know if it's firmware on the controller, firmware on my router, or something to do with my laptop (it seems to be the only affected device). I can "correct" the lack of communications by opening the networking settings and renewing my DHCP lease and communications to the controller come back.

No rhyme or reason, but the Vera controller is never able to correctly add the MAC address of my laptop into its ARP table until I renew the lease. This also happens to force me router to recognize my laptop "anew" again as well. So, I don't know if my issue is at all similar or related to yours. But, it might be worth a try to refresh your IP Address on your client device and see what happens.

Offline andrewgarfield

  • Full Member
  • ***
  • Posts: 102
  • Karma: +6/-0
Re: VeraPlus Firmware 1.7.2608 - unable to connect
« Reply #2 on: March 14, 2017, 12:04:26 am »
I also had a weird issue with my vera not coming back up during a reboot or firmware upgrade.  And now I know why.

For a while my Yamaha Receiver kept getting kicked offline constantly as soon as it got an IP address.  After some research I actually found that it was my vera causing the problems.  Apparently it was sending a flood of multicast packets to the receiver whenever it came online.  To fix it, I used the Unifi software to limit the amount of multicast packets Vera could send/receive to about 100 packets/second.   And it solved my Yamaha problem right away.

However, I started to then get the problem where after the Vera would restart or upgrade the firmware it would either fail to come up or take a very long time.  Pings to the device during this time came back as unreachable, and every once and a while would respond for a few pings and then stop responding again.

It turns out that for whatever reason the multicast limiting on the Vera's port was the blame for it not coming up.  It was at the point where I would ping the vera and it wouldn't send any responses.  Then I would remove the rate limit and almost instantly it would come up without problem.

Long story short (sorry, sometime i'm a bit wordy), the limitation on Vera's multicast traffic somehow was to blame for it being unreachable after restart/upgrade.  Since removing this limitation, the Vera has returned to normal.

I hope this helps someone.

Offline rafale77

  • Hero Member
  • *****
  • Posts: 623
  • Karma: +34/-20
Re: VeraPlus Firmware 1.7.2608 - unable to connect
« Reply #3 on: March 14, 2017, 06:02:28 pm »
Would disabling the option for Vera to auto discover devices on the network on the net/wifi settings page resolve this?
I actually have no idea why the vera wants to auto discover devices and what it does with it. It probably sends a bunch of pings in the network though.
112 zwave nodes, 8 zigbee nodes, 231 devices, 17 apps, 100 scenes on a Vera Plus linked with Echo and HomeKit through bridges

Offline andrewgarfield

  • Full Member
  • ***
  • Posts: 102
  • Karma: +6/-0
Re: VeraPlus Firmware 1.7.2608 - unable to connect
« Reply #4 on: March 15, 2017, 10:15:48 am »
Would disabling the option for Vera to auto discover devices on the network on the net/wifi settings page resolve this?
I actually have no idea why the vera wants to auto discover devices and what it does with it. It probably sends a bunch of pings in the network though.

Probably.  A few weeks after I put the multicast rate limiting I saw of the existence on this auto discover function and immediately unchecked it.  However, at some point this function re-enabled itself again. 

It appears as though whatever was happening on my network is now resolved (despite the fact that it had gone on for months).  I no longer have the rate limit on vera, and the "discover devices" is on, but things are working okay now.

And most importantly, back to the main topic of this thread, I now no longer have issues with vera not coming up after restarts and firmware upgrades.