We have moved at community.getvera.com

Author Topic: Countdown timer plugin (UI5)  (Read 96830 times)

Offline tomgru

  • Hero Member
  • *****
  • Posts: 1403
  • Karma: +18/-6
Re: Countdown timer plugin (UI5)
« Reply #165 on: July 31, 2015, 02:53:01 pm »
Any chance this got updated very recently to a new version?  My vera3 with U15 went into infinite reboot mode this morning, and it seemed to happed every time it loaded this plugin (from status windows). I uninstalled, and the vera quick rebooting.

But i can't find it via the apps/install tab from within the Vera UI, and from the apps portal, there is no version information.

Offline futzle

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: Countdown timer plugin (UI5)
« Reply #166 on: July 31, 2015, 08:14:01 pm »
Any chance this got updated very recently to a new version?

There hasn't been an update to this plugin in more than a month.  There might be more hints about what's wrong in the Luup log.

Offline a-lurker

  • Hero Member
  • *****
  • Posts: 872
  • Karma: +66/-8
Re: Countdown timer plugin (UI5)
« Reply #167 on: August 01, 2015, 01:07:21 am »
@futzle

I'm having the same problem. Looks like the count_down_timer app is no longer in the app store. Also the count_down_timer app files are no longer in Vera in  /etc/cmh-ludl

So my Vera know it needs the app, can't find it in Vera, so goes to the app store and it's not there either. Vera freaks out and restarts.

amg0 says there was a recent app store crash:

http://forum.micasaverde.com/index.php/topic,30310.msg243121.html#msg243121

Maybe that's the problem. Any chance of posting the count_down_timer *.lzo files. Perhaps manually copying them across will fix the issue? Looks like a MCV created problem as I haven't changed anything in Vera - it just started restarting continually by itself.

See also these recent threads:

http://forum.micasaverde.com/index.php/topic,33220.msg243195.html#msg243195

http://forum.micasaverde.com/index.php/topic,33220.msg243195.html#msg243195
« Last Edit: August 01, 2015, 01:13:31 am by a-lurker »

Offline futzle

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: Countdown timer plugin (UI5)
« Reply #168 on: August 01, 2015, 01:14:14 am »
Any chance of posting the count_down_timer *.lzo files. Perhaps manually copying them across will fix the issue?
All the files are on GitHub.  You can use pluto-lzo to compress them.

Offline tomgru

  • Hero Member
  • *****
  • Posts: 1403
  • Karma: +18/-6
Re: Countdown timer plugin (UI5)
« Reply #169 on: August 01, 2015, 01:29:23 am »
I ended up doing a restore from a backup done yesterday, after deleted the countdown timer plugin today.  All seems normal now.  Maybe the app store came up in the meantime.   

Glad to know i'm not nuts. 

Offline a-lurker

  • Hero Member
  • *****
  • Posts: 872
  • Karma: +66/-8
Re: Countdown timer plugin (UI5)
« Reply #170 on: August 01, 2015, 03:08:13 am »
OK - I compressed the files and copied them across. However Vera kept deleting them each time it restarted; presumably in preparation for a newly downloaded set that it can't download (???). I turned off the plugin's auto update flag and everything came good. I note that an AltUI update was also queued up waiting to be downloaded.

Futzle - is this related, do you think?

http://forum.micasaverde.com/index.php/topic,10679.msg74451.html#msg74451

Offline kenray536

  • Full Member
  • ***
  • Posts: 119
  • Karma: +1/-2
Re: Countdown timer plugin (UI5)
« Reply #171 on: August 01, 2015, 12:15:42 pm »
I had the same problem. It kept on trying to update plugin #1588 which translated to the countdown timer plugin. It would cause my Vera to lock up after awhile and become unresponsive. When I would l login I would get an error message saying something similar to "Luup engine is taking longer than expected....."

I turned off the auto-update in the app settings and left the current version 8.0 installed. It's working fine for me now, but I was worried for a second. Does anyone know is version 8.0 the latest version?
Vera 3 1.5.677 - DSC Envisalink 3 - Wemo - Philips Hue - Harmony - Wink Hub - Sonos - Echo Vera Bridge - HomeKit Bridge - GE - AEON Labs - Evolve - Leviton - Schlage - Honeywell - Ring Doorbell - Eagle Rainforest Bidgely

Offline tdinardo

  • Full Member
  • ***
  • Posts: 150
  • Karma: +1/-1
Re: Countdown timer plugin (UI5)
« Reply #172 on: August 01, 2015, 03:10:41 pm »
20 minutes of frustration to get Vera to uninstall the add-in. Went to apps.mios.com to attempt a reinstall, but apps.mios.com still shows it as installed. Hopefully they unbreak the store sometime soon....

Offline futzle

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: Countdown timer plugin (UI5)
« Reply #173 on: August 01, 2015, 06:41:59 pm »
This is happening to me too.  I can't look at it now but I will in the next 24 hours.  I too did nothing to my Vera so something automatic has happened.  The irony...

Edit: Here's what I did to fix it. Essentially I dissociated my Countdown Timer devices from the plugin, and then removed references to the plugin from the app store list.  Finally I put the plugin's source files back onto the Vera.

  • SSH into Vera, run /etc/init.d/cmh stop to stop the Luup engine.
  • Decompress the user data by running pluto-lzo d /etc/cmh/user_data.json.lzo /tmp/bad_user_data.json
  • Transfer bad_user_data.json to a real computer, and edit it.
  • Change any instance of "plugin": "1588" to "plugin": ""
  • Completely remove the section { "Version": [...] "Title": "Countdown timer", "Icon": "plugins/icons/1588.png", [...] "id": 1588, "timestamp": [...] }, being sure that the braces match and the trailing comma is removed too.
  • Save as good_user_data.json.
  • Verify it with an online tool like jsonlint.com
  • Transfer good_user_data.json back to /tmp on the Vera.
  • SSH back to Vera, and run pluto-lzo c /tmp/good_user_data.json /etc/cmh/user_data.json.lzo
  • Restart the Luup engine with /etc/init.d/cmh start
  • Transfer the five source files (the ones with underscores here on GitHub) back to Vera through Apps > Luup Files.
  • Restart the Luup engine again through the web UI

With these steps, the plugin is now acting as if it were manually installed.  It's holding good for me after 15 minutes.

MCV: You need to fix the store.  Anyone who installs this plugin afresh will get stuck in this loop and blame me.
« Last Edit: August 02, 2015, 03:27:17 am by futzle »

Offline brettow

  • Jr. Member
  • **
  • Posts: 60
  • Karma: +1/-0
Re: Countdown timer plugin (UI5)
« Reply #174 on: August 02, 2015, 10:28:53 pm »
I had the same problem. It kept on trying to update plugin #1588 which translated to the countdown timer plugin. It would cause my Vera to lock up after awhile and become unresponsive. When I would l login I would get an error message saying something similar to "Luup engine is taking longer than expected....."

I turned off the auto-update in the app settings and left the current version 8.0 installed. It's working fine for me now, but I was worried for a second. Does anyone know is version 8.0 the latest version?

This worked for me also. ;D

Offline Don Diego

  • Hero Member
  • *****
  • Posts: 534
  • Karma: +300/-3
Re: Countdown timer plugin (UI5)
« Reply #175 on: August 03, 2015, 05:10:19 am »
I had the same problem. It kept on trying to update plugin #1588 which translated to the countdown timer plugin. It would cause my Vera to lock up after awhile and become unresponsive. When I would l login I would get an error message saying something similar to "Luup engine is taking longer than expected....."

I turned off the auto-update in the app settings and left the current version 8.0 installed. It's working fine for me now, but I was worried for a second. Does anyone know is version 8.0 the latest version?

This worked for me also. ;D

All--

 I had the same problem. I turned off the auto update and that worked for me too. Hope someone lets us know when the problem fixed.

   Don
Vera 3 (@1.5.622) (3); Vera Plus (2);
Trane/Schlage TStats (1); Schlage Deadbolt (2); Kwikset Lock (3);  GE 45602 Dimmer (14); GE 45603 Dimmer (17); HSM-100 (16); Everspring Siren (8), Everspring Temp/Humidity (4); HSM 200 (1)

Offline pierda

  • Sr. Newbie
  • *
  • Posts: 35
  • Karma: +1/-0
Re: Countdown timer plugin (UI5)
« Reply #176 on: August 08, 2015, 04:23:04 pm »
I had the same problem. It kept on trying to update plugin #1588 which translated to the countdown timer plugin. It would cause my Vera to lock up after awhile and become unresponsive. When I would l login I would get an error message saying something similar to "Luup engine is taking longer than expected....."

I turned off the auto-update in the app settings and left the current version 8.0 installed. It's working fine for me now, but I was worried for a second. Does anyone know is version 8.0 the latest version?

Also had the same problem and your fix worked - many thanks.

Offline tdinardo

  • Full Member
  • ***
  • Posts: 150
  • Karma: +1/-1
Re: Countdown timer plugin (UI5)
« Reply #177 on: August 09, 2015, 10:47:38 pm »
How do we get MCV to fix the store? It's ridiculous that this is still broken.

Offline TheKorn

  • Jr. Member
  • **
  • Posts: 51
  • Karma: +3/-2
Re: Countdown timer plugin (UI5)
« Reply #178 on: August 17, 2015, 06:17:05 am »
On another note (thank goodness I have auto-update turned off!), is restart no longer working?  I have a scene on a motion detector where I kick restart instead of start upon detection (to keep a lamp on longer than the motion detector would normally keep it on).  It I test the scene by hitting play with the timer off, the countdown timer starts at the top as expected.  But if I re-run the scene (which should reset the timer), it just keeps counting down where it is rather than resetting the timer.

Vera edge running version 8.0 of countdown timer and firmware 1.7.1248.

Thanks!

(I've also tried hitting cancel, delay 1s, then hitting restart...  same results.  Haven't tried longer delays between cancel & restart.)
« Last Edit: August 17, 2015, 06:27:39 am by TheKorn »

Offline futzle

  • Beta Testers
  • Master Member
  • *****
  • Posts: 3260
  • Karma: +192/-9
Re: Countdown timer plugin (UI5)
« Reply #179 on: August 17, 2015, 06:01:15 pm »
On another note (thank goodness I have auto-update turned off!), is restart no longer working?  I have a scene on a motion detector where I kick restart instead of start upon detection (to keep a lamp on longer than the motion detector would normally keep it on).  It I test the scene by hitting play with the timer off, the countdown timer starts at the top as expected.  But if I re-run the scene (which should reset the timer), it just keeps counting down where it is rather than resetting the timer.

Clicking the Restart button on the Countdown Timer device works for me.  Try that.  If that works, but the scene doesn't, then the problem is in the interaction between the scene and the timer device.  Also watch the Luup log while you run the scene and see if there are any errors reported.

Re-creating the scene might help.  I had some duplicate IDs in the JSON file of the plugin, and while I've fixed them all now, I don't know how a scene or trigger created before the fix will behave.